Audio Output Device Not Being Respected

It crashed, it is bugged, ...

Audio Output Device Not Being Respected

Postby XKfTDW3eGL5NJ72dMavc » Tue May 02, 2017 3:18 am

Hi all,

I'm having a spot of trouble with Mumble 1.2.19 on Windows 10. Mumble is always sending audio output to the Windows default output device, not the device listed in Audio Output under the Advanced Options.

For example, my default audio device is my speakers (S/PDIF-1) and I want Mumble to output to my headphones via S/PDIF-2. I select S/PDIF-1 as my system default output, and set S/PDIF-2 as the Device under Audio Output in Mumble. Mumble audio then continues playing through the system default of S/PDIF-1.

This configuration works in TeamSpeak3, Ventrilo, and games where I can set the audio output device away from default. I am sure its a mumble problem but I don't know why or where to start troubleshooting.

I've closed and re-opened Mumble with and without administrator privileges in every combination of output device I can think of, none of it works.
XKfTDW3eGL5NJ72dMavc
 
Posts: 3
Joined: Tue May 02, 2017 3:11 am

Re: Audio Output Device Not Being Respected

Postby XKfTDW3eGL5NJ72dMavc » Fri May 05, 2017 5:59 pm

I actually figured this out while my post was waiting approval - it is related to https://github.com/mumble-voip/mumble/issues/2667.

Actual incoming speech from the server is directed correctly, but anything playing through the TTS goes to system default.
XKfTDW3eGL5NJ72dMavc
 
Posts: 3
Joined: Tue May 02, 2017 3:11 am

Re: Audio Output Device Not Being Respected

Postby mkrautz » Sun Jun 04, 2017 10:13 am

mkrautz
Team member
Team member
 
Posts: 200
Joined: Wed Sep 23, 2009 4:57 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest

cron