SuperUser Issue - RedHat 7

It crashed, it is bugged, ...

SuperUser Issue - RedHat 7

Postby Phreak2600 » Mon Mar 28, 2016 7:49 pm

Greetings,

I'm hoping to find some assistance with an issue I'm having logging in under the SuperUser account, something that I expected to be much simpler than what I'm experiencing anyway.. Hopefully I'm just making a dumb mistake.

I've installed Murmur 1.2.15 on RedHat 7.2 (Maipo) manually in /usr/local/murmur

The server runs and I can login as a regular user without issue.

I've tried to reset the SuperUser password, and it appears successful:

Code: Select all
sudo ./murmur.x86 -ini /etc/murmur.ini -supw 1234
<W>2016-03-28 15:08:41.093 Initializing settings from /etc/murmur.ini (basepath /etc)
<W>2016-03-28 15:08:41.094 Meta: TLS cipher preference is "ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:AES256-SHA:AES128-SHA"
<W>2016-03-28 15:08:41.095 OpenSSL: OpenSSL 1.0.1s  1 Mar 2016
<C>2016-03-28 15:08:41.095 WARNING: You are running murmurd as root, without setting a uname in the ini file. This might be a security risk.
<W>2016-03-28 15:08:41.130 ServerDB: Opened SQLite database /etc/murmur.sqlite
<F>2016-03-28 15:08:41.151 Superuser password set on server 1


However when I try to login as "SuperUser" in Mumble I get:

Code: Select all
Server connection rejected: Wrong certificate or password.


My ini file is correct as listed in /etc/systemd/system/murmur.service

Code: Select all
[Unit]
Description=Mumble Server (Murmur)
Requires=network-online.target
After=network-online.target mariadb.service time-sync.target

[Service]
User=murmur
Type=forking
PIDFile=/var/run/murmur/murmur.pid
ExecStart=/usr/local/murmur/murmur.x86 -ini /etc/murmur.ini

[Install]
WantedBy=multi-user.target


Also for reference here are my murmur.ini settings:

Code: Select all
database=
dbus=session
icesecretwrite=
autobanAttempts = 10
autobanTimeframe = 120
autobanTime = 300
logfile=/var/log/murmur/murmur.log
pidfile=/var/run/murmur/murmur.pid
welcometext=""
port=64738
serverpassword=
bandwidth=130000
users=100
allowhtml=true
logdays=-1
suggestPushToTalk=true
#sslCert=
#sslKey=
#sslCiphers=EECDH+AESGCM:AES256-SHA:AES128-SHA
[Ice]
Ice.Warn.UnknownProperties=1
Ice.MessageSizeMax=65536


What in the world am I doing wrong here? Any suggestions would be appreciated!

Thanks!
Phreak2600
 
Posts: 2
Joined: Mon Mar 28, 2016 7:16 pm

Re: SuperUser Issue - RedHat 7

Postby fwaggle » Mon Mar 28, 2016 11:22 pm

What's the log file look like after it's started normally?

I'm not sure if it'll fix it or not, but it looks like you're starting Murmur as root with sudo, yet systemd (or whatever Redhat uses) is starting it as user "murmur". You don't have a database specified in the .ini file - where is the database ending up when "murmur" is the executing user instead of root?

What I think is happening is your "sudo ./murmur.x86 -ini /etc/murmur.ini -supw 1234" line is modifying the wrong database. If that's the case you can either specify the correct database explicitly in the .ini file and see if that helps, or try "sudo su -m murmur" then "./murmur.x86 -ini /etc/murmur.ini -supw 1234" then "exit" and see if that sets it.

But compare the log file from a normal start, specifically looking at the "ServerDB: Opened SQLite database" line to see - if they're both using /etc/murmur.sqlite this is not likely the cause.
Full disclosure: I run a semi-commercial Mumble host, and my opinions do not reflect the opinions of the Mumble project.
Avatar is stolen from here
User avatar
fwaggle
Team member
Team member
 
Posts: 212
Joined: Tue Oct 06, 2009 10:40 pm
Location: Australia

Re: SuperUser Issue - RedHat 7

Postby Phreak2600 » Tue Mar 29, 2016 2:46 am

Thanks for the quick response!

You were dead on! When I was running murmur.x86 as root to set the password it was writing /etc/murmur.sqlite when in fact the DB was /var/lib/murmur/murmur.sqlite.

I updated the path in the murmur.ini and it works perfectly.

Thanks so much!
Phreak2600
 
Posts: 2
Joined: Mon Mar 28, 2016 7:16 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 2 guests

cron