Issues hearing others in Mumble

It crashed, it is bugged, ...

Issues hearing others in Mumble

Postby Archiver » Wed May 25, 2016 6:18 pm

So, whenever I launch mumble, I can hear others fine, and they can hear me fine. Then, after about 10 seconds, I cannot hear anyone else... but they can still hear me just fine. I have reinstalled many times, tried different versions, settings, etc. Nothing seems to work. This happens no matter what server I am on. This has been happening to me for over a year (so I have just used Teamspeak). However, all of my friends are now back on Mumble. Please help!
Archiver
 
Posts: 4
Joined: Wed May 25, 2016 6:14 pm

Re: Issues hearing others in Mumble

Postby fwaggle » Wed May 25, 2016 10:41 pm

If you disconnect and reconnect to the server, does it work again, or does it require a restart of Mumble? If it's the latter, please disregard the entire of this post and respond back with more details (including output of dxdiag on Windows would probably be helpful).

While it would be a gross usability regression for most people, you could try forcing TCP mode in Mumble's options: "Configure"; "Settings"; Make sure Advanced is checked; "Network"; "Force TCP mode". This will have the unwanted side-effect that if your internet drops briefly, instead of getting "robot voices" and continuing on, your conversation will be delayed.

I suspect the most likely culprit is your router, as we've seen this a bit before. It sounds to me (as a complete stab-in-the-dark) that your router is expiring the UDP state and simply refusing to forward the incoming packets. Mumble *should* automatically figure out that it's UDP "connection" (that is, it's ability to send and receive UDP) has gone away and fall back to TCP automatically, but this doesn't always happen. There was some talk about making our automatic TCP fallback more robust, but I'm not sure if anything got done about that yet (I personally don't even know what's wrong with it yet).

Would you be able to sit on the server for a few minutes, try talking a couple of times, then right click your own username in the tree, pick "Information" and then take a screenshot of the results and post that? Particularly interested in the UDP statistics, but the box above it might be handy too.
Full disclosure: I run a semi-commercial Mumble host, and my opinions do not reflect the opinions of the Mumble project.
Avatar is stolen from here
User avatar
fwaggle
Team member
Team member
 
Posts: 212
Joined: Tue Oct 06, 2009 10:40 pm
Location: Australia

Re: Issues hearing others in Mumble

Postby Archiver » Thu May 26, 2016 10:55 pm

Thanks for the reply! If I reconnect to the server, it works again for a moment, but then cuts out again and I cannot hear anyone (but they still hear me). I've attached DXdiag and the screenshot you asked for. Sorry for the screenshot being so small and pixely... would only let me upload up to 256 kb. Thanks again!
Last edited by Archiver on Tue Jun 07, 2016 7:02 pm, edited 1 time in total.
Archiver
 
Posts: 4
Joined: Wed May 25, 2016 6:14 pm

Re: Issues hearing others in Mumble

Postby Archiver » Mon May 30, 2016 6:09 pm

Can anybody help me resolve this issue?
Archiver
 
Posts: 4
Joined: Wed May 25, 2016 6:14 pm

Re: Issues hearing others in Mumble

Postby Archiver » Tue Jun 07, 2016 7:02 pm

Great technical support here boys, will make me feel not so bad about not using mumble in the future! Thanks for wasting my time Faggle.
Archiver
 
Posts: 4
Joined: Wed May 25, 2016 6:14 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest

cron