SSL error while connecting to my server

It crashed, it is bugged, ...

SSL error while connecting to my server

Postby rene » Wed Mar 15, 2017 9:14 pm


First off thank you devs for this awesome tool!
In my 10 years working with Linux this is my first time I'm actually posting a question on a forum.

I have been running mumble server quite some time now and i love it, works great. But here is where my trouble starts. Recently i upgraded my server to new hardware and did a clean install of Ubuntu server 16.10 (couldn't use 16.04 LTS due to a very new processor).

So i did a clean install of mumble-server, all went fine but I can't connect to it and I've been pulling my hair out trying to find out why.

Running mumble server version: murmurd -- 1.2.18-1~ppa1~yakkety1

Output of murmurd:
Code: Select all
root@har:/home/administrator# murmurd -v -fg
<W>2017-03-15 21:59:33.889 Initializing settings from /etc/mumble-server.ini (basepath /etc)
<W>2017-03-15 21:59:33.891 Meta: TLS cipher preference is "ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:AES256-SHA:AES128-SHA"
<W>2017-03-15 21:59:33.891 OpenSSL: OpenSSL 1.0.2g  1 Mar 2016
<C>2017-03-15 21:59:33.891 Successfully switched to uid 115
<W>2017-03-15 21:59:33.960 ServerDB: Opened SQLite database /var/lib/mumble-server/mumble-server.sqlite
<W>2017-03-15 21:59:33.962 Resource limits were 0 0
<W>2017-03-15 21:59:33.962 Successfully dropped capabilities
<W>2017-03-15 21:59:33.964 DBus registration succeeded
<W>2017-03-15 21:59:33.966 MurmurIce: Endpoint "tcp -h -p 6502 -t 60000" running
<W>2017-03-15 21:59:34.066 Murmur 1.2.18 (1.2.18-1~ppa1~yakkety1) running on X11: Ubuntu 16.10: Booting servers
<W>2017-03-15 21:59:34.077 1 => Server listening on [::]:64738
<W>2017-03-15 21:59:34.090 1 => Announcing server via bonjour
<W>2017-03-15 21:59:34.102 1 => Not registering server as public
<W>2017-03-15 21:59:34.103 Object::connect: No such slot MurmurDBus::userTextMessage(const User *, const TextMessage &)
<W>2017-03-15 21:59:41.459 1 => <1:(-1)> New connection:
<W>2017-03-15 21:59:41.545 1 => <1:(-1)> Client version 1.2.19 (Win: 1.2.19)
<W>2017-03-15 21:59:41.560 1 => Starting voice thread
<W>2017-03-15 21:59:41.569 1 => CELT codec switch ffffffff80000010 0 (prefer ffffffff80000010) (Opus 1)
<W>2017-03-15 21:59:41.593 1 => <1:SuperUser(0)> Authenticated
<W>2017-03-15 21:59:41.605 1 => <1:SuperUser(0)> Connection closed: The remote host closed the connection [1]
<W>2017-03-15 21:59:41.612 1 => Ending voice thread

Output of mumble windows client version 1.2.19
Code: Select all
[21:59:41] Connecting to server
[21:59:41] Connected.
[21:59:41] Server connection failed: Error while reading: error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac.

Trying to connect to it using a android phone for instance also fails. "connection refused"

Can someone point me in the right direction?
Posts: 2
Joined: Wed Mar 15, 2017 8:54 pm

Re: SSL error while connecting to my server

Postby rene » Sat Apr 01, 2017 7:44 pm

Okay, I've been digging deeper to find out what is happening and it seems related to my motherboard.

What i did was: (I did this with both the server and desktop version)
- Clean install of ubuntu 16.10 as virtual machine in virtualbox, installed mumble-server, works fine.
- Took my server offline and grabbed a spare hdd and did a clean install of ubuntu 16.10 using the new motherboard, installed mumble-server, doesn't work, same exact error as in my original post.

I ran exactly the same commands on all of these clean installs:
apt-get update
apt-get install ssh
apt-get install mumble-server

I tried this with both ubuntu server and ubuntu desktop and the results are the same and consistent. As i suspected it has something to to with my motherboard (Asrock J3455-ITX) with an Intel quad core J3455. This processor is only supported in the newest kernel 4.8 but maybe there is still a bug there.

Problem now is I have no more information as I gave in the first post. Seems that some action is failing but I have no idea what action and what that action is doing and what that action needs.

At least i know now I didn't screw something up on my server, wasn't looking forward to reconfigure everything again. :D
Posts: 2
Joined: Wed Mar 15, 2017 8:54 pm

Re: SSL error while connecting to my server

Postby kissaki » Tue Apr 04, 2017 9:08 am

<W>2017-03-15 21:59:34.103 Object::connect: No such slot MurmurDBus::userTextMessage(const User *, const TextMessage &)

Did you change the Mumble server configuration?

Do you register a dbus script?

Try disabling dbus in the server configuration.

Are you using your own cert? Maybe it’s broken?

See also, potentially an openssl issue - which version of Mumble server and OpenSSL is that?

The client code line in question: MainWindow.cpp#L2962. No ServerHandler QSslError (no SSL error that Qt handles on QSocket as a signal sslErrors), no SSL version mismatch.
MumPI: Your Mumble Web Interface in PHP
User avatar
Team member
Team member
Posts: 1234
Joined: Sat Jan 09, 2010 12:15 pm

Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest