Mumble can't find CELT library in Linux

It crashed, it is bugged, ...

Mumble can't find CELT library in Linux

Postby realnc » Tue Feb 09, 2010 8:12 pm

Mumble is unable to find libcelt.so on Linux. CELT (0.7.1) installs these libraries on Linux:

/usr/lib/libcelt0.a /usr/lib/libcelt0.so /usr/lib/libcelt0.so.0 /usr/lib/libcelt0.so.0.0.0

However, Mumble searches for "libcelt.so.*", not "libcelt0.so.*"

Gentoo is patching Mumble to make it work. I believe it's good practice for patches to go upstream, and I don't think any distro did that yet. Therefore, I am attaching the patch.

Edit:
I was not able to attach the patch (forum doesn't allow files with a .patch extension.) I've put it here:

http://pastebin.ca/1791771
realnc
 
Posts: 18
Joined: Tue Feb 09, 2010 8:07 pm

Re: Mumble can't find CELT library in Linux

Postby realnc » Tue Feb 09, 2010 8:34 pm

Please ignore this post. I was not aware that this patch has actually made it into Mumble 1.2.2 (released today.) Sorry.
realnc
 
Posts: 18
Joined: Tue Feb 09, 2010 8:07 pm


Return to Technical

Who is online

Users browsing this forum: Bing [Bot] and 3 guests