server connection failed: unable to write

It crashed, it is bugged, ...

server connection failed: unable to write

Postby argantonis » Thu Mar 25, 2010 11:46 pm

Hello all.
I've connected to 2 mumble servers now, after a while it says 'server connection failed: unable to write'.
This is a bit of a cryptic error message to me, what is going on here? It doesn't seem to be the server itself since it happened to me on 2 servers now.
Sometimes I can connect for a few hours or even days, I got a pretty good 'run' last time when I ran mumble with admin rights, but it always happens eventually.
If I uninstall everything (I think including preferences too) and then reinstall it starts working again.
I tried the latest stable 1.2.2 and the beta too. I'm running Vista 64 bit.
argantonis
 
Posts: 3
Joined: Thu Mar 25, 2010 11:44 pm

Re: server connection failed: unable to write

Postby argantonis » Sat Mar 27, 2010 12:53 am

So, anyone that knows anything about this exception? Or tell me where I can get help? I posted on 3 different forums so far.
argantonis
 
Posts: 3
Joined: Thu Mar 25, 2010 11:44 pm

Re: server connection failed: unable to write

Postby slicer » Sat Mar 27, 2010 10:14 am

This happens if you have extended loss of connectivity to your server, long and serious enough that the TCP session is lost, or the TLS session fails integrity. The most likely suspect is your internet connection, or you might have some undesirable software that mucks around with your connections.
User avatar
slicer
Team member
Team member
 
Posts: 3
Joined: Wed Sep 23, 2009 2:33 pm

Re: server connection failed: unable to write

Postby argantonis » Wed Mar 31, 2010 4:55 pm

slicer wrote:This happens if you have extended loss of connectivity to your server, long and serious enough that the TCP session is lost, or the TLS session fails integrity. The most likely suspect is your internet connection, or you might have some undesirable software that mucks around with your connections.


That doesn't seem to be the case. The most evidence I have for this is that once it stops working, I cannot reconnect at all anymore, it will keep giving me that message. But when I uninstall and reinstall Mumble, I can just do anything like I used to, for anything from a few hours to a few days. Also this happend to me on both servers I've used and I have a very stable internet connection.



Edit: does Mumble write to some kind of log file somewhere? This is one of the reasons I could come up with that makes it work again after reinstalling, some log file running full and being deleted.
argantonis
 
Posts: 3
Joined: Thu Mar 25, 2010 11:44 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 6 guests