Overlay won't compile

It crashed, it is bugged, ...

Overlay won't compile

Postby meyou9 » Tue Apr 20, 2010 3:49 pm

I have been able to build the new 1.2.2 of mumble client, and successfully connect to/use a 1.2.2 server.

I cannot seem to find the mumble-overlay binary. It did not compile and I do not understand why.
Are there any special config flags I need to force building of this binary?
meyou9
 
Posts: 2
Joined: Tue Apr 20, 2010 3:47 pm

Re: Overlay won't compile

Postby hacst » Tue Apr 20, 2010 4:15 pm

If we are talking about Windows or Linux: The mumble overlay is compiled with the client. If the mumble_ol.dll/libmumble.so.1 isn't present your compile wasn't complete. Look for error messages in the build log.

Be aware that on linux the mumble-overlay thing you call your application with is a script (located in the scripts/ folder of the repository) which only LD_PRELOADS the lib.

I have no clue about MacOSX though, you'd have to ask krejler.
hacst
Team member
Team member
 
Posts: 339
Joined: Wed Sep 23, 2009 4:28 pm

Re: Overlay won't compile

Postby meyou9 » Tue Apr 20, 2010 5:11 pm

dd0t wrote:Be aware that on linux the mumble-overlay thing you call your application with is a script (located in the scripts/ folder of the repository) which only LD_PRELOADS the lib.



Thank you, that was the piece of information I was missing.
The install guide is extremely lacking in how to actually install the application after compile.
meyou9
 
Posts: 2
Joined: Tue Apr 20, 2010 3:47 pm

Re: Overlay won't compile

Postby hacst » Tue Apr 20, 2010 6:17 pm

:D How about extending it? Everyone can register a wiki account (there's a three day cooldown period to fend off spam though).

We are always grateful for contributions to the wiki, we simply can't (and honestly don't want^^) to maintain everything in there.
hacst
Team member
Team member
 
Posts: 339
Joined: Wed Sep 23, 2009 4:28 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 6 guests

cron