Technical Latest Topicsforum/6-technical/Technical Latest TopicsenMumble Launcher Error-1 "Unable to config environment"topic/18330-mumble-launcher-error-1-unable-to-config-environment/ Hello smarty-folk!

As of this morning, when I open Mumble, this appears every time.
Any work-arounds? Was using windows 10 while it failed. Updated to windows 11 today just in case that helped (didn't).
I've searched online and found nothing.
Oddly enough, when I search Mumble's properties it doesn't show the version # (hence I typed in a BS #1.4.287 just so this post would be granted).

TIA for your help!!



18330Mon, 10 Apr 2023 23:51:36 +0000
mic not being picked up by mumble at alltopic/18256-mic-not-being-picked-up-by-mumble-at-all/ i have been trying to get mumble to pick up my mic i have made sure that it is broadcasting to my computer fine, just mumble that it will not pick it up.

audio set up is a blue yeti usb going in to Nvidia broadcast to voicemeeter banana 

works for discord and stream stuff just not mumble

18256Sun, 02 Apr 2023 03:09:06 +0000
Focusrite ASIO/Extreme low latency Supporttopic/18252-focusrite-asioextreme-low-latency-support/ Hello, may your days be well!


I'm having quite the awful time configuring ASIO for my focusrite 8i6, which I can use spdif as an output, but it seems to crash after applying, no matter what settings I use. It's awful inconvenient.


If someone could help me utilize all of my inputs with WASAPI, that would help me greatly as well, especially as I have read very little positive about ASIO support. 


My use case is that me and my friend wish to play music across the country with as little of delay as possible, and we have paid for high bandwidth, low-ping internet connections to do this plus video, and we have built the servers to be running on multiple machines so as to reduce processing times. 


I have reduced the latency to a very small amount, but it does affect timing of instruments. 


Please know that we understand that noise is not going to be filtered out and this is not for studio level recording. I have found a good balance of quality versus latency at 44kb/s, and have gone as far down as 8kb/s and had the same level of delay - in loopback tests.  


This may be an engineering/physics level problem, and may not actually ever work, but I know there is a community of musicians who would benefit from extreme low latency audio sessions and would like my voice to be heard for that reason alone. 


ASIO may be the wrong direction all together, and I'm fine being pointed in the right direction, so please excuse my lack of technical knowledge and know that I have taken a scientific level of testing to find the best options in Mumble as they're presented to me. 


Thank you for any responses. 


18252Sat, 01 Apr 2023 04:25:51 +0000
Push to talk activation not possible on Catalina 10.15 - what to do?topic/17978-push-to-talk-activation-not-possible-on-catalina-1015-what-to-do/ Any ideas how to solve the problem? 


The activation of push to talk does not work. Whatever I try to activate a key on my keyboard, there is no response. as if my keyboard is not connected. what is the the problem here, and how can I solve it? Thanks for help!! 

17978Sun, 19 Mar 2023 20:07:57 +0000
One member in our mumble group sound always distorts but only to metopic/17955-one-member-in-our-mumble-group-sound-always-distorts-but-only-to-me/ No one else in our group experiences it.  He will sound normal then all of a sudden go up literally 75dB and become distorted, not robotic.  It's so bad I have to take my headphones off.  I have reinstalled, run wizard, messed with settings but still happening.  Does not happen on Discord.  Any help greatly appreciated.  

17955Sat, 18 Mar 2023 04:01:00 +0000
Mumble link but I can still hear everyonetopic/17965-mumble-link-but-i-can-still-hear-everyone/ Hi,

So here is my problem. I'm on a multiplayer server with mumble, I link and have all the same mumble setting has everyone. It say that it is link but I can still hear eveyrone. Everyone can here me fine and hear me only when at the right distance in our setting. I think the problem is due to me having a steelserie bluethooth headset (artic 7) since I saw that some people seem to have the same problem with bluethooth headset but nobody describe the solution but people say that they found it. So I was wondering if anyone knew how to fix that. I apologize for my broken english since I normaly talk another language. 

Thank you in advance.

17965Sat, 18 Mar 2023 19:36:54 +0000
Installing Mumble server on windows 10topic/17850-installing-mumble-server-on-windows-10/ I am trying to create a server, and have downloaded and installed mumble_server-1.4.287.x64.  Following through the instructions from the wiki

and I get as far as - Set Up Server - Configuring ini File.  I can't find any ini file at all.  I realize the instructions seem to be for an earlier version, but I don't know where to go from here. 


If I click on the application icon, it runs in the system tray, but I don't know how to get at any of the settings.


Can anyone help?



17850Tue, 07 Mar 2023 20:54:51 +0000
1.4 conflict with flight control rudder pedalstopic/14467-14-conflict-with-flight-control-rudder-pedals/ With the update to 1.4, Mumble stopped working for me.  After a good deal of methodical troubleshooting (including everything up to new SSDs and clean Windows installation), I have identified that the issue is caused by my flight control rudder pedals (this machine is used primarily for flight simulation).  The pedals are connected to the computer via USB.  If the pedals are plugged in to the computer (either via a USB hub or directly to the mobo), Mumble freezes on startup with the main window white and unresponsive.  If I start Mumble with the pedals unplugged (or unpowered via a hub) Mumble starts and works normally.  If Mumble is running normally and I plug the pedals in, Mumble freezes in a hot-mic setting, is unresponsive to any input, and must be closed via task manager.  The pedals do not utilize any software; they were manufactured by Slaw Device (, a boutique Polish flight equipment builder (I have emailed them with this issue as well).  I have tried checking and unchecking 'Enable shortcuts in privileged application,' 'Enable GKey,' and 'Enable XInput,' with no change to the issue.  Any ideas to address this would be greatly appreciated.  Thank you.

14467Sun, 28 Aug 2022 19:37:47 +0000
Slow Server Connections(Time)topic/17173-slow-server-connectionstime/ Hi all, tried searching and couldn't find anything out there so thought i would post here. Is there a way to increase the connection speed time to server? On any of the new mumble versions, it takes ~10 seconds to just connect to the server, but on older version of mumble I have from years ago(1.2.16), it's like instant. If there isn't a way to make it faster, is it fine to just use the older version? This is on Windows 10.

17173Sun, 15 Jan 2023 04:55:20 +0000
Problems on running the code and the demo app locallytopic/17151-problems-on-running-the-code-and-the-demo-app-locally/ Hello, I'm trying to create a web application using React JS that has a push-to-talk (PTT) feature on it.
One of the technologies that we will use is Mumble.


The demo on this repository is working fine.
I tried to run the repository on my local computer but got some different errors.


Installation Errors


I cloned and tried to install all of the libraries on the root folder of the repository using the `npm install` command on my local computer with Windows OS and Node JS v16 but I got this error below.

verbose stack Error: command failed
verbose stack     at ChildProcess.<anonymous> (C:\Users\LENOVO\AppData\Roaming\nvm\v16.18.0\node_modules\npm\node_modules\@npmcli\promise-spawn\lib\index.js:63:27)
verbose stack     at ChildProcess.emit (node:events:513:28)
verbose stack     at maybeClose (node:internal/child_process:1100:16)
verbose stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:304:5)
verbose pkgid mumble-client-websocket@1.0.0
verbose cwd C:\Users\LENOVO\AppData\Local\npm-cache\_cacache\tmp\git-cloneZtPlJ2
verbose Windows_NT 10.0.22621
verbose node v16.18.0
verbose npm  v8.19.2
error code 1
error path C:\Users\LENOVO\AppData\Local\npm-cache\_cacache\tmp\git-cloneZtPlJ2
error command failed
error command C:\WINDOWS\system32\cmd.exe /d /s /c npm run compile
verbose exit 1
timing npm Completed in 8638ms
verbose code 1


Then I switched the Node JS version using the NVM from v16 to v14.
I tried to install all of the libraries on the repository using the `npm install` command again but then got another different error.

verbose stack Error: mumble-web@0.5.1 prepare: `rm -rf dist && npm run build`
verbose stack Exit status 1
verbose stack     at EventEmitter.<anonymous> (C:\Users\LENOVO\AppData\Roaming\nvm\v14.21.2\node_modules\npm\node_modules\npm-lifecycle\index.js:332:16)
verbose stack     at EventEmitter.emit (events.js:400:28)
verbose stack     at ChildProcess.<anonymous> (C:\Users\LENOVO\AppData\Roaming\nvm\v14.21.2\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
verbose stack     at ChildProcess.emit (events.js:400:28)
verbose stack     at maybeClose (internal/child_process.js:1088:16)
verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:296:5)
verbose pkgid mumble-web@0.5.1
verbose cwd D:\\Works\Others\Lacak-and-Valid\Exercises\React-Js\mumble-web-2
verbose Windows_NT 10.0.22621
verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "i"
verbose node v14.21.2
verbose npm  v6.14.17
error code ELIFECYCLE
error errno 1
error mumble-web@0.5.1 prepare: `rm -rf dist && npm run build`
error Exit status 1
error Failed at the mumble-web@0.5.1 prepare script.
error This is probably not a problem with npm. There is likely additional logging output above.
verbose exit [ 1, true ]


I tried to delete the `"prepare": "rm -rf dist && npm run build",` code (line 45) on the package.json file.
I didn't know whether deleting the code would have an impact on running the app later or not.
I also searched on the internet and found this answer to clear the npm cache, regenerate the package-lock.json file, and delete the node_modules folder.
I did all of them then I ran the "npm install" command again.


This time, there was no error.


Runtime Errors


Continuing the previous section, I tried to run the root of the repository by running the `npm run watch` command.
I didn't know whether the was correct or not because I usually enter the `npm start` command to run a React JS locally.
I didn't see any port configured on the package.json file so I opened the `localhost:8080` address on my browser.
Unfortunately, there was nothing there. The browser said `This site can’t be reached. localhost refused to connect.`

<h3>The App Folder</h3>

Continuing the previous section, I tried to run the index.html file on the `app` folder by double-clicking on the file.
It seemed that the app crashed because I saw there was an error on the browser console as seen in this screenshot below.
Here is the error message:
Uncaught SyntaxError: Cannot use import statement outside a module (at index.js:1:1)




I want to learn how to create the demo ( on the repository. My questions are:
1. Which one is the source code of the demo app? Is it from the root folder of the repository or the app folder?
2. Continuing the first question, how to install all of the required dependencies for the demo app locally?
3. Continuing the first and second questions, how to run the demo app locally?

17151Thu, 12 Jan 2023 10:42:10 +0000
Sound gets to some clients, not otherstopic/17006-sound-gets-to-some-clients-not-others/ I am using 1.3.0 server on Debian 10 with 1.3.4 on Ubuntu 20.04 and 22.04 with Mumla 3.6.3 (mumble 1.2.5) on Android 11. Sound from 1.3.4/20.04 goes to 1.3.4/22.04. Sound from 1.3.4/22.04 goes to 3.6.3/11. Sound from 3.6.3/11 goes to 1.3.4/20.04 and 1.3.4/22.04. But! Sound does not go from 1.3.4/20.04 to 3.6.3/11


This was with the Play store version. I switched to the fdroid version... still 3.6.3/1.2.5, but seemingly a newer build? Then things started working. I'm mentioning this for others who may hit similar issues. I guess it would be of interest to the Mumla developer as well, if they want to do a rebuild for the play store? If I have time, I'll file a bug/check the bug tracker. It'd also be interesting if anyone can reproduce it (or not) with the same client/server set up.



17006Fri, 30 Dec 2022 09:28:51 +0000
Docker/Portainer Configuration Questionstopic/16738-dockerportainer-configuration-questions/ If I use the docker-compose script, the install goes as it needs to run. I can even make connections. I tried to remove the "expose 6502 "(default ICE interface??). That throws errors. I have not been able to figure out how to configure/setup some of the locations (databases, logs, config,etc.), passwords, etc.  It seems like all of the instructions are for server/PC based installs (like modifying the ini). 


So if I go to, there are no links to the docker image (that I have found). if you go to the docker-hub, there are 220 packages. Not easy to find the official version 😉 So for those of us new to all of this, not a lot of help. 


Looking for guidance.

16738Tue, 20 Dec 2022 02:07:59 +0000
Mumble not connectedtopic/16693-mumble-not-connected/ Hi all, I have been using Mumble for about 2 years now, without issues. Since the last update with 'mumble_client-1.4.287.x64' it is not connecting to the server I normally connect to. I tried reinstalling the old version, the new version 3 times, upgrading the C++ redistributable, contacted the server host who said I am not blocked by him and I am not 'getting out' (he does not see me connecting).

I have checked the firewall, and Mumble is in the allowed list of apps. I recently installed another virus scanner (from Norton to ESET) and specifically set Mumble in the allowed list of the firewall, so that can't be the reason.


Extra information:


When I reinstall Mumble, all the previous settings are already there (Favorite channel, port), I tried removing this with CCleaner but that did not work. After reinstall I never entered a password for the server, and I don't see an option anywhere to do that (or check the password).


I have Windows 10 Home, version 21H2, 64-bit operating system, x64-based processor


Anyone has an idea what might be the problem? I don't have issues with my internet or other apps, it is just Mumble.


Thanks in advance for any help!

16693Fri, 16 Dec 2022 13:32:55 +0000
IPv6 problemstopic/1809-ipv6-problems/Hi,

I'm running a mumble server for a few of my friends, and I have noticed that those who connect to it with ipv6 experiences some problems. Everything works fine for hours/days, but sooner or later they can no longer hear or speak. They can write and read in chat, but there is no sound and the icons do not light up when others speak. Reconnecting to the server fixes the problem, but it always returns after a day or so. My workaround is to just disable ipv6 for the server, since the ipv4 clients can stay connected for weeks with no problems, but I am wondering if it is a problem other have or if there is something specific with my setup. The server log does not list any changes for the affected client either.

1809Fri, 18 Sep 2015 22:57:36 +0000
I don't know how to fix SSL Version Mismatch Errortopic/16453-i-dont-know-how-to-fix-ssl-version-mismatch-error/ Hey, im trying to fix this SSL Version Mismatch Error that says "This server is using an older encryption standard, and is no longer supported by modern versions of Mumble." I have looked all on the web but can't find anything that works. I am trying to add proximity voice to my 1.19.2 minecraft server but whatever I try doing, it always puts that message. Can someone please help me. (I am using shockbyte hosting for my servers)

16453Wed, 30 Nov 2022 21:18:39 +0000
Mineraft proximity chat from behind!topic/16106-mineraft-proximity-chat-from-behind/ Hello!

Me and my friends installed Mumble 3 days ago. We did setup everything right and it works! But when you turn around, so you look oppsite to the other player, the person is REALLY quiet even if you stand right next to him/her!

How can you fix it?
I hope you are doing well and have a great week/day!

Vincent Schaefer

16106Wed, 02 Nov 2022 14:36:24 +0000
Server is incredibly quiettopic/16108-server-is-incredibly-quiet/ Hello everyone,


I'm having an issue with our mumble server being much quieter than other servers that I've tested. I've been on this for weeks and thought it was the clients at first but I tested out a public server this morning with those same clients and had no issues with volume.


Are there settings I can change within the mumble-server.ini file that boosts user volume or is there something else that might be the cause of this?


Environment is a Google Cloud VM running Ubuntu Server 20.04 with the most recent version of the mumble server.

16108Wed, 02 Nov 2022 17:10:07 +0000
External PTT button.topic/15733-external-ptt-button/ Hello all,


Can someone tell me what the possibilities are for an external Bluetooth PTT button. For example, is there a possibility with BT HSP/HFP to use the play/pause button as a PTT button. Or are there commands that can generate a PTT with SSP (serial communication).

In short; what are the possibilities to give a PTT via Bluetooth. Preferably not with BLE.

15733Tue, 11 Oct 2022 06:02:21 +0000
mumble docker not registering in public server listtopic/15116-mumble-docker-not-registering-in-public-server-list/ Hello there guys. I hope i can have some guidance in an issue i am facing. I have in a server the official mumble docker image. It runs good, i have botamusique on it and i can access it through internet with the proper port forwarding in my router. the problem is that i can't have my server registered in the public server lists. if i check the logs of my container it says the following:


<W>2022-09-07 12:01:37.712 1 => <0:(-1)> New connection:

<W>2022-09-07 12:01:37.955 1 => Registration failed: Host requires authentication

<W>2022-09-07 12:01:38.147 1 => <0:(-1)> Connection closed: The TLS/SSL connection has been closed [1]


i haven't been able to figure out what i am missing. i have filled the required configuration for server registration. thanks in advance for any guidance or help.

15116Wed, 07 Sep 2022 12:17:12 +0000
Monitoring server connection and logstopic/15538-monitoring-server-connection-and-logs/ How can I monitor the server logs in real time?


Thanks, Jim Darrough

15538Mon, 26 Sep 2022 14:35:55 +0000
Voice command activate/deactivate audio transmission using Plantronics Voyager 5200topic/15478-voice-command-activatedeactivate-audio-transmission-using-plantronics-voyager-5200/ Hello,


The Plantronics Voyager 5200 has a voice command option to answer calls using voice command. Is it possible to program a script to use voice command to activate and deactivate the audio transmission in Mumble?


The use case is so that the mic can be enabled without the use of fingers and also without transmitting all speech. This would make it possible to make noise while listening to the channel, and initiate response by starting with a code word to activate mic.

15478Tue, 20 Sep 2022 18:41:01 +0000
Server Version Reporttopic/15378-server-version-report/ Hi folks,


Not meaning to be a pain, but there still seems to be a version report issue. I assume in 1.4.287 it didn't get fixed. Server reports 1.4.255.


15378Wed, 14 Sep 2022 17:48:22 +0000
Double spacingtopic/15380-double-spacing/ Folks, is there any way to fix the "overwrite" bug issue without using double spacing in display lines? The single line spacing was more usable to a screen that has a lot of activity.

15380Wed, 14 Sep 2022 20:40:28 +0000
Chat links are unclickabletopic/14334-chat-links-are-unclickable/ Idk if my server has something wrong, but everyone who updated client to 1.4.274 can't click any url posted in any chat. Btw, server is updated as well. Any suggestion for what's hapenning?

14334Fri, 26 Aug 2022 22:18:37 +0000
Small Bugs found on 1.4.274topic/14222-small-bugs-found-on-14274/ Folks,

Upgraded to the latest client and server. Noticed an occasional bug where text in the activity window overlaps. Its often enough I suspect others have seen it as well. Attaching a graphic below.


Also, I noticed that the latest 1.4.274 murmur is showing 1.5.18 in the public server listings drop down on hover.


Otherwise, all seems good. 🙂




14222Thu, 25 Aug 2022 13:31:12 +0000