Official Mumble VoIP Forums

What kind of audio device are you using?
Check if you have exclusive access to audio devices enabled in the Mumble client (audio input and out put settings, you may have to enable advanced settings). Also try disabling QoS in the network settings.
Please verify that your myfritz.net dynamic entry does not point to invalid information, e.g., a likely useless IPv4 address through an A record.

CNAMEs, undesirable as they may be, do not seem to be an issue for the client's DNS resolver (tested on 1.2.10).
Please provide your concrete setup. If you don't want to provide actual hostnames or addresses, you can replace actual data with symbolic values, e.g., hostnames with blah.example.com, IPv6 addresses with some kind of local address (e.g., something under fec0::/10). Just be precise enough to describ...
Sounds like a corrupted client database. Try moving or renaming the file before starting the client; the location is described here: http://wiki.mumble.info/wiki/Client_Settings
What happens when you set the audio device to 16bit?
This sounds a lot like a general audio misconfiguration. Are other applications also using pulseaudio, or are (some) using ALSA directly?
Without a frontend, I'd say stop the server and then use the sqlite commandline tool or a DB browser to delete the settings in question.
Once a setting is in the server database, the server will not react to ini changes for that setting anymore.
By default, applications do not have permission to write to Program Files (edit: and that's a good thing, don't change that by modifying ACLs in there!). You should modify your ini to put the database in a location the user running murmur has write access to.