Jump to content
Mumble forums

Help: deny entry into parent, but allow in sub group


yahmobethere
 Share

Recommended Posts

I am having tremendous problems figuring this out and I am blaming it on the @all that is permanent in the root and can not be altered.


What I have is this:


Root

-Channel A

--Channel B

--Channel C


What I want to do is make it so no one (except admins for the whole server) can enter Channel A, but anyone can enter and talk in Channel B or C. This is purely for organizational purposes. I want Channel A to be just a organizational name for the sub groups and not a place to go and talk.


In Channel A I have the default @all and then an @all that denies everything. Inherit ACLs is unchecked and under context for the @all I added, "applies to sub-channels" is unchecked. That should mean the deny all won't be present in Channel B or C. Further, the default @all is auto inherited into Channel B and C, which allows for all to enter and talk.


Regular, non-admin people are not able to enter Channel A, so that is working. The problem is that they can't enter Channel B or C either.


Can anyone help me figure out what I need to add, check, etc that would all all people to not enter A, but enter and talk in B and C?

Link to comment
Share on other sites

  • 2 weeks later...
  • Administrators

Check the help-text for the traverse permission.

(Shift-F1 / “?” icon then click on checkbox)

https://github.com/mumble-voip/mumble/blob/master/src/mumble/mumble_en.ts#L2645


“If a user is denied this privilege, he will be unable to access this channel and any sub-channels in any way, regardless of other permissions in the sub-channels.”

So I guess you have denied this for Channel A, which you do not want to do in your case.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...