Jump to content
Mumble forums

[SOLVED] MumPI Issue


wowakan
 Share

Recommended Posts

ok here is what I have

Murmurd 1.2.5

Ice 3.5.1

CentosOS 6.5


I can log into the Mumble server with no problem. However Ice is giving me all sorts of problems.


Ican see that Ice is running:2014-02-23 19:15:15.120 ServerDB: Opened SQLite database /opt/mumble-server/mumble-server-default.sqlite

2014-02-23 19:15:15.125 MurmurIce: Endpoint "tcp -h 23.31.67.19 -p 6502" running


However I get a blank screen here:http://www.redtalkers.com/MumPI/user/


We are trying to get this up and running and could use all the help that we can get please.


We are going to try and start using this for TBI, Spinal Cord Injury, and D.D. folks. There would be a total of 17 Mumble V Servers for the 17 regions in the USA. Each one would hold 56 to 157 clients per server.


thank you.

Link to comment
Share on other sites

ok opened up error reporting in my php.ini and this is what I am getting:


Warning: require_once(SliceChecksumDict.php): failed to open stream: No such file or directory in /var/zpanel/hostdata/zadmin/public_html/redtalkers_com/MumPI/classes/Murmur.php on line 22 Fatal error: require_once(): Failed opening required 'SliceChecksumDict.php' (include_path='.:/usr/share/php') in /var/zpanel/hostdata/zadmin/public_html/redtalkers_com/MumPI/classes/Murmur.php on line 22

Link to comment
Share on other sites

Spoke to soon got that error fixed. Now I get this:


[Debug: Error was added] Could not connect to Ice.

Either your server is not running or it is not running with Ice. Check your configuration.


Could not connect to Ice.

Either your server is not running or it is not running with Ice. Check your configuration.


It's strange because I can see that Ice is in fact running.


Wanted to add this:

2014-03-01 12:51:02.233 Initializing settings from /opt/mumble-server/mumble-server-default.ini (basepath /opt/mumble-server)

2014-03-01 12:51:02.235 Adding 1 CA certificates from certificate file.

2014-03-01 12:51:02.235 OpenSSL: OpenSSL 1.0.0l 6 Jan 2014

2014-03-01 12:51:02.280 ServerDB: Opened SQLite database /opt/mumble-server/mumble-server-default.sqlite

2014-03-01 12:51:02.284 MurmurIce: Endpoint "tcp -h 23.31.67.19 -p 6502" running

2014-03-01 12:51:02.300 Murmur 1.2.5 (1.2.5) running on X11: CentOS release 6.5 (Final): Booting servers

2014-03-01 12:51:02.411 1 => Server listening on [::]:64738

2014-03-01 12:51:02.520 1 => Announcing server via bonjour

2014-03-01 12:51:02.611 1 => Not registering server as public

2014-03-01 12:51:02.612 Object::connect: No such slot MurmurDBus::userTextMessage(const User *, const TextMessage &)

Link to comment
Share on other sites

  • Administrators

So the mumble server instance starting is announcing that it is binding ice.

Could you check your *system* for open, listening ports, that ice is actually bound and active?

On GNU Linux should be something like `netstat -p | grep 6502`


So your Ice binds to 23.31.67.19.

Did you set up MumPI to use that IP as the ICE connection target host? (The default is localhost 127.0.0.1.)

Link to comment
Share on other sites

command:

netstat -apn | grep 6502


returns:

tcp 0 0 127.0.0.1:6502 0.0.0.0:* LISTEN 4431/murmurd


# If you want to use ZeroC Ice to communicate with Murmur, you need

# to specify the endpoint to use. Since there is no authentication

# with ICE, you should only use it if you trust all the users who have

# shell access to your machine.

# Please see the ICE documentation on how to specify endpoints.

ice="tcp -h 127.0.0.1 -p 6502"


2014-03-01 18:35:00.983 Initializing settings from /opt/mumble-server/mumble-server-default.ini (basepath /opt/mumble-server)

2014-03-01 18:35:00.984 Adding 1 CA certificates from certificate file.

2014-03-01 18:35:00.984 OpenSSL: OpenSSL 1.0.0l 6 Jan 2014

2014-03-01 18:35:01.029 ServerDB: Opened SQLite database /opt/mumble-server/mumble-server-default.sqlite

2014-03-01 18:35:01.033 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running

2014-03-01 18:35:01.049 Murmur 1.2.5 (1.2.5) running on X11: CentOS release 6.5 (Final): Booting servers

2014-03-01 18:35:01.240 1 => Server listening on [::]:64738

2014-03-01 18:35:01.371 1 => Announcing server via bonjour

2014-03-01 18:35:01.463 1 => Not registering server as public

2014-03-01 18:35:01.463 Object::connect: No such slot MurmurDBus::userTextMessage(const User *, const TextMessage &)



As you can see it is now running on the right IP but I still get the same error:


[Debug: Error was added] Could not connect to Ice.

Either your server is not running or it is not running with Ice. Check your configuration.


Could not connect to Ice.

Either your server is not running or it is not running with Ice. Check your configuration.


At this point if you need I am willing to let you ssh in and take a look.

Link to comment
Share on other sites

  • Administrators

Did you check the FAQ? https://github.com/Kissaki/MumPI/wiki/FAQ#wiki-is-mumpi-compatible-with-ice-icephp-35-

In your first post you said you have Ice 3.5 installed.

From your MumPI setting I see you did not specify the -e option.


Ice 3.5 changed the default protocol to a newer, incompatible version. -e allows using the previous protocol version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...