Jump to content
Mumble forums

[SOLVED] Murmur server connection time out.


samoridon
 Share

Recommended Posts

So I had my server set up for a while now and it always worked, that is until recently. I have no idea on what happened but the server just stopped working. Well the server works, I can connect to it from the computer hosting it, but if anyone of my friends tries to connect, they get a connection timed out. The server is up, they have the right IP and port, and the ports are open. Here is the log

2014-03-18 22:19:25.323 Initializing settings from E:/Mumble/murmur.ini (basepath E:/Mumble)

2014-03-18 22:19:25.326 OpenSSL: OpenSSL 1.0.0l 6 Jan 2014

2014-03-18 22:19:25.332 ServerDB: Opened SQLite database E:/Mumble/murmur.sqlite

2014-03-18 22:19:25.336 Murmur 1.2.5 (1.2.5) running on Win: 6.1.7600.1: Booting servers

2014-03-18 22:19:25.417 1 => Server listening on [::]:64739

2014-03-18 22:19:25.484 1 => Server listening on 0.0.0.0:64739

2014-03-18 22:19:25.487 Bonjour: Failed to load dnssd.dll

2014-03-18 22:19:25.559 1 => Not registering server as public

I am completely stumped on why this does not work anymore all of a sudden.

Link to comment
Share on other sites

If you can connect locally, then it has to be one of the steps on the path into the server.


Double check the IP by googling, "What's my IP," and it will show up. If that's correct, I would move on to the Local IP address. It looks like you're running it on a Windows box, is it your desktop that you're also running Mumble on? You may have moved on the LAN, and then your port forwards could have broke because you're not at the same spot anymore. Do an IPCONFIG from the command line on the server system, and make sure your port forwards have the correct destination IP address.


If you have a smartphone, load the Mumble app and try to connect locally to your server (using WiFi). That will ensure other clients can connect as well as ensure that you know the correct address on your network for your server.

Link to comment
Share on other sites

From the server, can you telnet to the Mumble port?


telnet localhost [port]

ie.

telnet locahost 64738


Should just switch to an empty CMD window, it won't send any info through the session. That will at least tell you if it's listening locally for connections, and eliminate the local firewall as a possibility (or point to it as the issue).

Link to comment
Share on other sites

Did you check that the IP address on your LAN is correct in the Mumble client? You never said if they were running on the same box or not. If so, you could change the IP in Mumble to "localhost" or "127.0.0.1" and try again. Just to be sure that it's not something on your network, but something on your server.


What kind of system are you on? Windows (if so, and from your log, it seems so, is it XP, Vista, 7, 8, 8.1, Server 2008, 2008 R2, 2012, 2012 R2, etc), Linux (Ubuntu, Fedora, Mint, etc), Mac, etc?


To use Telnet on most systems, if you can get to a terminal or command prompt, you can just type that line I put above:

telnet localhost 64738

 

If you've left the default port, that should do it. If it connects, your terminal or command prompt window should go black/blank. If not, it should say something to the effect of:

C:\Users\InfinityDrop>telnet localhost 64738
Connecting To localhost...Could not open connection to the host, on port 64738: Connect failed

 

If it says something like, "Could not find Telnet" or similar error (maybe Telnet is not a recognized internal or external command, or something like that), then follow the directions here for installing it.

http://windows.microsoft.com/en-us/windows/telnet-faq#1TC=windows-7


Then try again.


And, I hate to break it to you, but you're not likely to receive a lot of hand holding here. If you had goggled "How do I telnet," the first result is an ehow article that's pretty good: http://windows.microsoft.com/en-us/windows/telnet-faq#1TC=windows-7


If you can't take it upon yourself to figure out the simple stuff, few people are likely to help you figure out the more complicated stuff. Additionally, most people feel that if you can't figure out the simple stuff on your own, you probably shouldn't be running your own server.

Link to comment
Share on other sites

Ok, lets go through whats happening again to avoid confusion.

I'm running the mumble server on my gaming machine, which I can connect to the server from (127.0.0.1), thats how I know the server works, I cannot however connect to the server via any other machine, be it in the locally or not. The port is open on both the TCP and UDP protocols and forwarded to the IP of my computer (on the right local IP, I've checked several times).

I tried to telnet, but the command "telnet localhost" does not exist, so I tried to telnet the port with the "open hostname" command (which in the help of the telnet commands says is the connect to hostname) but that gives me could not open connection to the host message, am I supposed to do something else than just enable telnet and go to cmd and do the command?

I'm running win 7.

Again the server used to work fine, but just decided to just stop working and I dont kow why.

Link to comment
Share on other sites

Okay, so that's good to know. I take it your PC is set to a static IP address?


If you can connect locally using Mumble to 127.0.0.1, then there's no need to telnet. It will also work just fine. If you did want to install telnet (it's just a Windows component that's not installed by default any more) you could follow either of the links I posted above.


What error do the other PC's see in Mumble when they try to connect? Does it say:

Server connection failed: The remote host closed the connection.

 

Or something else? If it says the above, it means it's not even talking to the server, more than likely. If, however, it says something like

Server connection rejected: Wrong password.

 

It means the server is actually rejecting connections to the service. If you haven't made any changes to the Mumble Server configuration at all, I wouldn't think that would be the case, but it will help to know what the clients are thinking.


Do you use a 3rd party firewall, or the one built into Windows? Can you try disabling it and connecting again? And, I know you said you've checked your port forwards, and they are good, and I hope I don't insult you by asking this, but I would also just hate for it to be something simple that was overlooked because I didn't ask. Have you literally opened a command prompt on the Mumble Server, typed in "ipconfig" and looked at the IP of the system your connecting to? If 127.0.0.1 works from your system, try using the IP that comes up when you do an IP config. If it still connects, use that IP in a different Mumble client on your network (inside, either LAN or WiFi) and see if it connects.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...