Jump to content
Mumble forums

Cannot login using SuperUser


blackblaze00
 Share

Recommended Posts

I have just installed a Murmur server. I have everything up and running just fine, and I was attempting to add myself as an admin on the server. I followed the guide give in the wiki. I connected to my server successfully, logged in under my username, and then registered myself. I then disconnected, edited the login info to have Username set to SuperUser, and I used my superuser password that I configured using the command

 

sudo -i murmurd -ini /etc/mumble-server.ini -supw <password>

 

I entered this password in the Server -> Connect screen under the username SuperUser. However, when I click connect to my server, I get the following error:

 

Wrong certificate or password for registered user. If you are certain this user is protected by a pasword please retry. Otherwise abort and check your certificate and username.

 

I know for certain that I have entered the password correctly. I made sure the username SuperUser was the correct case. What am I doing wrong here? I have been searching the internet and forums for a while now and can't find anything to address this issue. I have tried restarting my server many times. I have tried changing the SuperUser password both with the server running and the server shutdown, and restarted it each time. I can still connect just fine with my normal username, but I cannot access my server via SuperUser.


Any help is much appreciated. I'm going insane trying to fix this, as it doesn't make any sense.

Link to comment
Share on other sites

Not sure if this is relevant, but I also cannot get the Root channel name to change, nor can I get the Welcome message to change. Although both the /etc/murmur.ini and the ~/murmur/mumble-server.ini files are configured to have these updated to the same thing, the change does not take effect no matter how many times I restart my server.


I don't need this problem fixed, per say, but rather I mention it as it may help in diagnosing the problem mentioned in my original post.

Link to comment
Share on other sites

I ended up stopping my server, uninstalling and purging the entire mumble-server package, moved my murmur.ini file to murmur.ini.old, rebooted, and tried again. It's working now. I have no idea why it was having problems in the first place. I should mention that this time, I didn't use the command

 

murmur-user-wrapper -i

 

but instead only edited the /etc/mumble-server.ini after running the command

 

sudo dpkg-reconfigure mumble-server

 

Hope this helps someone else with this problem. I should also mention that I logged in as SuperUser using a different computer with a new certificate, so I'm not sure if that makes a difference. However, my Root channel name has changed as it should have, along with the Welcome message.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...