Jump to content
Mumble forums

Mumble takes 4 minutes to load/exit


Ordegar
 Share

Recommended Posts

Previous versions did not do this; the last update is when this began for me (1.2.8 Windows)


It literally takes 4 minutes to load; and even more strange, it takes 4 minutes to exit. I am not exaggerating; I timed it.


I uninstalled and reinstalled, but that didn't help. Mumble seems to work fine after the lengthy load. I tried disabling all the plugins; but it doesn't affect it. I tried disabling my AV/Firewall before starting Mumble. I tried loading it without Raptr and Steam since they both also have overlays.


I'm using a 32 bit version of Mumble on a 64 bit OS; but there doesn't seem to be a 64 bit stable version.


My system:


Intel i7 CPU

GeForce 660ti

Win 7 Home 64 bit

Link to comment
Share on other sites

  • Administrators

Is it only on first launch of Mumble?

With Debug View I could verify that this is an issue with QoS on my system, where Mumble takes a long time when querying the/for QoS, what I think leads the OS taking a long time to initially load or initialized QoS. No idea why though. This is only an issue for me on first launch once a system bootup, and has been for quite some time (not since 1.2.8).


Maybe you want to get DebugView and check at which step Mumble takes so long. Alternatively, the %APPDATA%/Mumble/Console.log may also log this info in time (not sure).

Link to comment
Share on other sites

It happens every time I run Mumble.


I renamed the console.txt so it made a new one when I started Mumble. It actually loaded a bit faster this time. Then I shut down Mumble and it took a long time. Note that the HDD was going like crazy making it impossible to do anything else until 14:12, so the log isn't showing when it actually ends. Here's the log:

 

<W>2014-09-01 14:04:05.156 DirectSound: Disabled as WASAPI is available
<W>2014-09-01 14:04:05.156 ASIO: No valid devices found, disabling
<W>2014-09-01 14:04:05.204 CELT bitstream 8000000b from C:/Program Files (x86)/Mumble/celt0.0.7.0.sse2.dll
<W>2014-09-01 14:04:05.205 CELT bitstream 80000010 from C:/Program Files (x86)/Mumble/celt0.0.11.0.sse2.dll
<W>2014-09-01 14:04:05.205 Locale is "en_US" (System: "en_US")
<W>2014-09-01 14:05:23.093 SQL Query failed "VACUUM" 
<W>2014-09-01 14:05:23.093 -1 "disk I/O error Unable to fetch row" 
<W>2014-09-01 14:05:23.094 Database SQLite: "3.7.7.1" 
<W>2014-09-01 14:05:23.094 Bonjour: Failed to load dnssd.dll
<W>2014-09-01 14:05:23.130 Overlay: Listening on "\\.\pipe\MumbleOverlayPipe" 
<W>2014-09-01 14:05:23.444 GlobalShortcutWin: No LowLevelHooksTimeout registry key found.
<W>2014-09-01 14:05:23.791 Adding device {6f1d2b60-d5a0-11cf-bfc7-444553540000} Mouse Mouse:8
<W>2014-09-01 14:05:23.842 Adding device {6f1d2b61-d5a0-11cf-bfc7-444553540000} Keyboard Keyboard:109
<W>2014-09-01 14:05:23.959 Adding device {ef6f5a80-99a6-11e3-8004-444553540000} Microsoft eHome Infrared Transceiver Microsoft eHome Infrared Transceiver:573
<W>2014-09-01 14:05:24.068 Adding device {ef6f5a80-99a6-11e3-8008-444553540000} Microsoft eHome Infrared Transceiver Microsoft eHome Infrared Transceiver:256
<W>2014-09-01 14:05:24.127 Adding device {41c36820-98b3-11e3-8004-444553540000} USB Receiver USB Receiver:767
<W>2014-09-01 14:05:24.142 Adding device {41c4c7b0-98b3-11e3-8005-444553540000} USB Receiver USB Receiver:3
<W>2014-09-01 14:05:24.383 Adding device {41c563f0-98b3-11e3-8009-444553540000} Ideazon Merc Stealth MM USB Human Interface Device Ideazon Merc Stealth MM USB Human Interface Device:18
<W>2014-09-01 14:05:24.401 AudioInput: 40000 bits/s, 48000 hz, 480 sample
<W>2014-09-01 14:05:24.405 WASAPIInput: Latencies 100000 30000 => 100000
<W>2014-09-01 14:05:24.408 WASAPIOutput: Latencies 100000 30000 => 100000
<W>2014-09-01 14:05:24.436 WASAPIInput: Stream Latency 53333 (960)
<W>2014-09-01 14:05:24.471 WASAPIOutput: Stream Latency 141042 (2880)
<W>2014-09-01 14:05:24.471 WASAPIOutput: Periods 10000us 3000us (latency 14104us)
<W>2014-09-01 14:05:24.471 WASAPIOutput: Buffer is 30000us (1)
<W>2014-09-01 14:05:24.472 AudioOutput: Initialized 2 channel 96000 hz mixer
<W>2014-09-01 14:05:24.514 AudioInput: Initialized mixer for 2 channel 48000 hz mic and 2 channel 96000 hz echo
<W>2014-09-01 14:05:24.575 AudioInput: ECHO CANCELLER ACTIVE
<W>2014-09-01 14:07:45.066 SQL Query failed "VACUUM" 
<W>2014-09-01 14:07:45.066 -1 "disk I/O error Unable to fetch row" 

Link to comment
Share on other sites

Ok I ran Mumble with DebugView going with global win32 and kernel options. It basically shows the same thing. The delay seems to be from an error reading the file when the SQL query error happens. I'm uninstalling Mumble and deleting all files, then doing a cleanup and chkdisk in case it's something on my system causing this.

Link to comment
Share on other sites

That took all day lol. I had no errors on the HDD, but now the problem is fixed.


I think it was a corrupted file in the mumble folder under appdata ( specifically mumble.sqlite ). When I uninstalled Mumble before using Control Panel Add/Remove it doesn't remove those files. This time I deleted them after uninstalling. I should have done an install again after that before running chkdisk; "simplest solutions first" is what I was taught, but oh well.


Maybe you can make the uninstall include those files so an uninstall/reinstall will fix problems like this.


Thanks for your help; if you hadn't mentioned the appdata folder I might have never thought of that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...