Jump to content
Mumble forums

Headset only working in exclusive and position audio


r3nplays
 Share

Recommended Posts

Hello!


I contacted Mumble Support twice yesterday to troubleshoot some issues I've been having for a while with Mumble. I don't usually use this service because it disables a lot of my audio on my computer and not allowing me to hear them through my headset.


Here is what I'd like for my headset to do;

-Listen to the game music/sound

-Listen to music outside of the game/itunes/pandora...

-Listen and talk to my friends on mumble


Here is the issues that I am experiencing;


Exclusive & Position Audio:

-I CAN hear people on mumble

-I CANNOT hear game sounds or music

-I CANNOT hear music through my itunes


Exclusive OFF & Position Audio OFF:

-I CANNOT hear people on mumble

-I CAN hear game sounds and music // after turning the game off and restarting it after changing this setting in Mumble

-I CAN here music through itunes/pandora // after restarting the program or browser after changing this setting in Mumble


Exclusive OFF & Position Audio ON:

-I CANNOT hear people on mumble

-I CANNOT hear game sounds or music

-I CAN hear music through my itunes


Exclusive ON & Positional Audio OFF:

-I CANNOT hear people on mumble

-I CANNOT hear game sounds or music

-I CANNOT hear music through my itunes


These are some interesting things I've experienced. I have attempted to troubleshoot the process:

-Updated all of the Audio Drivers on my computer

-Changed all of the settings within Sound Advance Settings on my Computer

-Changed headsets (Still experiencing the same issue)

-Uninstalled and reinstalled Mumble several times



I am not sure that I can do to assist you, but! I do have two audio devices;

Onboard: Realtek High Definition Audio

Audio Card: ASUS Xonar DX


My headset is: Skullcandy PLYR-1 Wireless Headset (Skullcandy GMX Dolby Transmitter)



Please help me! I really dislike that I cannot use mumble my friends are using. I also cannot stream with OBS because of this issue/

Link to comment
Share on other sites

  • Administrators

That does not really make sense.

If you can hear game and music without Mumble, you should then start Mumble with non-exclusive and disabled PA.

Enabling or disabling PA should not matter in the audio device choice; only in the volume and perceived location of others.

Link to comment
Share on other sites

That does not really make sense.

If you can hear game and music without Mumble, you should then start Mumble with non-exclusive and disabled PA.

Enabling or disabling PA should not matter in the audio device choice; only in the volume and perceived location of others.

 


I can hear music and sound in the game without Mumble. But when I open mumble it completely turns off all audio. I attempted opening it up with non-exlusive and disabled PA. Still the same issue. I'm not sure what the issue is, I have attempted to try using the Default device and then setting it as the device I want to hear the audio. Still no audio.

Link to comment
Share on other sites

I made sure that it was disabled, checked it and I noticed that it doesn't work. I restarted the computer and the program and nothing really happened.


I also attempted to check the settings in the "Play Back Devices" and checked Exclusive Mode; Allow Applications to take exclusive control of this device AND/OR Give Exclusive Mode Application Priority.


I don't know what to do, because I cannot stream because it says there is an Audio issue and OBS closes out.

Link to comment
Share on other sites

I am having the same issue.


I'm using the following:


Windows 8

Mumble 1.2.8 (tried 1.2.7 as well)

Afterglow wireless headset.


Not sure what the problem is, but similarly, I can only hear people talking on mumble and talk back myself when Exclusive and Positional audio is enabled. When I disable either or both of these, mumble cuts out. I want to be able to hear my game sounds at the same time as mumble through my headset.


Any thoughts or tips on how to make it work?

Link to comment
Share on other sites

Here are some tests I've done;


I've made sure that everything works fine through my desktop speakers while mumble is working. It works really good, it doesn't shut out any of the audio from my speakers, I can listen to the game music, and music outside of the game as well.


But, when I change the default to my headphones for the audio for game music and sounds, it completely shuts out the audio from the game; (IE: FFXIV:ARR) and iTunes. I can still listen to people on mumble, but I'd like to have things going through my headset mostly.


I am assuming it has something to do with my using a USB headset is preventing me to do what I'd like.


I will mention, I did make sure that there wasn't an option for the game program to re-direct the sound going through a different source. FFXIV: ARR doesn't allow that, and only goes through the default output for sound.


Please let m know if you have more questions, I'd appreciate it.

Link to comment
Share on other sites

I had this EXACT SAME ISSUE with Windows 8 and my SK PLYR1 headset.


Right-click on the mumble executable and select compatibility mode, choose Windows XP SP3.

Close and restart Mumble.


This completely resolved my problem and I am receiving game audio and Mumble communication simultaneously, FINALLY!


I hope this helps those of you dealing with this exact same issue!

Link to comment
Share on other sites

I had this EXACT SAME ISSUE with Windows 8 and my SK PLYR1 headset.


Right-click on the mumble executable and select compatibility mode, choose Windows XP SP3.

Close and restart Mumble.


This completely resolved my problem and I am receiving game audio and Mumble communication simultaneously, FINALLY!


I hope this helps those of you dealing with this exact same issue!

 

I still have the issue because all of the people I am listening to sounds like a chipmunk.

Link to comment
Share on other sites

I had this EXACT SAME ISSUE with Windows 8 and my SK PLYR1 headset.


Right-click on the mumble executable and select compatibility mode, choose Windows XP SP3.

Close and restart Mumble.


This completely resolved my problem and I am receiving game audio and Mumble communication simultaneously, FINALLY!


I hope this helps those of you dealing with this exact same issue!

 

I still have the issue because all of the people I am listening to sounds like a chipmunk.

 

Exact same thing for me.

Link to comment
Share on other sites

  • Moderators
I still have the issue because all of the people I am listening to sounds like a chipmunk.

 

In my extremely uneducated opinion, that sounds like it might be a sample rate problem. Can you post the output from Mumble's log file when this occurs? On Windows it should be %APPDATA%\Mumble\Console.txt. I'm not sure if it'll contain any helpful information or not, but it's worth a look.

Full disclosure: I used to run a commercial Mumble host, and my opinions do not reflect the opinions of the Mumble project.

Avatar is stolen from here

Link to comment
Share on other sites

  • 5 months later...

In my extremely uneducated opinion, that sounds like it might be a sample rate problem. Can you post the output from Mumble's log file when this occurs?

 

Sorry for posting to an old thread, but I am having the exact same issue here and it looks like it still hasn't been resolved. Here is my log when using Windows XP compatability mode:

 

<W>2015-03-15 18:03:46.075 WASAPIInit: Requires Vista SP1
<W>2015-03-15 18:03:46.075 ASIO: No valid devices found, disabling
<W>2015-03-15 18:03:46.153 G15LCDEngine_lglcd: Logitech LCD Manager not detected.
<W>2015-03-15 18:03:46.157 CELT bitstream 8000000b from C:/Program Files (x86)/Mumble/celt0.0.7.0.sse2.dll
<W>2015-03-15 18:03:46.160 CELT bitstream 80000010 from C:/Program Files (x86)/Mumble/celt0.0.11.0.sse2.dll
<W>2015-03-15 18:03:46.161 Locale is "en_US" (System: "en_US")
<W>2015-03-15 18:03:46.290 Database SQLite: "3.7.7.1" 
<W>2015-03-15 18:03:46.315 Overlay: Listening on "\\.\pipe\MumbleOverlayPipe" 
<W>2015-03-15 18:03:46.621 GlobalShortcutWin: No LowLevelHooksTimeout registry key found.
<W>2015-03-15 18:03:46.915 Adding device {6f1d2b60-d5a0-11cf-bfc7-444553540000} Mouse Mouse:8
<W>2015-03-15 18:03:46.916 Adding device {6f1d2b61-d5a0-11cf-bfc7-444553540000} Keyboard Keyboard:127
<W>2015-03-15 18:03:46.922 Adding device {9d03b650-8a15-11e4-8006-444553540000} Hid Interface Hid Interface:5
<W>2015-03-15 18:03:46.933 Adding device {9d03b650-8a15-11e4-8004-444553540000} HP Wireless Button Driver HP Wireless Button Driver:1
<W>2015-03-15 18:03:46.940 AudioInput: 36431 bits/s, 48000 hz, 480 sample
<W>2015-03-15 18:03:46.989 DXAudioInput: Initialized
<W>2015-03-15 18:03:46.991 DXAudioOutput: Primary buffer of 48000 Hz, 2 channels, 16 bits
<W>2015-03-15 18:03:46.992 DXAudioOutputUser: New 48000Hz output buffer of 96000 bytes
<W>2015-03-15 18:03:46.992 AudioOutput: Initialized 1 channel 48000 hz mixer
<W>2015-03-15 18:03:49.097 OpenSSL Support: 1 (OpenSSL 1.0.0n 6 Aug 2014)
<W>2015-03-15 18:03:49.120 SSL: CA certificate filter applied. Filtered size: 78, original size: 78
<W>2015-03-15 18:03:49.128 ServerHandler: QOS2 loaded

 

And here is a log when launching normally:

 

<W>2015-03-15 18:06:45.758 DirectSound: Disabled as WASAPI is available
<W>2015-03-15 18:06:45.759 ASIO: No valid devices found, disabling
<W>2015-03-15 18:06:45.810 G15LCDEngine_lglcd: Logitech LCD Manager not detected.
<W>2015-03-15 18:06:45.815 CELT bitstream 8000000b from C:/Program Files (x86)/Mumble/celt0.0.7.0.sse2.dll
<W>2015-03-15 18:06:45.817 CELT bitstream 80000010 from C:/Program Files (x86)/Mumble/celt0.0.11.0.sse2.dll
<W>2015-03-15 18:06:45.818 Locale is "en_US" (System: "en_US")
<W>2015-03-15 18:06:46.073 Database SQLite: "3.7.7.1" 
<W>2015-03-15 18:06:46.112 Overlay: Listening on "\\.\pipe\MumbleOverlayPipe" 
<W>2015-03-15 18:06:46.371 GlobalShortcutWin: No LowLevelHooksTimeout registry key found.
<W>2015-03-15 18:06:46.624 Adding device {6f1d2b60-d5a0-11cf-bfc7-444553540000} Mouse Mouse:8
<W>2015-03-15 18:06:46.625 Adding device {6f1d2b61-d5a0-11cf-bfc7-444553540000} Keyboard Keyboard:127
<W>2015-03-15 18:06:46.630 Adding device {9d03b650-8a15-11e4-8006-444553540000} Hid Interface Hid Interface:5
<W>2015-03-15 18:06:46.636 AudioInput: 36431 bits/s, 48000 hz, 480 sample
<W>2015-03-15 18:06:46.639 Adding device {9d03b650-8a15-11e4-8004-444553540000} HP Wireless Button Driver HP Wireless Button Driver:1
<W>2015-03-15 18:06:46.646 WASAPIInput: Latencies 100000 30000 => 100000
<W>2015-03-15 18:06:46.648 WASAPIOutput: Latencies 100000 30000 => 100000
<W>2015-03-15 18:06:46.649 WASAPIOutput: Subformat is not IEEE Float: hr=0x00000000
<W>2015-03-15 18:06:46.652 WASAPIInput: Stream Latency 58050 (882)
<W>2015-03-15 18:06:46.652 AudioInput: Initialized mixer for 1 channel 44100 hz mic and 0 channel 48000 hz echo
<W>2015-03-15 18:06:48.751 OpenSSL Support: 1 (OpenSSL 1.0.0n 6 Aug 2014)
<W>2015-03-15 18:06:48.758 SSL: CA certificate filter applied. Filtered size: 78, original size: 78
<W>2015-03-15 18:06:48.766 ServerHandler: QOS2 loaded
<W>2015-03-15 18:06:49.228 Sound file ":/ServerConnected.ogg" is not a valid audio file, fallback to TTS. 

Link to comment
Share on other sites

  • 2 weeks later...

I'm having this same problem. Running Win 8.1, Skullcandy GMX usb headset. Mic works, audio output through that device does not work. Putting the Mumble executable in Win XP sp3 mode causes the output work through the headset, but the audio sounds like chipmunks.


I'd love to know if/when this issue is resolved.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...