Jump to content
Mumble forums

How to set Server using OPUS


StonedLover
 Share

Recommended Posts

Heyho,

I trying to get run the mumble-ruby bot as a music bot. When I tried to run "cli.stream_raw_audio..." instead of playing music the bot is mute his self. After google a lil bit I found that u have to change the codec from the server to OPUS. But I didnt found any resoulution for it. I tried : opusthreshold=1 but this didnt worked. Instead of using celt 0.7 he is using 0.11 Anyone can help me ?

Link to comment
Share on other sites

  • Moderators

Wit a default configuration your server in version 1.2.4 and later uses Opus automatically if every clients ON THE SERVER (not in the channel) supports it. You may enforce usage of Opus by setting opusthreshold.


All Mumble clients with at least version 1.2.4, Mumble for iOS (don't know the version) and Plumble version 2.x support Opus.


The problem with the bot that mutes himself also happens on our Mumble server and we enforce Opus. But you can easily unmute the bot with: @cli.me.mute false


If you want to create a music bot for Mumble, try Superbot wich plays music from a running MPD and can be controlled via text commands in Mumble.


Btw. there is also a mumble-ruby fork from dafoxia which supports CELT if you really need it, see https://github.com/dafoxia/mumble-ruby/.

Link to comment
Share on other sites

yeah I tried to work with superbot but it doesnt work <.<

When I run the script I get this error:

/home/botmaster/.rvm/rubies/ruby-2.1.2/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- mumble-ruby (LoadError)

from /home/botmaster/.rvm/rubies/ruby-2.1.2/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'

from superbot.rb:3:in `'



So i tried another tutorial and with the other tutorial there are aswell problems x.x

Link to comment
Share on other sites

  • Moderators

You need to setup the environment if you want to run the bot in your current shell:

source ~/.rvm/scripts/rvm

rvm use @bots


Then run your ruby script.


This is described here.


In the tutorial the bots are started in a script, which does this. I changed the documentation for this.

Link to comment
Share on other sites

I just did it like it is written in the docu but anyway didnt worked. That was the first thing what i tried. Its the same message ( in ./rvm/scripts there isnt a div called rvm ).


Anyway when I tried it with the other option and I try to run

cli.stream_raw_audio('/tmp/mumble.fifo')

I get the Error:

irb(main):006:0> cli.stream_raw_audio('/tmp/mumble.fifo')
NoMethodError: undefined method `stream_raw_audio' for #<Mumble::Client:0x9074e4c>
       from (irb):6
       from /usr/bin/irb1.9.1:12:in `<main>'

>.< I dont get it why it get this much errors I followed the hole tutorial right x.x

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...