Jump to content
Mumble forums

[RESOLVED by using stable version] Help with server


Trixter313
 Share

Recommended Posts

I set a server up and gave my friend the proper address etc. and when he adds the server it gets a ping of about 23 but when he tries to connect it says "Connecting to server", waits a while then says "Disconnected from server". I can't connect to the server either, when i use the IP the ping switches from 0 to 1 but does the same thing that happens to my cousin. The computer I'm using is also the host of the server.


I tested the port 64738 and it says it's open and not blocked by my ISP.


I followed the tutorial and am very frustrated, any help would be awesome, thanks!


My murmur.ini file:

# Murmur configuration file.

#

# General notes:

# * Settings in this file are default settings and many of them can be overridden

# with virtual server specific configuration via the Ice or DBus interface.

# * Due to the way this configuration file is read some rules have to be

# followed when specifying variable values (as in variable = value):

# * Make sure to quote the value when using commas in strings or passwords.

# NOT variable = super,secret BUT variable = "super,secret"

# * Make sure to escape special characters like '\' or '"' correctly

# NOT variable = """ BUT variable = "\""

# NOT regex = \w* BUT regex = \\w*


# Path to database. If blank, will search for

# murmur.sqlite in default locations or create it if not found.

database=


# If you wish to use something other than SQLite, you'll need to set the name

# of the database above, and also uncomment the below.

# Sticking with SQLite is strongly recommended, as it's the most well tested

# and by far the fastest solution.

#

#dbDriver=QMYSQL

#dbUsername=

#dbPassword=

#dbHost=

#dbPort=

#dbPrefix=murmur_

#dbOpts=


# Murmur defaults to not using D-Bus. If you wish to use dbus, which is one of the

# RPC methods available in Murmur, please specify so here.

#

dbus=session


# Alternate D-Bus service name. Only use if you are running distinct

# murmurd processes connected to the same D-Bus daemon.

#dbusservice=net.sourceforge.mumble.murmur


# If you want to use ZeroC Ice to communicate with Murmur, you need

# to specify the endpoint to use. Since there is no authentication

# with ICE, you should only use it if you trust all the users who have

# shell access to your machine.

# Please see the ICE documentation on how to specify endpoints.

#ice="tcp -h 127.0.0.1 -p 6502"


# Ice primarily uses local sockets. This means anyone who has a

# user account on your machine can connect to the Ice services.

# You can set a plaintext "secret" on the Ice connection, and

# any script attempting to access must then have this secret

# (as context with name "secret").

# Access is split in read (look only) and write (modify)

# operations. Write access always includes read access,

# unless read is explicitly denied (see note below).

#

# Note that if this is uncommented and with empty content,

# access will be denied.


#icesecretread=

icesecretwrite=


# How many login attempts do we tolerate from one IP

# inside a given timeframe before we ban the connection?

# Note that this is global (shared between all virtual servers), and that

# it counts both successfull and unsuccessfull connection attempts.

# Set either Attempts or Timeframe to 0 to disable.

#autobanAttempts = 10

#autobanTimeframe = 120

#autobanTime = 300


# Specifies the file Murmur should log to. By default, Murmur

# logs to the file 'murmur.log'. If you leave this field blank

# on Unix-like systems, Murmur will force itself into foreground

# mode which logs to the console.

#logfile=murmur.log


# If set, Murmur will write its process ID to this file

# when running in daemon mode (when the -fg flag is not

# specified on the command line). Only available on

# Unix-like systems.

#pidfile=


# The below will be used as defaults for new configured servers.

# If you're just running one server (the default), it's easier to

# configure it here than through D-Bus or Ice.

#

# Welcome message sent to clients when they connect.

welcometext="

Welcome to this server running Murmur.

Enjoy your stay!

"


# Port to bind TCP and UDP sockets to.

port=64738


# Specific IP or hostname to bind to.

# If this is left blank (default), Murmur will bind to all available addresses.

host=192.168.200.100


# Password to join server.

serverpassword=minecraft


# Maximum bandwidth (in bits per second) clients are allowed

# to send speech at.

bandwidth=72000


# Maximum number of concurrent clients allowed.

users=3


# Amount of users with Opus support needed to force Opus usage, in percent.

# 0 = Always enable Opus, 100 = enable Opus if it's supported by all clients.

#opusthreshold=100


# Maximum depth of channel nesting. Note that some databases like MySQL using

# InnoDB will fail when operating on deeply nested channels.

#channelnestinglimit=10


# Regular expression used to validate channel names.

# (Note that you have to escape backslashes with \ )

#channelname=[ \\-=\\w\\#\\[\\]\\{\\}\\(\\)\\@\\|]+


# Regular expression used to validate user names.

# (Note that you have to escape backslashes with \ )

#username=[-=\\w\\[\\]\\{\\}\\(\\)\\@\\|\\.]+


# Maximum length of text messages in characters. 0 for no limit.

#textmessagelength=5000


# Maximum length of text messages in characters, with image data. 0 for no limit.

#imagemessagelength=131072


# Allow clients to use HTML in messages, user comments and channel descriptions?

#allowhtml=true


# Murmur retains the per-server log entries in an internal database which

# allows it to be accessed over D-Bus/ICE.

# How many days should such entries be kept?

# Set to 0 to keep forever, or -1 to disable logging to the DB.

#logdays=31


# To enable public server registration, the serverpassword must be blank, and

# this must all be filled out.

# The password here is used to create a registry for the server name; subsequent

# updates will need the same password. Don't lose your password.

# The URL is your own website, and only set the registerHostname for static IP

# addresses.

# Only uncomment the 'registerName' parameter if you wish to give your "Root" channel a custom name.

#

registerName=Trixter313's Mumble Server

#registerPassword=secret

#registerUrl=http://mumble.sourceforge.net/

#registerHostname=


# If this option is enabled, the server will announce its presence via the

# bonjour service discovery protocol. To change the name announced by bonjour

# adjust the registerName variable.

# See http://developer.apple.com/networking/bonjour/index.html for more information

# about bonjour.

#bonjour=True


# If you have a proper SSL certificate, you can provide the filenames here.

# Otherwise, Murmur will create it's own certificate automatically.

#sslCert=

#sslKey=


# If Murmur is started as root, which user should it switch to?

# This option is ignored if Murmur isn't started with root privileges.

#uname=


# If this options is enabled, only clients which have a certificate are allowed

# to connect.

#certrequired=False


# If enabled, clients are sent information about the servers version and operating

# system.

#sendversion=True


# You can configure any of the configuration options for Ice here. We recommend

# leave the defaults as they are.

# Please note that this section has to be last in the configuration file.

#

[ice]

Ice.Warn.UnknownProperties=1

Ice.MessageSizeMax=65536

The log:

2014-09-18 18:28:44.816 Initializing settings from C:/Program Files/Mumble/murmur.ini (basepath C:/Program Files/Mumble)

2014-09-18 18:28:44.816 Binding to address 192.168.200.100

2014-09-18 18:28:44.816 OpenSSL: OpenSSL 1.0.1i 6 Aug 2014

2014-09-18 18:28:44.816 Failed to open logfile murmur.log. No logging will be performed.

2014-09-18 18:28:44.821 SSL: CA certificate filter applied. Filtered size: 70, original size: 72

2014-09-18 18:28:44.821 ServerDB: Opened SQLite database C:/Users/Nick/murmur.sqlite

2014-09-18 18:28:44.823 Murmur 1.3.0 (1.3.0~375~g6095134~snapshot) running on WinX64: Windows 8 x64 - 6.2.9200: Booting servers

2014-09-18 18:28:44.960 1 => Server listening on 192.168.200.100:64738

2014-09-18 18:28:44.961 Bonjour: Failed to load dnssd.dll

2014-09-18 18:28:45.041 1 => Registration needs nonempty 'registername', 'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.

Edited by Trixter313
Link to comment
Share on other sites

whenever i've made a mumble server, i've never once changed the "host=" field...i've always left it in its default state. I don't mean any disrespect with this next question but my years of support have taught me "ask all the questions": are you giving your friend the 192.168.*.* IP address?

Link to comment
Share on other sites

whenever i've made a mumble server, i've never once changed the "host=" field...i've always left it in its default state. I don't mean any disrespect with this next question but my years of support have taught me "ask all the questions": are you giving your friend the 192.168.*.* IP address?

No offense taken lol, best to ask than assume. I am not giving my friend my computer router IP address, I gave him my public IP address like the one that Google will tell you if you google whats my IP. :)

Edit: I should also say that I can't connect to the server either... when i use the IP the ping switches from 0 to 1 but does the same thing that happens to my cousin. The computer I'm using is also the host of the server.

Link to comment
Share on other sites

Is the ping your friend doing the active mumble ping for the server list or just a straight command line ping? Is the host IP that you have in the file an IP address of the computer the server is running on?


Is that the entirety of your log file? I'm just wondering if your log even shows your friend trying to connect.


I'm still trying to narrow down the problem so any information I can get could help.

Link to comment
Share on other sites

Is the ping your friend doing the active mumble ping for the server list or just a straight command line ping? Is the host IP that you have in the file an IP address of the computer the server is running on?


Is that the entirety of your log file? I'm just wondering if your log even shows your friend trying to connect.


I'm still trying to narrow down the problem so any information I can get could help.

It is the ping that shows in the connect to a server list.

Yes, that is the computers static IP address.

Yes, that is the entire log. No sign of my friend at all.

Link to comment
Share on other sites

I can think of only a few possibilities here...

A) your friend is trying to connect to the wrong IP

B) the firewall rules aren't set properly

C) running multiple instances of Murmur and they are getting confused

D) the completed host field is somehow causing a conflict.


Have others connected to your server? have you tried connecting to it from your smartphone (while not on wifi)?

Link to comment
Share on other sites

I can think of only a few possibilities here...

A) your friend is trying to connect to the wrong IP

B) the firewall rules aren't set properly

C) running multiple instances of Murmur and they are getting confused

D) the completed host field is somehow causing a conflict.


Have others connected to your server? have you tried connecting to it from your smartphone (while not on wifi)?

A.) They have the correct IP

B.) Maybe... I don't know how to fix that though or even test to see if thats the problem

C.) There is only one Murmur, I had them restart their computer and double check that there was only one afterwards.

D.) If I comment out the host code it says

2014-09-19 18:00:02.768 Initializing settings from C:/Program Files/Mumble/murmur.ini (basepath C:/Program Files/Mumble)

2014-09-19 18:00:02.771 OpenSSL: OpenSSL 1.0.1i 6 Aug 2014

2014-09-19 18:00:02.771 Failed to open logfile murmur.log. No logging will be performed.

2014-09-19 18:00:02.775 SSL: CA certificate filter applied. Filtered size: 70, original size: 72

2014-09-19 18:00:02.777 ServerDB: Opened SQLite database C:/Users/Nick/murmur.sqlite

2014-09-19 18:00:02.780 Murmur 1.3.0 (1.3.0~375~g6095134~snapshot) running on WinX64: Windows 8 x64 - 6.2.9200: Booting servers

2014-09-19 18:00:02.876 1 => Server listening on [::]:64738

2014-09-19 18:00:02.956 1 => Server listening on 0.0.0.0:64738

2014-09-19 18:00:03.031 1 => Failed to bind UDP Socket to 0.0.0.0:64738

2014-09-19 18:00:03.033 Bonjour: Failed to load dnssd.dll

2014-09-19 18:00:03.123 1 => Registration needs nonempty 'registername', 'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.

No-one has connected ever yet, not even me, it does the same to me.

Edit: Tried the app, it says the server is offline if I'm connected to the wifi but if I'm not on wifi it says online! It still won't connect to the server though...

Also, if I use the hosts router assigned static IP on the same wifi it says the server is online but it still won't connect.

Edited by Trixter313
Link to comment
Share on other sites

I would uncommercial out the host line, but delete the IP address from it, as the blank host is what should activate the default code action.


Also, if you are connecting to mumble to murmur on the same computer try connecting to 127.0.0.1


There is a website, I forget the name but google should help, to test if a port is open.

Link to comment
Share on other sites

I would uncommercial out the host line, but delete the IP address from it, as the blank host is what should activate the default code action.


Also, if you are connecting to mumble to murmur on the same computer try connecting to 127.0.0.1


There is a website, I forget the name but google should help, to test if a port is open.

I deleted the ip from the host line and in the log it says,

"2014-09-20 09:50:40.759 1 => Failed to bind UDP Socket to 0.0.0.0:64738"

again which is why I put an IP address there in the first place. Also when I leave it blank no-one gets a ping and the app says offline when I do have an IP there the app says online and clients get pings but neither can connect.

Tried 127.0.0.1 just now; no ping at all and can't connect.

I already checked with the site that the guide recommends and it said the ports were open.

Sorry it took a while to respond, I was refreshing the page but your post was on the next page so didn't see it.

I hope we can get this to work... It sounded like the perfect thing me and my friends needed since Skype's voice chat was lagging and their computers aren't so good so their games lag a lot with Skype.

Link to comment
Share on other sites

Ok, in case I changed something and forgot to say, here is the new/current murmur.ini and log.


murmur.ini:

# Murmur configuration file.

#

# General notes:

# * Settings in this file are default settings and many of them can be overridden

# with virtual server specific configuration via the Ice or DBus interface.

# * Due to the way this configuration file is read some rules have to be

# followed when specifying variable values (as in variable = value):

# * Make sure to quote the value when using commas in strings or passwords.

# NOT variable = super,secret BUT variable = "super,secret"

# * Make sure to escape special characters like '\' or '"' correctly

# NOT variable = """ BUT variable = "\""

# NOT regex = \w* BUT regex = \\w*


# Path to database. If blank, will search for

# murmur.sqlite in default locations or create it if not found.

database=


# If you wish to use something other than SQLite, you'll need to set the name

# of the database above, and also uncomment the below.

# Sticking with SQLite is strongly recommended, as it's the most well tested

# and by far the fastest solution.

#

#dbDriver=QMYSQL

#dbUsername=

#dbPassword=

#dbHost=

#dbPort=

#dbPrefix=murmur_

#dbOpts=


# Murmur defaults to not using D-Bus. If you wish to use dbus, which is one of the

# RPC methods available in Murmur, please specify so here.

#

dbus=session


# Alternate D-Bus service name. Only use if you are running distinct

# murmurd processes connected to the same D-Bus daemon.

#dbusservice=net.sourceforge.mumble.murmur


# If you want to use ZeroC Ice to communicate with Murmur, you need

# to specify the endpoint to use. Since there is no authentication

# with ICE, you should only use it if you trust all the users who have

# shell access to your machine.

# Please see the ICE documentation on how to specify endpoints.

#ice="tcp -h 127.0.0.1 -p 6502"


# Ice primarily uses local sockets. This means anyone who has a

# user account on your machine can connect to the Ice services.

# You can set a plaintext "secret" on the Ice connection, and

# any script attempting to access must then have this secret

# (as context with name "secret").

# Access is split in read (look only) and write (modify)

# operations. Write access always includes read access,

# unless read is explicitly denied (see note below).

#

# Note that if this is uncommented and with empty content,

# access will be denied.


#icesecretread=

icesecretwrite=


# How many login attempts do we tolerate from one IP

# inside a given timeframe before we ban the connection?

# Note that this is global (shared between all virtual servers), and that

# it counts both successfull and unsuccessfull connection attempts.

# Set either Attempts or Timeframe to 0 to disable.

#autobanAttempts = 10

#autobanTimeframe = 120

#autobanTime = 300


# Specifies the file Murmur should log to. By default, Murmur

# logs to the file 'murmur.log'. If you leave this field blank

# on Unix-like systems, Murmur will force itself into foreground

# mode which logs to the console.

#logfile=murmur.log


# If set, Murmur will write its process ID to this file

# when running in daemon mode (when the -fg flag is not

# specified on the command line). Only available on

# Unix-like systems.

#pidfile=


# The below will be used as defaults for new configured servers.

# If you're just running one server (the default), it's easier to

# configure it here than through D-Bus or Ice.

#

# Welcome message sent to clients when they connect.

welcometext="

Welcome to this server running Murmur.

Enjoy your stay!

"


# Port to bind TCP and UDP sockets to.

port=64738


# Specific IP or hostname to bind to.

# If this is left blank (default), Murmur will bind to all available addresses.

host=192.168.200.100


# Password to join server.

serverpassword=


# Maximum bandwidth (in bits per second) clients are allowed

# to send speech at.

bandwidth=72000


# Maximum number of concurrent clients allowed.

users=3


# Amount of users with Opus support needed to force Opus usage, in percent.

# 0 = Always enable Opus, 100 = enable Opus if it's supported by all clients.

#opusthreshold=100


# Maximum depth of channel nesting. Note that some databases like MySQL using

# InnoDB will fail when operating on deeply nested channels.

#channelnestinglimit=10


# Regular expression used to validate channel names.

# (Note that you have to escape backslashes with \ )

#channelname=[ \\-=\\w\\#\\[\\]\\{\\}\\(\\)\\@\\|]+


# Regular expression used to validate user names.

# (Note that you have to escape backslashes with \ )

#username=[-=\\w\\[\\]\\{\\}\\(\\)\\@\\|\\.]+


# Maximum length of text messages in characters. 0 for no limit.

#textmessagelength=5000


# Maximum length of text messages in characters, with image data. 0 for no limit.

#imagemessagelength=131072


# Allow clients to use HTML in messages, user comments and channel descriptions?

#allowhtml=true


# Murmur retains the per-server log entries in an internal database which

# allows it to be accessed over D-Bus/ICE.

# How many days should such entries be kept?

# Set to 0 to keep forever, or -1 to disable logging to the DB.

#logdays=31


# To enable public server registration, the serverpassword must be blank, and

# this must all be filled out.

# The password here is used to create a registry for the server name; subsequent

# updates will need the same password. Don't lose your password.

# The URL is your own website, and only set the registerHostname for static IP

# addresses.

# Only uncomment the 'registerName' parameter if you wish to give your "Root" channel a custom name.

#

#registerName=Trixter313

#registerPassword=secret

#registerUrl=http://mumble.sourceforge.net/

#registerHostname=


# If this option is enabled, the server will announce its presence via the

# bonjour service discovery protocol. To change the name announced by bonjour

# adjust the registerName variable.

# See http://developer.apple.com/networking/bonjour/index.html for more information

# about bonjour.

#bonjour=true


# If you have a proper SSL certificate, you can provide the filenames here.

# Otherwise, Murmur will create it's own certificate automatically.

#sslCert=

#sslKey=


# If Murmur is started as root, which user should it switch to?

# This option is ignored if Murmur isn't started with root privileges.

#uname=


# If this options is enabled, only clients which have a certificate are allowed

# to connect.

#certrequired=False


# If enabled, clients are sent information about the servers version and operating

# system.

#sendversion=True


# You can configure any of the configuration options for Ice here. We recommend

# leave the defaults as they are.

# Please note that this section has to be last in the configuration file.

#

[ice]

Ice.Warn.UnknownProperties=1

Ice.MessageSizeMax=65536

 

Server log:

2014-09-20 10:12:41.192 Initializing settings from C:/Program Files/Mumble/murmur.ini (basepath C:/Program Files/Mumble)

2014-09-20 10:12:41.192 Binding to address 192.168.200.100

2014-09-20 10:12:41.192 OpenSSL: OpenSSL 1.0.1i 6 Aug 2014

2014-09-20 10:12:41.192 Failed to open logfile murmur.log. No logging will be performed.

2014-09-20 10:12:41.196 SSL: CA certificate filter applied. Filtered size: 70, original size: 72

2014-09-20 10:12:41.197 ServerDB: Opened SQLite database C:/Users/Nick/murmur.sqlite

2014-09-20 10:12:41.199 Murmur 1.3.0 (1.3.0~384~g916dcc0~snapshot) running on WinX64: Windows 8 x64 - 6.2.9200: Booting servers

2014-09-20 10:12:41.333 1 => Server listening on 192.168.200.100:64738

2014-09-20 10:12:41.334 Bonjour: Failed to load dnssd.dll

2014-09-20 10:12:41.491 1 => Not registering server as public

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...