Jump to content
Mumble forums

Mumble client without GUI? (ubuntu server)


Recommended Posts

Hi all.

First post here, I am Babis from Greece.

I wish the best for all for the new year and for always :)

My question is: Could the mumble client run on a linux system without GUI? I tried to install mumble on ubuntu 14.04 server but mumble needs xserver (I think its a gui for linux).

I am VERY new to linux, I know almost nothing, so forgive my ignorance...


Link to comment
Share on other sites

  • 3 weeks later...

Someone with an answer?

I read something about "barnard" and "mumble ruby" but it seems I can not make mumble-ruby work...

And also I can not make barnard work, I need info and reading...

I know here is mumble forum and maybe it is not the right place for these questions regarding barnard or mumble-ruby (or it is?), but if someone has info about my questions, please respond.

Link to comment
Share on other sites

Hi babisbabis,

mumble-ruby is a cool and powerful tool to build mumble-client's and bot's. It is probeably not the right thing for you. You will need programming skills in ruby to get a working client.

I think you take barnard better. Banard is a full mumble client. On Ubuntu with ALSA installed you can get it with following commands running:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoremove golang
sudo apt-get install build-essential git mercurial libopenal1 libopenal-dev wget nano
cd ~
wget https://storage.googleapis.com/golang/go1.3.linux-amd64.tar.gz
sudo tar -C /usr/local -xzf go1.3.linux-amd64.tar.gz
sudo nano /etc/environment

append before last " :


(ctrl-x) save and exit

source /etc/environment

user has to be exchange with your user shown at promt!

mkdir -p /home/user/go-apps/src
cd /home/user/go-apps/src
export GOPATH=/home/user/go-apps
git clone https://github.com/layeh/barnard.git
cd barnard
go get
go run cmd/barnard/main.go "serveraddress:port"


If your server need's a certificate you could export it from your normal mumble client and convert it on Ubuntu with:

openssl pkcs12 -in certificate.p12 -out certificate.pem -nodes

then you can start it:

go run cmd/barnard/main.go -server=”serveraddress:port″ -username=”guess-it” -insecure=true -certificate=/home/user/path-to-certificate.pem


hth ;)

Link to comment
Share on other sites

Hi dafoxia.

Thank you very much for the answer. I will try these steps you suggested :)

My final goal (I should write it on the first post..) would be a PC working 24/7 with, say, ubuntu server, mumble server, and a mumble client (bot or whatever). The mumble client would do the following:

It would transmit with voice activity (VOX) from mic input of soundcard.

Whenever someone else talks in the channel, the mumble client would output the audio to the souncard output of course, and also would change the RTS pin state of RS232. For example, if noone speaks, then the RTS would have about -11V (normal "idle" state). When someone speaks in the channel, the RTS pin will have +11V. This RTS pin will be used as hardware PTT (press to talk) command for an external ham radio transciever.

The guys at http://mumblefunk.de have done this, but with ubuntu desktop and patched mumble client (with gui).

So, I guess I should first make barnard work, and then study, in order to understand how it works, so that maybe some day I could be able to perhaps "patch" it with code to do all the above things...

Am I thinking right?

Of course, it will be difficult for me, since I have not yet been able to make barnard work (in windows) :oops: but also I think it will be very interesting.

Any further help will be welcomed, of course.

Thanks again.

Link to comment
Share on other sites

  • 1 year later...

hi dafoxia,

Thank you for this guide!

I have one big problem, i cant solve. I tryed to google it but im to nooby for it... :O

If i use "go run cmd/barnard/main.go/ "myserver:port" i get an error message;

#pkg-config --cflags opus

Package opus was not found in the pkg-config search path.

Perhaps you should add the directory containing "opus.pc"

to the PKG_CONFIG_PATH enviroment variable

No package "opus" found

exit status 1

How could i fix this? i tryed now a lot include export the path.. but may be i do allthing wrong?

I hope you could help me!

best regards

Link to comment
Share on other sites

  • 11 months later...

sorry to bump this old thread, if deathvader hasn't solved his problem, here's what worked for me on raspberry:

apt-cache search opus 

returned among others libopus-dev, which i installed and voila - worked out well.

i'm stuck with an error when connecting to a server though:

dial tcp: unknown port tcp/64738“

exit status 1


any hints regarding this?

Link to comment
Share on other sites

  • 8 months later...

We ended up building then on a Raspberry Pi but with a desktop, for small I/O boxes.

This way we can use all the features of the mumble client, and then use GPI for triggering the Keys, or a touchscreen with shortcuts.

An Ansible script for installing it is here: https://forums.mumble.info/viewtopic.php?f=7&t=4089

We use this on Mac´s with Dante network and multiple mumble clients for I/O in house (I have the smallest Mac mini running 16 clients, and one runnning 24 clients)

I´m working on a Runbook if someone else would like to build a Mac mini with multiple mumbles. :)

Link to comment
Share on other sites

  • 7 months later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...