Jump to content
Mumble forums

Help! People cannot hear until they hit their push to talk


Recommended Posts

First, I want to thank those that take the time to answer questions in this forum. A big Happy New Year.

I have been running version 1.2.8 of the murmur server on CentOS using the .x86 binary. Everything works great with just one exception. Whenever someone new joins the server with their mumble client they cannot hear anyone in any channel until they hit their push-to-talk key several times.

Every time we invite someone new to our server we have to tell them repeatedly in chat that if they can't hear us to hit their push-to-talk key. When they do, mumble works great and they never have the problem again. But every new user always has to go through this procedure.

I recently upgraded the murmur server to a 1.3.0 snapshot and the problem continues to exist. I've reviewed the docs and my config file for clues and am at wits end.

Suggestions on what I may be doing wrong?

Many thanks.

Link to comment
Share on other sites

  • Moderators

Sounds to me like most likely culprit is a misconfigured firewall, but it's weird that it happens with multiple people.

Full disclosure: I used to run a commercial Mumble host, and my opinions do not reflect the opinions of the Mumble project.

Avatar is stolen from here

Link to comment
Share on other sites

I haven't looked at the 1.2.8 package in CentOS, but this used to be a problem in Mumble in versions prior to 1.2.4 in Debian:


And there are still some issues concerning users being able to hear each other when using the Armel architecture:


It does not sound like a firewall problem to me, since communication works after using PTT a few times.

Link to comment
Share on other sites

I'm having usually the same issues.

There is at least discussion in http://forums.mumble.info/viewtopic.php?f=4&t=1509 here and some other threads on same.

So I have had this for long time. Clients are mostly Client version 1.2.8 (Win: 1.2.8) but also the older work the same. Server was Murmur 1.2.2 and is now Murmur 1.3.0 (1.3.0~447~g7d434bb~snapshot) running on X11: Debian GNU/Linux 7.7 (wheezy).

So same things and few others. So if someone logs in, they don't hear anyone if they dont tap push to talk. It might be also that after a long idle (hours) they also go to this state. Also sometimes they go loke squirells and can't understand the speak, and reboot of windows mumble client helps.

But the most anoying is this that they are on the channel and they don't hear anyone until tapping push to talk. And this happends mostly every time they log to channel (probably every time).

I will look to eventviewer at some point on those servers, but it seems this is actually really wide problem as I have seen 5-10 people in this forum having the same issues, sometimes the TCP setting has repaired this on client. At my case it didn't.

Probably this has something to do with the client fw, but there is nothing fancy at my case, standard NAT that most people have.



Link to comment
Share on other sites

  • Administrators

I've seen this in MumbleKit as well.

In there, we fix it like so:


Reading the comment, it seems like it has only been an issue for TCP mode, though...

Anyway, I believe it is a real problem, so maybe we should do the same in desktop Mumble.

Link to comment
Share on other sites

Ok, actually behind same fw / nat, I don't think that on OSX this has never been an problem, so if I understood correctly, there could be something on it.

Would it be possible to have an snapshot for this that I could test on Windows.

Today, my daughter brought up her windows up 1.5h ago and with autologin to channel. I tried to speak on same channel and nothing, not even the red lips, so it would be pretty easy for me to test.


Actually at least on my case, I just put recently all clients to TCP mode because on some forum that seemed to help. So I have had this issue both TCP and UDP.


So somewhere here?




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...