Jump to content
Mumble forums

Lagging when in game cause of mumble


raineykins
 Share

Recommended Posts

I start mumble go in game(have also started game then mumble) and I lag I hit major lag spikes...I can barely move sometimes...sometimes the tank dies cause i lag and cant heal him...if i alt tab out of game and close mumble my lag goes away..ive even tried lowering the process(mumble sets itself to high automatically in task manager for cpu usage which it doesnt need to) and I still lag...I lowered compression and raised audio packet...still lag any help for this?

Link to comment
Share on other sites

  • Administrators

Please use paragraphs instead of only dots to seperate text and make it more readable.

Also, you didn't tell us which game you're talking about, only that it has tanks.

Did you mean mumble is on high priority in task manager or that it has high CPU load?

Also, are you talking about lag as in network lag?


Try disabling overlay.

Link to comment
Share on other sites

It sets itself to high priorty in task manager.

Whenever I am playing a game any game I have computer lag.

Long as I do not run mumble everything runs smooth.

My main game is perfect world international, mumble was recommended to me by a trusted friend.

I have used mumble for a long time along with playing games.

The older mumble versions did not make me lag, its only with the last 1 or 2 new releases I have lag.

Sometimes if I start mumble before I enter game I can not enter game cause of the lag and I have to shut down mumble enter game then boot mumble.

But with the games I play mumble is what my teammates use to communicate, and its great being on voice when doing dungeon runs etc.

But lately I cant run mumble and be in a dungeon cause I can not get over certain objects in the dungeon due to lag.

Like I said I have 0 lag when not running mumble.

Link to comment
Share on other sites

Try playing around with the compression in the settings. Here you can set the voice quality and the latency. By picking a low quality and high latency, mumble will use the old Speex codec. This way you circumvent the new CELT codec that was introduced in the 1.2.x versions.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

  • Administrators

As I suggested in my last post, please try disabling the Mumble overlay.

Having problems starting programs when mumble is already running may also indicate that that's an/the issue.

 

Try playing around with the compression in the settings. Here you can set the voice quality and the latency. By picking a low quality and high latency, mumble will use the old Speex codec. This way you circumvent the new CELT codec that was introduced in the 1.2.x versions.

 

It's not voice quality, it's compression quality.

Higher compression quality will cause more CPU-usage but less network bandwidth.



Could you further describe what kind of lag we're talking about?

Network lag as in you can move and control normaly, only it resets your positions/actions at times.

Or is it more of a stuttering where your computer, display, mouse/controls or application freezes frequently, in shorter or longer durations?

Also, did I understand that correctly that when you started mumble you're also experiencing problems in your system (are you using windows?)?


As you seem to have checked the task manager, did you also check your CPU-usage?

Does mumble use too much CPU for the game to run smoothly? (mumble + app usage % = 100%)

If so, it's probably stuttering, not lagging we're talking about and you could check mumbles options to optimize for low CPU; disable echo cancellation, make packets bit and few (low compression quality, big in size), disable overlay and text-to-speech, maybe even disable noise suppression…

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...