Jump to content
Mumble forums

Mumble on headless Debian doesn't receive remote audio.


notthetup
 Share

Recommended Posts

Hi all,


I'm trying to recreate my podcast streaming setup on a Debian VPS (similar my original setup http://chinpen.net/blog/streaming-audio).


A mumble client which listens to the entire conversation and streams it out to an icecast server is the centre of this setup. But I'm having some issues with that mumble client not receiving audio from other clients in the same room.


Here is what I happens:


1. I launch Mumble (I VNC into the server to see the UI) and it connects to my Murmur server, and enter a room.

2. I launch Mumble on my local machine (Macbook) and make it connect to the same Murmur server and enter the same room.

3. While my local setup shows that it's picking my my audio (red lips), the Mumble on the Debian server doesn't seem to be getting any audio from me (no red lips).


This is weird since it's just Mumble receiving audio from the network, it should work regardless of underlying audio setup (pulseaudio, streams, etc).


Update:

The one interesting thing I noticed was, sometimes after toggling various settings in the Audio Output tab, it suddenly seems to work randomly. I traced back the logs and I saw this statement which I hadn't seen before. "PulseAudio: Starting output: stream".


So why isn't the Pulseaudio output stream starting other times. And why would that stop the remote audio from being received by Mumble?

Link to comment
Share on other sites

  • Moderators

I had the same problems with the Pulseaudio output when creating and using Mumble bots. I couldn't solve this issue and this is why I started to use JACK instead of PulseAudio for Mumble bots.


There is an unofficial Jack-Patch for Mumble (https://github.com/mumble-voip/mumble/pull/137). One advantage is a lower cpu usage for JACK.


Maybe you could try this for your setup.

Link to comment
Share on other sites

  • Moderators

An atom cpu is probably too weak for this; at least one person wrote me an email and asked for optimizations for mumble-ruby on his atom cpu netbook.


Instead of the original mumble-ruby you could try https://github.com/dafoxia/mumble-ruby which has some performance improvements. (I remember them talking about 2% CPU usage instead of 10% with the original mumble-ruby).

Link to comment
Share on other sites

Thanks guys.


I should try mumble-ruby. I tried the original one before (last year) and I was kinda saddened by it's performance. Maybe this new fork can help. But quick question about that. Does it let me stream OUT audio from the Mumble session? I only see a `cli.player.stream_named_pipe` API.


As for the suggesting to use JACK, would that mean I'd need to recompile? Cos I had issues compiling (running out of RAM on my VPS) Mumble-1.2.8. So I might have to bash my head against that a little.


I also looked again at my old setup (from the blog) and I saw some logs from ALSA when Pulse started. I am wondering if I have to install/configure ALSA which may fix things.

Link to comment
Share on other sites

Ah cool! I didn't read the code, just looked at the docs. Let me know what the API for the output pipe is.


I tried the JACK branch of Mumble and managed to make it compile (took 1GB RAM :P). But now i'm trying to get JACK running on my VPS. It doesn't seem to like the fact that there is no SoundCard. I wonder how natenom got that to work.

Link to comment
Share on other sites

Hi,


I looked into the code and noticed that a direct pipe does'nt exist anymore. But you can create a fifo.file and then use @cli.recorder.start("/path/to/fifo.file").

In my fork it seems there is an issue with sound recording (clicking noise), for opus only you can use perrym5's, there it sounds clean.


When no user speak, there will be no output, also no silent signal. This will break with ices2 stdin. You should pipe it through a player, for example aplay from alsa, first


hth

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...