Jump to content
Mumble forums

AUDIO output device problems


LPCSparc
 Share

Recommended Posts

Okay so here is my exact problem, and I have pinpointed that it seems to specifically be Mumble (at fault) and Mumble only that I have this problem with. Here is the exact synopsis:


So my overall goal is live streaming while excluding audio from Mumble in the live stream. So I set up Mumble, VAC (virtual audio cable), Open Broadcaster Software, and a program to stream (specifically Guild Wars 2, MineCraft, Perfect World, Counter Strike, etc.). I set up VAC to have 2 virtual audio cables (at a minimum for the following purposes). I set Line 1 as the default device, I set Line 2 as the default communication device. I set Open Broadcaster Software to take audio (for the live stream) from Line 1, I set Mumble to output device = Line 2. Both Line 1 and Line 2 'repeat' to my actual speakers so I hear everything. With this exact set up I should be able to hear everything over my speakers, but Mumble should be excluded from the live stream. This however is not the case. I even re-installed TS3 (teamspeak 3) to test for desired functionality. With all programs set to use "default device" as input/output VAC, TS3, Open Broadcaster Software, and a game to stream it worked just fine. I didn't even have to change any input or output devices within all of the programs to get it to successfully exclude TS3 from the "live stream audio" segment.


So I figured okay, I will implicitly tell each and every program what input/output devices to use, instead of defaults. Seeing as I prefer Mumble over TS3 (former teamspeak veteran going back to TS1, until I found out about Mumble) I would much rather have to do this, that rely on "defaults". So again I set up Mumble to "output" to VAC "Line 2", a game to output to VAC "Line 1", and the audio input for Open Broadcaster Software to VAC "Line 1". Again, I could STILL hear Mumble in my live stream audio! Not to mention this would not be optimal as most games don't allow you to implicitly configure their sound output device. Luckily, at least for testing purposes, Guild Wars 2 does! Though as I mentioned, implicitly setting output/input devices on all these programs still failed, I could still hear the Mumble audio in the live stream audio feed. So I again tested with TS3, setting TS3 output as VAC "Line 2", GW2 to output VAC "Line 1", and OBS audio input as VAC "Line 1". Again, the audio from TS3 successfully did not play in my live stream audio feed, and only over my speakers as desired.


So then I decided to attempt further testing on Mumble since Mumble already seemed to be the direct culprit of not being able to obtain the desired results. I left the output setting in Mumble to VAC "Line 2" but changed the default device and default communication device to "Line 3" (a VAC line NOT in use, and NOT re-routed to my speakers). Sure as **** when I did this Mumble was no longer in the live stream audio, AND could not longer be heard over the speakers. So in my tests, even though the Mumble audio output device was set to "Line 2" but I changed the "default device" settings in Win7 to "Line 3", Mumble started outputting to Line 3 *anyways*. I then changed the "default communication device" (in Win7) to "Line 2", still no audio in speakers or live stream feed. I then changed the "default device" (in Win7) to "Line 2" and Mumble audio was restored; in *both* my speakers and the live stream feed.


So it would seem to me that Mumble is not respecting the audio output device settings. It seems to fail to respect the "default communication device" settings of Win7, and seems to only send output to whatever device is listed as the "default" device in Win7 despite whatever else may be set in Mumble itself.


Which at the same time, I must admit, is VERY odd seeing as I have previously successfully set up a "music bot" and even a "TS patch" in Mumble previously. The music bot I can sort of understand since that's merely changing the input device, and I haven't noticed a problem with Mumble not respecting the input device settings. The music bot is very straight forward. Using VAC, a media player, and mumble: set a media players output to a VAC Line 1, set the input device for Mumble to VAC Line 1 (and open mic) - presto, music bot. Though I have also succeeded in setting up even a two way TS patch (because my guild uses Mumble, but we still wanted to be able to communicate with people on the game server that used TS). For that I would set up Mumble as TS "side by side", Set TS input to Line 1, TS output to Line 2 - Mumble input to Line 2, Mumble output to Line 1. Presto, I had an instant two way TS/Mumble "patch" - tested and fully working. People in the same channel could talk to each other just fine regardless of whether they were on TS or Mumble!


So, this is all REALLY boggling to me! Why would Mumble respect output settings in the instance when I made that Mumble => TS => Mumble "patch", but not when I'm trying to set up a live stream, and exclude the audio from Mumble from said stream?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...