Jump to content
Mumble forums

Support status of 64 bits platforms


etheric
 Share

Recommended Posts

Hello,


I am in the process of setting up a murmur server.

Target system does not support 32-bit binaries (support was not enabled in kernel).


I successfully built a 64-bit executable from source. Here is my exact build configuration:

qmake main.pro CONFIG+=no-client CONFIG+=no-ice CONFIG+=no-bonjour

I am a bit surprised to find out the generated binary is static, despite not specifying the static option, but I don't really care so…


Now, when I run it, it segfaults immediately, leaving this in the log:

<W>2015-03-18 18:51:31.188 Initializing settings from /etc/murmur/main.ini (basepath /etc/murmur)
<W>2015-03-18 18:51:31.188 Binding to address 195.x.x.x
<W>2015-03-18 18:51:31.188 OpenSSL: OpenSSL 1.0.1e 11 Feb 2013
<W>2015-03-18 18:51:31.546 ServerDB: Opened SQLite database /var/run/murmur/murmur.db
<W>2015-03-18 18:51:31.547 Generating new tables...

The murmur.db file is actually created and properly initialized (I checked the content using sqlite3 command line tool). From the output of strace, it looks like it crashes just after it is done with the database.

Qt version is 4.8.6, static build with QtGui disabled.


So here are my questions:

1) is mumurd actually supported on 64-bit platforms, compiled as 64-bit binary?

2) if so, do you have any suggestion, or is there some way I can help pinning down the issue?

Link to comment
Share on other sites

i run it on fedora 20

 

# file /usr/sbin/murmurd
/usr/sbin/murmurd: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=0d3e1afcdd93c59ea29cdad7820daf03f13c212e, stripped

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...