Jump to content
Mumble forums

Register User greyed out


Scorpion2k
 Share

Recommended Posts

Yesterday I bought a voice server through a rental service. I want to use it privately with some friends so I'm using a server password.


I want to register users so they don't have to type the password.


So I logged in as a SuperUser. I edited the channels like this:


Scorpion2k: Server

<>Hangout

<>Away


With the following ACL for Scorpion2k: Server:

@all

- Greyed out

@all (Inherit ACLs) / (Applies to this channel)

- Enter Disable

@all (Inherit ACLs) / (Applies to sub-channels) / (Applies to this channel)

- Register User Allow

- Register Self Allow

@admin

- Write ACL Allow

- Speak Allow

@auth

- Make Temporary Allow


But I can't register users. When logging in the first time I accepted the certificate but Self --> Register stays grey. Also can't select it through SuperUser. Any advice? I'm out of options...

Link to comment
Share on other sites

  • Moderators

What client versions?


It used to be if you cancelled the certificate wizard after installing, you would end up with a client with no certificate, and you couldn't register yourself (because no certificate).


Quite some time ago this was changed so that if you cancelled the wizard, Mumble would just silently generate a self-signed cert, and so this scenario shouldn't really happen any more.

Full disclosure: I used to run a commercial Mumble host, and my opinions do not reflect the opinions of the Mumble project.

Avatar is stolen from here

Link to comment
Share on other sites

Thank for accepting my question.


I just used Server --> Information and it says the following about the server:

- 1.2.8 (X11)

- FreeBSD 10.1-RELEASE-p5

- Furthermore I use the Mumble 1.2.8 client.


Your reaction gave me the idea to uninstall mumble and install again. It did not work because all my settings were still there. Then I uninstalled with Revo Uninstaller pro. I removed Mumble from %AppData\Roaming\Mumble and Regedit (HKCU\Software\Mumble). I downloaded Mumble 1.2.8. again and connected to my server.


It asked for a certificate again which I accepted and the Register option wasn't grey anymore. I succesfully registered my account.


My problem is solved now. Thank you for the nudge!

Link to comment
Share on other sites

Me again. I was just setting up my new installation of Mumble again. Now I know why it didn't work.


My previous post wasn't the answer. It was the setting "Network" and "Suppress certificate and password storage". Never noticed it before. Can't remember switching it on. This wasn't turned on by default with my new install. That's why it worked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...