Jump to content
Mumble forums

No incoming sound after crash, but mic works


antiventura
 Share

Recommended Posts

Hi all, I had a really strange issue happen to me twice yesterday when I first tried to install and use Mumble v1.2.2.


First off, here are the details of my setup:


PC Brand and OS: Dell Studio 17 Laptop, Genuine Windows® 7 Home Premium, 64bit, English

Processor: Intel® Core™ i7-720QM Quad Core Processor 1.6GHz (2.8GHz Turbo Mode, 6MB Cache)

RAM: 4GB Shared Dual Channel DDR3 at 1333MHz

Sound Card: High Definition Audio 2.0 (that’s all it says on the order slip)

Headset: Rocketfish Bluetooth – behind-the-neck (RF-MAB2)

The headset is connected via a Rocketfish Micro Bluetooth Adapter (I believe model number RF-MRBTAD)

This was all running with World of Warcraft 3.3.5


And here’s what happened:

The install went ok initially. The only problem I had there was that during parts of the Audio Wizard, a piercing noise would go into my ear (like a pulsing feedback). This only occurred while I was looping my own voice, so I figured it was simply because the mic and earpiece were so close together. It went away when I exited the Wizard.


After the install, I was able to converse normally with everyone. I use Push-to-Talk, so I don’t know if the feedback thing would still have been an issue.


I then went into the program to mess with a couple audio settings and the program hung up. I closed it out and restarted it, and then all I heard was some very faint popping noises coming out as soon as the program launched. As long as the program was running, that very faint popping noise (think old vinyl record player after the music is done) overrode all other sounds on my machine. This included Windows sounds, WoW sounds, anything. When the program had been running normally prior to the hang up, this wasn’t the case.


I logged onto our server, and everyone could still hear what I was saying. All I could hear was that faint popping, though. I checked the audio settings and they were the same as when they were working. I also closed the program and logged to Vent just to make sure some system settings hadn’t gotten screwed up, but everything worked fine there.


After messing around with it for over an hour, I was finally able to get it working again by completely uninstalling the program (settings and all), rebooting the machine, establishing the Bluetooth connection, and then re-running the setup.


Of course, not too long after that I tinkered with the settings again and the same thing happened. This was while connected to our server and others were talking, so that may be a bad time to do that. I can just avoid messing with the settings, but I’m still concerned that it could bomb again at an inopportune time, since that’s not really “fixing the problem”. The only other thing I can think to do is update the driver for my soundcard. If anyone can think of any other possible fixes, please let me know.

Link to comment
Share on other sites

From last night:


I was able to log in and speak normally last night with about 10 others in channel. After about 15-20 minutes, however, I noticed my sound went out again (same as above). This time I made a point not to touch any settings, menu options, etc in Mumble once I got it connected, but the issue happened anyway.


I guess I should look into how bluetooth works? Could it be dropping connection, causing the program to have to switch between output devices? I had to mess with my output devices (set computer speakers to default and then headset back to default) to get the sound to work again once I closed down Mumble.

Link to comment
Share on other sites

  • Administrators

If the bluetooth device does indeed drop the connection and goes away Mumble will loose it's input and output device and won't be able to in or out sound until its audio engine gets reset (opening the config and pressing ok does that and I think you can also define a shortcut for that).


If you are using our snapshots make sure you have exclusive mode disabled in Mumble's audio input/output configuration. It is known to cause problems with a lot of devices with bad drivers.


Apart from that you could try playing around with the audio settings your driver offers as well as the ones available in our input/output tab to see if anything makes a difference.


I'm sorry for not having a better solution at this point but such behaviour is pretty much always caused by misbehaving drivers, is very erratic and impossible for us to debug.

Link to comment
Share on other sites

Thanks for the suggestions!


Yeah, I figured it wouldn't be easy to determine the problem with this one. Before I try those suggestions, I'm going to see if I can isolate it to the headset. I borrowed an older USB wired headset and will give that one a try tomorrow. If it works fine, then I can assume it's definitely a conflict with the bluetooth headset and not something else on my PC. I'll keep you guys posted.

Link to comment
Share on other sites

Report from last night:


After swapping out the bluetooth headset for a standard wired Logitech USB headset, this issue went away completely. I was able to run Mumble for a couple hours with no issues at all.


I'll continue to work with that bluetooth headset and see if I can get it working with Mumble. If I find a way, I'll let you know here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...