Jump to content
Mumble forums

I can't be heard on my server, but I can hear everyone else


shakymaky
 Share

Recommended Posts

Hi! So I'm new to Mumble and I've been trying to set up a server but I've run into an issue. I follow the guides and set everything up like I'm supposed to and both me and my friends are able to connect to my server. However, the problem is that while I can hear my friends, they can't hear me, despite the fact that the mouth icon in Mumble shows me as broadcasting. So I looked it up and found out that I could use the "loopback" function to check where the issue was. When I set the loopback to local I can hear myself just fine (so the problem is not my microphone), but when I set it to server it goes completely quiet, i.e. my voice is not being sent to the server. I thought this was weird, and I sent my friend the exact same ini file I used to host the server and told him to try hosting it, and when he did he could hear me, but I could not hear him... Both of us have forwarded our ports, so that does not seem to be the issue.


So what I then tried was installing a mumble server on my Raspberry Pi connected to my router. Same thing there, I can't hear myself on server loopback. So what I tried on a hunch was to join the Pi server using a VPN and voila, it worked.... So I'm assuming this problem is IP related somehow but I have absolutely zero idea how I'm supposed to fix this and hours of googling have not given me a solution to this problem. Any help with this issue would be appreciated, or else I'll just have to stick to Skype...

Link to comment
Share on other sites

  • Administrators

(Only skimmed this block of text :) )


Mumble for networking uses TCP for the control channel, and UDP for voice packets.


Given that you connect, get status updates and messages, TCP is fine.

Given that others can hear you, the UDP communication from you to the server is fine as well.

Given that you can not hear others, some part of your networking blocks *incoming* UDP packets.


In the case of you self-hosting the server, I’m not sure I grasped that. Either way, I would try to fix the above issue first; find out which router/firewall may block packets.

Maybe that’s where the whole issue lies.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...