Jump to content
Mumble forums

CentOS 7 installation problem


kraig
 Share

Recommended Posts

Hello, I have a CentOS 7 64bit installation.


I downloaded the current static linux server (v 1.2.10) and I followed the guide found on the wiki http://wiki.mumble.info/wiki/Install_CentOS7. First, I would like to say that I believe the line

 

sudo systemd-tmpfiles --create /etc/tmpfiles.d/

is an error and it should be


sudo systemd-tmpfiles --create /etc/tmpfiles.d/murmur.conf


but I could be wrong. The first one gives an error complaining that the file is a directory (it expect a file).


However, even after following the guide, I couldn't start the service, complaining of a permission error on murmur.x86.


http://i.imgur.com/hO7ZiT0.png


I tried with permission root:root 700, root:root 777, and even murmur:murmur 777, but I was having the same permission error.


I would be very glad if someone know how to make it work and that we update the guide.

Link to comment
Share on other sites

  • Moderators

Please get out of the habit of using 777 as an attempt to fix something, particularly if it's an internet-facing box or has multiple untrusted users, and particularly if it's an executable that's likely to be run suid root. You're basically asking for the machine to get rooted. If it doesn't work with 755 or 775, it's not gonna work with 777. If it's the database you need write permissions to, and 644 isn't good enough, the solution is changing the owner not widening permissions more.


Having said that, I've not used CentOS in ages... but is this perhaps an x86/amd64 thing? Did you disable SELinux as suggested in the guide?

Full disclosure: I used to run a commercial Mumble host, and my opinions do not reflect the opinions of the Mumble project.

Avatar is stolen from here

Link to comment
Share on other sites

Thank you for your concern. root ssh login is disabled, password login is disabled and only private keys are accepted, only two ports are open (ssh and murmur) and firewalld closed the rest, and I've got umask set to 077 for good measure and only one key so far is allowed on the server (one user account too!).


Yes, SELinux has been disabled, thank you for your suggestion.


I actually rebooted the machine (unrelated issue) and gave murmur.x86 755 permission and Murmur.ini 644, which allowed me to start the server. I assume it didn't worked with 755 the first time because I didn't bothered going back to journactl to see it complain about reading permissions on the .ini instead of the executable, my bad.


I'll see how I could give my "murmur" system account read+excute permission on those files without allowing all accounts. Thanks again for your suggestion and comments.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...