Jump to content
Mumble forums

bind to wrong ip


ash_1_2
 Share

Recommended Posts

Hey guys,


I am having a bit of trouble with mumble server.


When trying to connect to it with a cleint i get the following error: Server connection failed: Connection refused.


I did some search on the server and reliased that is binding to "127.0.0.1:64738" even though i have set ito to bind to 192.168.0.120


I would be greatful for any help =D

 

<W>2010-07-25 06:51:24.977 Log rotated successfully
<W>2010-07-25 07:59:39.013 Initializing settings from /etc/mumble-server.ini (basepath /etc)
<W>2010-07-25 07:59:39.013 Binding to address 192.168.0.120
<W>2010-07-25 07:59:39.059 SSL: Added CA certificates from '/etc/ssl/certs/ca-certificates.crt'
<W>2010-07-25 07:59:39.085 ServerDB: Openend SQLite database /var/lib/mumble-server/mumble-server.sqlite
<W>2010-07-25 07:59:39.101 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running
<W>2010-07-25 07:59:39.228 Murmur 1.2.2 (1.2.2-1ubuntu1) running on X11: Ubuntu 10.04.1 LTS: Booting servers
<W>2010-07-25 07:59:39.239 1 => Binding to address 127.0.0.1
<W>2010-07-25 07:59:39.259 1 => Server listening on 127.0.0.1:64738
<W>2010-07-25 07:59:39.277 1 => Announcing server via bonjour
<W>2010-07-25 07:59:39.296 1 => Registration needs nonempty 'registername', 'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.
<C>2010-07-25 08:01:37.655 Caught SIGTERM, exiting
<W>2010-07-25 08:01:37.656 Killing running servers
<W>2010-07-25 08:01:37.673 1 => Stopped announcing server via bonjour
<W>2010-07-25 08:01:37.710 1 => Stopped
<W>2010-07-25 08:01:37.711 Shutting down
<W>2010-07-25 08:01:37.712 MurmurIce: Shutdown complete
<W>2010-07-25 08:01:40.093 Initializing settings from /etc/mumble-server.ini (basepath /etc)
<W>2010-07-25 08:01:40.093 Binding to address 0.0.0.0
<W>2010-07-25 08:01:40.138 SSL: Added CA certificates from '/etc/ssl/certs/ca-certificates.crt'
<W>2010-07-25 08:01:40.167 ServerDB: Openend SQLite database /var/lib/mumble-server/mumble-server.sqlite
<W>2010-07-25 08:01:40.182 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running
<W>2010-07-25 08:01:40.292 Murmur 1.2.2 (1.2.2-1ubuntu1) running on X11: Ubuntu 10.04.1 LTS: Booting servers
<W>2010-07-25 08:01:40.306 1 => Binding to address 127.0.0.1
<W>2010-07-25 08:01:40.329 1 => Server listening on 127.0.0.1:64738
<W>2010-07-25 08:01:40.342 1 => Announcing server via bonjour
<W>2010-07-25 08:01:40.371 1 => Registration needs nonempty 'registername', 'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.

 

Thanks

Link to comment
Share on other sites

  • Administrators

2010-07-25 08:01:40.093 Binding to address 0.0.0.0

So the server does bind to all ips.

In fact, the error msg indicates that the server actively rejected your join-request.


Are you running Mumble 1.1.x and are trying to connect to Murmur 1.2.x?


Also, is that IP set as your PCs ip?

If it can't statically bind to it, maybe that's why it uses localhost.

If you don't use more than one IP and want it to be public just leave it to bind to any available ip.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...