This is a read-only archive of the Mumble forums.

This website archives and makes accessible historical state. It receives no updates or corrections. It is provided only to keep the information accessible as-is, under their old address.

For up-to-date information please refer to the Mumble website and its linked documentation and other resources. For support please refer to one of our other community/support channels.

Jump to content

Asus HS-W1 and WASAPI not playing nice with each other


Recommended Posts


I want to report and maybe help if I can a problem with this headset and the WASAPI on windows 10.

I can't listen and record at the same time while I have no problem at all on Linux with that.

The XP compatibility "fix" the problem as a new one emerge : people hear themselves talk.

I'm ready to dive in some code if needed, but I need help at least to isolate the source of the problem.

Link to comment
Share on other sites

  • 2 weeks later...
  • Administrators

Hi teldar,

We need to get the log output to investigate your issue.

Please try to start Mumble (in non-XP-compat mode) with WASAPI, and try to use it as you would normally.

Then open %APPDATA%\Mumble\Console.txt and paste the log from your session in here.


Link to comment
Share on other sites

Hi mkrautz,

Thanks for the reply, here is the console log as you requested :


<W>2015-10-19 00:13:44.990 DirectSound: Disabled as WASAPI is available
<W>2015-10-19 00:13:44.991 ASIO: No valid devices found, disabling
<W>2015-10-19 00:13:45.016 G15LCDEngine_lglcd: Logitech LCD Manager not detected.
<W>2015-10-19 00:13:45.018 CELT bitstream 8000000b from C:/Program Files (x86)/Mumble/celt0.0.7.0.sse2.dll
<W>2015-10-19 00:13:45.018 CELT bitstream 80000010 from C:/Program Files (x86)/Mumble/celt0.0.11.0.sse2.dll
<W>2015-10-19 00:13:45.019 Locale is "fr_FR" (System: "fr_FR")
<W>2015-10-19 00:13:45.055 Database SQLite: "" 
<W>2015-10-19 00:13:45.056 Bonjour: Failed to load dnssd.dll
<W>2015-10-19 00:13:45.621 Overlay: Listening on "\\.\pipe\MumbleOverlayPipe" 
<W>2015-10-19 00:13:45.755 GlobalShortcutWin: No LowLevelHooksTimeout registry key found.
<W>2015-10-19 00:13:45.938 AudioInput: 40000 bits/s, 48000 hz, 480 sample
<W>2015-10-19 00:13:45.942 WASAPIInput: Latencies 100000 100000 => 100000
<W>2015-10-19 00:13:45.943 WASAPIOutput: Latencies 100000 100000 => 100000
<W>2015-10-19 00:13:45.944 WASAPIOutput: Subformat is not IEEE Float: hr=0x00000000
<W>2015-10-19 00:13:45.949 Adding device {6f1d2b60-d5a0-11cf-bfc7-444553540000} Souris Souris:8
<W>2015-10-19 00:13:45.950 Adding device {6f1d2b61-d5a0-11cf-bfc7-444553540000} Clavier Clavier:126
<W>2015-10-19 00:13:45.950 WASAPIInput: Stream Latency 0 (1056)
<W>2015-10-19 00:13:45.951 AudioInput: Initialized mixer for 1 channel 48000 hz mic and 0 channel 48000 hz echo
<W>2015-10-19 00:13:45.951 Adding device {bbe2c510-072a-11e5-8004-444553540000} ASUS Wireless Radio Control ASUS Wireless Radio Control:1
<W>2015-10-19 00:13:45.953 Adding device {4b696510-6c50-11e5-8002-444553540000} Wireless Audio Wireless Audio:5
<W>2015-10-19 00:13:45.964 Adding device {bbe2c510-072a-11e5-8001-444553540000} USB Receiver USB Receiver:652
<W>2015-10-19 00:13:45.967 Adding device {bbe2c510-072a-11e5-8002-444553540000} USB Receiver USB Receiver:3
<W>2015-10-19 00:13:48.766 OpenSSL Support: 1 (OpenSSL 1.0.1p 9 Jul 2015)
<W>2015-10-19 00:13:48.776 SSL: CA certificate filter applied. Filtered size: 88, original size: 88
<W>2015-10-19 00:13:48.777 ServerHandler: TLS cipher preference is "ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:AES256-SHA:AES128-SHA"
<W>2015-10-19 00:13:48.779 ServerHandler: QOS2 loaded


I did the same test as before, and people can hear me but I can't hear them if I use the same device for input and ouput with this headset.

Link to comment
Share on other sites

  • Administrators

I believe the issue you are seeing is fixed in current development snapshots.

You can download Devlopment Snapshots from

Please report back if using a snapshot fixes the issue. Thank you!

EDIT: The commit that fixed the issue was

Link to comment
Share on other sites

You were right, using the latest development snapshot solved the problem for me.

Thanks for the help.

I appreciate the link to the commit. I was not aware that the current stable version of mumble did not support 16 bits PCM output on the WASAPI. But given the error line you singled out and the commit, it was indeed the case.

Link to comment
Share on other sites


  • Create New...