Jump to content
Mumble forums

get murmur in the public server list?


otom24
 Share

Recommended Posts

Hi,


i try to list our mumble-server in the public server list for about 1 week, searched a lot of topics and tried a lot of things - without success.


Server runs on Debian Lenny stable, only mumble is updated with the latest unstable sources from "deb ftp://ftp.de.debian.org/debian/ sid main contrib non-free" - i think the mumble-server is 1.2.3 unstable and we all use the latest 1.2.3 developer snapshot as client to connect.


This is what shows up when i get the config via putty:

dbus-send --system --print-reply --dest=net.sourceforge.mumble.murmur --type=method_call / net.sourceforge.mumble.Meta.getAllConf int32:2

method return sender=:1.271 -> dest=:1.274 reply_serial=2
array [
     dict entry(
        string "certificate"
        string "-----BEGIN CERTIFICATE-----
      #blanked out#
-----END CERTIFICATE-----
"
     )
     dict entry(
        string "host"
        string "[iP blanked out]"
     )
     dict entry(
        string "key"
        string "-----BEGIN RSA PRIVATE KEY-----
     #blanked out#
-----END RSA PRIVATE KEY-----
"
     )
     dict entry(
        string "port"
        string "64738"
     )
     dict entry(
        string "registerHostname"
        string "[iP blanked out]"
     )
     dict entry(
        string "registerName"
        string "KSK Tactical Gamers"
     )
     dict entry(
        string "registerPassword"
        string "#blanked out#"
     )
     dict entry(
        string "registerUrl"
        string "http://ksk-pr.de.vu"
     )
     dict entry(
        string "welcometext"
        string "<h2>KSK Tactical Gamers </h2><p>Keiner sieht sie kommen. Keiner weiß, daß sie da sind.<br />Und wenn ihre Mission beendet ist, gibt es keinen Beweis dafür, daß sie jemals da waren.</p><p> </p><p><strong>Homepage:</strong> <a href=http://ksk-pr.de.vu>http://ksk-pr.de.vu</a></p><p> </p><p><img src=http://ksk-pr.strangled.net/cms/images/slideshow/frog.jpg /></p><p> </p><h3> </h3>"
     )
  ]

-> #blanked out# = deleted by me in the post

-> the serverID 2 ist the right one for sure


This is the global config with putty command:

dbus-send --system --print-reply --dest=net.sourceforge.mumble.murmur --type=method_call / net.sourceforge.mumble.Meta.getDefaultConf

method return sender=:1.277 -> dest=:1.284 reply_serial=2
  array [
     dict entry(
        string "allowhtml"
        string "true"
     )
     dict entry(
        string "bandwidth"
        string "96000"
     )
     dict entry(
        string "bonjour"
        string "true"
     )
     dict entry(
        string "certificate"
        string ""
     )
     dict entry(
        string "certrequired"
        string "false"
     )
     dict entry(
        string "channelname"
        string "[ \-=\w\#\[\]\{\}\(\)\@\|]+"
     )
     dict entry(
        string "defaultchannel"
        string "0"
     )
     dict entry(
        string "host"
        string "0.0.0.0"
     )
     dict entry(
        string "key"
        string ""
     )
     dict entry(
        string "obfuscate"
        string "false"
     )
     dict entry(
        string "password"
        string ""
     )
     dict entry(
        string "port"
        string "64738"
     )
     dict entry(
        string "registerhostname"
        string "[iP blanked out]"
     )
     dict entry(
        string "registername"
        string "KSK Tactical Gamers"
     )
     dict entry(
        string "registerpassword"
        string "1234usmarinechor"
     )
     dict entry(
        string "registerurl"
        string "http://ksk-pr.de.vu"
     )
     dict entry(
        string "textmessagelength"
        string "5000"
     )
     dict entry(
        string "timeout"
        string "30"
     )
     dict entry(
        string "username"
        string "[-=\w\[\]\{\}\(\)\@\|\.]+"
     )
     dict entry(
        string "users"
        string "100"
     )
     dict entry(
        string "welcometext"
        string "<br />Welcome to this server running <b>Murmur</b>.<br />Enjoy your stay!<br />"
     )
  ]
curie:~#

 

But it do not show up in the public server list, i already waited now with these settings for 3 days (guessed a DNS update)


There was a password set before, i deleted the password with that command via dBus:

dbus-send --system --print-reply --dest=net.sourceforge.mumble.murmur --type=method_call / net.sourceforge.mumble.Meta.setConf int32:2 string:"serverpassword" string:""


The Mumble Ports are open via iptables:

[...snip]
-A INPUT -p tcp -m state --state NEW -m tcp --dport 443 -j ACCEPT 
-A INPUT -p tcp -m state --state NEW -m tcp --dport 64738 -j ACCEPT 
-A INPUT -p udp -m state --state NEW -m udp --dport 64738 -j ACCEPT 
[snap...]

 

Anyone got a hint for me how to list our mumble-server public, or anyone see errors i made with the config?

And how do the mumble-servers match to the country? By ip-range?


Regards tOm

Edited by otom24
Link to comment
Share on other sites

Hello,


if it helps, here is the server log after i reinstalled murmur.

 

<W>2010-08-18 13:57:00.754 Initializing settings from /etc/mumble-server.ini (basepath /etc)
<W>2010-08-18 13:57:00.784 SSL: Added CA certificates from '/etc/ssl/certs/ca-certificates.crt'
<W>2010-08-18 13:57:00.801 ServerDB: Openend SQLite database /var/lib/mumble-server/mumble-server.sqlite
<W>2010-08-18 13:57:00.811 DBus registration succeeded
<W>2010-08-18 13:57:00.822 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running
<W>2010-08-18 13:57:00.823 OSInfo: Failed to execute lsb_release
<W>2010-08-18 13:57:00.824 Murmur 1.2.2 (1.2.2-4+b1) running on X11: Linux 2.6.20.4-1-686-clusters_smp: Booting servers
<W>2010-08-18 13:57:00.840 1 => Binding to address [iP blanked out]
<W>2010-08-18 13:57:00.848 1 => Server listening on [iP blanked out]:64738
<W>2010-08-18 13:57:00.856 1 => Announcing server via bonjour
<W>2010-08-18 13:57:00.874 2 => Binding to address [iP blanked out]
<W>2010-08-18 13:57:00.882 2 => Server listening on [iP blanked out]:64738
<W>2010-08-18 13:57:00.911 2 => Announcing server via bonjour
<W>2010-08-18 13:57:10.907 2 => Starting voice thread
<W>2010-08-18 13:57:10.912 2 => CELT codec switch ffffffff8000000b 0 (prefer ffffffff8000000b)
<W>2010-08-18 13:58:34.076 1 => Registration failed: SSL handshake failed

 

Registration failed: SSL handshake failed

-> do i have to change the ssl certificate?


Regards otOm

Link to comment
Share on other sites

  • 2 weeks later...

Hi again,


i visited the #mumble IRC channel a few days ago and got some useful info about that issue. There is some kind of bug or incompatibility with newer OpenSSL packages - and it is resolved in newer git snapshots of the mumble-server. My OpenSSL version is 0.9.8g-15+lenny6, the newest Version of the Mumble-Server in the Debian sid package is atm 1.2.2-4+b1 - with this combination it seems to be impossible to register a mumble-server as public.


I have to wait until there are newer packages available for Debian or i have to compile the newest git-snapshot by myself. But that seems to be too difficult for me :roll:. This http://mumble.sourceforge.net/BuildingLinux is not working, qmake and qmake-qt4 is freaking me up somehow ...


Regards otOm

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...