Jump to content
Mumble forums

Unknown Speex_Preprocessor_ctl error


Grandpa-G
 Share

Recommended Posts

Running Mumble on Raspberry Pi with terminal window so I see all the console message. I get this error with the number 25 or 36 repeated about every second or so. I hate just ignoring errors. I built mumble from source using the instructions given in the Mumble docs.


What, if anything, is wrong?

Grandp-G

Here from the beginning.

Link to comment
Share on other sites

  • 2 weeks later...
  • Administrators

There should be no problem using the floating point mode of SpeexDSP on Raspberry Pi -- except for the fact that the Raspbian pre-built version is built without it.


You should be able to build it from source with ./configure --enable-float (I believe that's what the configure option is called -- maybe something else, check the --help!)


Alternatively, you can build Mumble with qmake -recursive main.pro CONFIG+="release bundled-speex bundled-celt bundled-opus" to skip the system's Speex/CELT/Opus libraries!


If you encounter any problems, feel free to follow up. Someone will probably be able to help you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...