Jump to content
Mumble forums

New bugs as of March 2, 2016


quixadhal
 Share

Recommended Posts

So, I've used mumble for years now. I've run my own servers for friends to use, and I've used the client to chat with much larger groups. I even helped talk my large gaming guild into switching to mumble a few years back. So, thank you devs for making such a useful product!


Now, the reason I'm posting here is a shiny new bug that has manifested in the last couple of days. It seems to be related to the recent WIndows 10 updates from March 1st, 2016.


Cumulative Update for Windows 10 Version 1511 for x64-based Systems (KB3140743)

Update for Windows 10 Version 1511 for x64-based Systems (KB3139907)


I was using mumble with my game, as usual, and noticed it said there was a newer version available. I had been running 1.2.13, and so I went ahead and updated to 1.2.14. The update wanted me to reboot, because something had a file locked (Microsoft's Skype service, I think), and so I went ahead and let it.


During the reboot cycle, I noticed the new windows updates being applied.


After reboot, I started mumble again, and noticed that the push-to-talk key no longer worked. Strange... I'd had it bound to ALT-8 (which my mouse sends when I hit button 8), and it was working fine before that. I went to adjust the settings and it utterly ignored all keyboard and mouse events at that point.


That is to say, the client kept working, and I could type into the chat window, but clicking the column to set the keybind for the PTT event would not work. It only recognized right-click to abort the operation.


So, I uninstalled and reinstalled an older version. I tried one from 2 years ago. I tried the newest 1.3.0 beta. I did full wipes of the registry and %APPDATA% areas. Reboots aplenty. No luck.


I also noticed mumble liked to crash a bit more often, not quite sure exactly what makes it crash now, but I suspect it's linked to the above issue.


It may well be a change in the way driver events are propogated to applications, but so far mumble is the ONLY one to have any problems with it. One other thing I noticed, after quitting mumble, it leaves behind a process that sits there spinning and holds one CPU core at 100% forever. I left it run overnight just to see if it was actually trying to DO something. My guess is, that's a thread that would be handling the PTT events and it is stuck trying to get a resource it can no longer just grab.


Sorry for the wall of text, but I wanted to try to describe what was happening as well as I could. Unfortunately, with Windows 10, you can't just roll back an unwanted (or unstable) patch. Well, you can, but Microsoft will force you to apply it later anyways.... so I haven't tried that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...