Jump to content
Mumble forums

Odd Frequency Cut Off Mute


Omicron
 Share

Recommended Posts

I'm trying to track down an issue which only seems to occur when I am running Mumble under Windows 7 x64. For reference, I have attenuation disabled, no muting enabled for applications under the sound mixer, and all "sound enhancements" turned off.


When Mumble is not running, all applications seem to work fine whether they are Wasapi, DirectSound, or Windows Wave mixer based. However, when I have Mumble running, I start to run into this very strange issue.


Any sound in the background that is either under a certain intensity, or has a certain range of frequencies, sounds oddly muted or as if it is no longer in stereo. However, once the sound is loud enough, it "re-stereos" and is normal. You can imagine though how bad things sound as they constantly cut between this poor quality and normal quality mode.


This is fully repeatable as the same segments of songs will have the exact same "switching" points where they will sound lo-fi and normal again.


When Mumble is not running, this goes away completely. However, I am not sure what it is being caused by other than my drivers possibly fighting with how Mumble is configured. This seems to strike me as ducking/attenuation still being enabled somehow even though it is "off" in the GUI.


Is there a way to shut the ducking item totally off without having to modify and recompile the code? :|

Link to comment
Share on other sites

Yeah, nothing seems to stop this. Regardless of whatever setting I have selected for the attenuation section, it continues to force "muffle" other programs. If I press "apply" it quickly unmutes and fades back to the mute, so it is definitely Mumble.


I found this forum thread which seems vaguely relevant:

https://sourceforge.net/p/mumble/discussion/492607/thread/1f1f9e9d/?limit=25


However, I am using a Conexant 20672 audio chipset on a T420, none of these weird fancy audio cards. Isn't there some sort of registry setting or ini addition I can use to completely disable this ducking thing?


I like Mumble a lot, but this is annoying.


Maybe I can try forcing it to use DirectSound instead? It doesn't seem to want to let me, and even though WASAPI is a better method, I'd rather get rid of this problem first.


Just tested it by forcing it into WinXP mode (which makes it use DirectSound instead.) This doesn't seem to fix anything, but makes the issue less aggressive. Totally goes away when Mumble is off though, any ideas?

Link to comment
Share on other sites

For those trying to figure this out, turn off signal enhancements under your microphone tab. Thought only attenuation or audio enhancements under the playback device did this, but the microphone can cause the problem as well.


This solved the issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...