Jump to content
Mumble forums

Circumvent ISP Blocking


emadramlawi
 Share

Recommended Posts

Hello Support and Community,


I have an awe-full issue, I reckon it is caused due to I live in developing 3rd world country that loves to dissect communities instead of connecting them.


I googled and this seem to be an issue affecting MENA region especially UAE.


I'm very PC savvy person, and work in I.T field.


So here is the issue :


1) I open port on my router and made sure it is open, when I start Murmur. My computer Internal IP is 192.168.0.100 and at the time of writing public IP is 92.253.58.157

1708879888_2016-06-0711_29_34-DSLRouter.thumb.png.32202224d495c7d8b4e919d7aded54e7.png

22.thumb.png.51df1861c93be1f55188d8f3785fd4de.png

 

2) I start murmur with the following config entries changed from the default entries


autobanAttempts = 0

port=64738

host=

bandwidth=72000

serverpassword=medo

users=8

certrequired=False


Murmur starts with the following log :

 

<W>2016-06-07 11:40:48.759 Initializing settings from C:/Program Files (x86)/Mumble/murmur.ini (basepath C:/Program Files (x86)/Mumble)
<W>2016-06-07 11:40:48.765 Meta: TLS cipher preference is "ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:AES256-SHA:AES128-SHA"
<W>2016-06-07 11:40:48.765 OpenSSL: OpenSSL 1.0.1t  3 May 2016
<W>2016-06-07 11:40:48.777 SSL: CA certificate filter applied. Filtered size: 86, original size: 86
<W>2016-06-07 11:40:48.778 ServerDB: Opened SQLite database C:/Program Files (x86)/Mumble/murmur.sqlite
<W>2016-06-07 11:40:48.781 Murmur 1.2.16 (1.2.16) running on Win: 6.1.7601.1: Booting servers
<W>2016-06-07 11:40:48.792 1 => Server listening on [::]:64738
<W>2016-06-07 11:40:48.798 1 => Server listening on 0.0.0.0:64738
<W>2016-06-07 11:40:48.801 Bonjour: Failed to load dnssd.dll
<W>2016-06-07 11:40:48.805 1 => Not registering server as public

 

3) Okay time to connect, which is very weird behavior. I can see that it tries to connect, but fails I can see IP entry gets created in the log but server keeps disconnecting and never connects. If i try a client using my Home WiFi it will work 100%, however if a client uses a different network he will be able to retrieve the server name and ping it and find out number of seats but never connects as seen in the below image, where I showcase this using my work machine which I can RDP remote connect to

 

666.thumb.png.790f563ab4afc86994fb3e31efb01170.png

 

I installed mumble there, and connect to server using my public IP 92.253.58.157


I tried using mumble/murmur latest stable and latest dev, and even old builds = same results. also tried using different OS, like Ubuntu server, also tried using the proxy option but that didnt work, and why would I need proxy I am able to port forward successfully .


How can they block mumble/murmur if i use different port, how does the ISP know I am running Murmur on the fly ??? which I tried and it have the same results and the port is 100% open, is the server broadcasting its name ? can we try special build for Murmur using different name ? for example I know HFS web server broadcast it self as HTTP file server in its headers, can the developers help me out and obfuscate certain elements. I am free to test this out and even provide remote access to my machine if required.


Do note sometimes I cant connect to mumble main web site like yesterday and I had to use proxy, but today it is working fine.

Link to comment
Share on other sites

  • Moderators

If your ISP are using Deep Packet Inspection to pick up any OpenSSL connections (I'm assuming that's what they'd be doing) then there's probably not much that can be done. :(

Full disclosure: I used to run a commercial Mumble host, and my opinions do not reflect the opinions of the Mumble project.

Avatar is stolen from here

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...