Jump to content
Mumble forums

Mumble Reducing Audio Quality when client is open (MacOS X)


cox
 Share

Recommended Posts

Hi there,


I am having an issue which sounds very much like this unresolved issue: https://forums.mumble.info/viewtopic.php?f=4&t=1763&p=5978


I recently got a Bluetooth Headset—Bose QuietComfort 35. With the Mumble client not open, when I listen to Spotify (or Chrome, or any other audio source) the audio is crystal clear.


When I open the Mumble client all the audio which is received by the headset, whether it be Mumble VoIP audio or Spotify or anything else output by the computer, the quality is very low. Essentially it sounds as if my Spotify audio is coming in over the VoIP connection.


I'm running MacOS X 10.10.5 and Mumble 1.2.16 (as well as Mumble 1.3 snapshot—I've tried both).


It seems as if when Mumble is open it "takes over" all of the audio and compresses it to VoIP quality even though its not sending it!



I have tried:

- Mumble 1.3

- Disabling positional audio

- Changing input and output audio devices to every combination of selection (Default Device, Bose Quiet Comfort, Built-In Audio, Airplay)


Any help diagnosing would be much appreciated.

Link to comment
Share on other sites

  • 11 months later...

Its the resampling of MACOS which is enabled by default when two programs with audio outputs that differ in sample rate play concurrently. Because an output sound device can only accept one rate at any given time, one source has to be resampled, or in some instances, both sources - operating system resampling isn't usually very good and in fact i'd prefer if the industry would settle on one rate once and for all, so this sample rate MESS can piss off.

Resampling should avoided where possible.


I've tried to raise this issue with the developers but it doesn't seem like this problem is being taken very seriously....


https://forums.mumble.info/viewtopic.php?f=2&t=3172&p=8498#p8498

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...