Jump to content
Mumble forums

Every client showing my own IP on local server


khalonen
 Share

Recommended Posts

Recently after many years of hosting my own server, I had to ban user.. So this created a ban for my own public IP and no user could connect to the server? I managed to remove the ban but started to dig why it is that way.


My Murmur is version 1.2.16 and behind NAT, static LAN IP, bound to that address 192.168.1.5:13862 in murmur.ini. Port 13862 is forwarded from my router and users can connect and talk no problem, however when looking information from users they all show my own public IP as their IP address. And when I ban one, it will ban all clients as for server it looks they all come from the same IP.

When I do "netstat -a" on the server machine, murmur connections look like this:

          Local                    Foreing
TCP    192.168.1.5:13862      line-10888:25563       ESTABLISHED
TCP    192.168.1.5:13862      line-10888:47773       ESTABLISHED
TCP    192.168.1.5:13862      line-10888:56299       ESTABLISHED

 

My networking skills arent enough, is this some sort of routing thing in my router or what does that "line-10888" mean? I do run web and game servers behind the same NAT without problems.

Link to comment
Share on other sites

  • Administrators

Huh, I would expect NAT to work just fine.


The router maps specific ports to specific hosts. The connections are still end-to-end. So I don’t know what is going on there.


You can pass the -n option to netstat to display numerical addresses. Maybe that helps identifying the IP device of the connection.

Link to comment
Share on other sites

Thank you,


nestat -n told me that "line-10888" just resolves to my public IP..

Further investigation show that this is not Mumble issue. This same behaviour happens on all my servers behind my NAT. (2 games, ftp and web). Their log files are just full of my own public IP address. I did reset my router (Inteno FG500) back to factory settings and only did the port forwarding again. Still the same and for clients everything works perfectly.

I've googled and read that this might because of "NAT Looback" is enabled for my router. This will allow me to connect to my public IP from inside the NAT, but will make connections coming from Internet through the NAT look like what I'am seeing. However I could not find how to disable it. Will contact ISP if they can help configure the router as its their device rented. From murmur.log I can see that this started happening at end of July, about the time I got new router after lightning strike broke my old one..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...