Jump to content
Mumble forums

How to set mumble to use your default sound device


Recommended Posts

  • 1 month later...
  • Administrators

As mumble is a communication application it uses the default communication device by default. You can however configure mumble to use a fixed audio device of your choice instead. This can be done from the Configuration when the "Advanced" checkbox is checked.

Link to post
Share on other sites
  • 3 weeks later...
  • 3 weeks later...
  • 2 weeks later...
  • Administrators

Mumble doesn't seem to respect the explicit Audio Output Device?


At least, on my two computers (Win 10), I can't force a specific output device. It just always goes to the system default regardless of settings in Mumble.

 

This issue seems to pop up a lot.


Mumble doesn't respect the chosen output device for Text-to-Speech: we simply use Microsoft's Text-to-Speech API, and whatever default output device it uses.


I've filed this issue for the problem:

https://github.com/mumble-voip/mumble/issues/3116

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...
  • Administrators

You can download a 1.3.0 development snapshot from our website mumble.info, which is regularly updated with our in-development next-version code base.


From the linked changes this setting (wasapi/role) is not available in Mumbles gui, but you can set it in the registry where the settings are stored.

Link to post
Share on other sites
  • 2 weeks later...
  • Administrators

Hit Windows+R.

A "Run" window should open.

Enter

REG ADD HKCU\Software\Mumble\Mumble\wasapi /v role /t REG_SZ /d console /f

to set the role to console (as per ERole docs: "Games, system notification sounds, and voice commands.")


or

 

REG ADD HKCU\Software\Mumble\Mumble\wasapi /v role /t REG_SZ /d multimedia /f

to set the role to multimedia (as per ERole docs: "Music, movies, narration, and live music recording.")


To restore the default (communications role):

REG DELETE HKCU\Software\Mumble\Mumble\wasapi /v role /f

 


To apply the changes make sure to restart Mumble (or the WASAPI instance by going into settings and pressing ok - should also work).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...