Jump to content
Mumble forums

where do I add my ip adress?


lostsoul1
 Share

Recommended Posts

This has been driving me mad for the last few hours. I cant see here to add my ip adress to this so other people can access my server.



 

# Path to database. If blank, will search for

# murmur.sqlite in default locations or create it if not found.

database=


# If you wish to use something other than SQLite, you'll need to set the name

# of the database above, and also uncomment the below.

# Sticking with SQLite is strongly recommended, as it's the most well tested

# and by far the fastest solution.

#

#dbDriver=QMYSQL

#dbUsername=

#dbPassword=

#dbHost=

#dbPort=

#dbPrefix=murmur_

#dbOpts=


# Murmur defaults to not using D-Bus. If you wish to use dbus, which is one of the

# RPC methods available in murmur, please specify so here.

#

dbus=session


# Alternate service name. Only use if you are running distinct

# murmurd processes connected to the same D-Bus daemon.

#dbusservice=net.sourceforge.mumble.murmur


# If you want to use ZeroC Ice to communicate with Murmur, you need

# to specify the endpoint to use. Since there is no authentication

# with ICE, you should only use it if you trust all the users who have

# shell access to your machine.

# Please see the ICE documentation on how to specify endpoints.

ice="tcp -h 127.0.0.1 -p 6502"


# Ice primarily uses local sockets. This means anyone who has a

# user account on your machine can connect to the Ice services.

# You can set a plaintext "secret" on the Ice conntection, and

# any script attempting to access must then have this secret.

#icesecret=


# How many login attempts do we tolerate from one IP

# inside a given timeframe before we ban the connection?

# Note that this is global (shared between all virtual servers), and that

# it counts both successfull and unsuccessfull connection attempts.

# Set either Attempts or Timeframe to 0 to disable.

#autobanAttempts = 10

#autobanTimeframe = 120

#autobanTime = 300


# Murmur default to logging to murmur.log. If you leave this blank,

# murmur will log to the console (linux) or through message boxes (win32).

#logfile=murmur.log


# If set, murmur will write its process ID to this file.

#pidfile=


# The below will be used as defaults for new configured servers.

# If you're just running one server (the default), it's easier to

# configure it here than through D-Bus or Ice.

#

# Welcome message sent to clients when they connect

welcometext="

Welcome to Hooligan.

Enjoy your stay!

"


# Port to bind TCP and UDP sockets to

port=64738


# Specific IP or hostname to bind to 93.97.170.26

# If this is left blank (default), murmur will bind to all available addresses.

#host=93.97.170.26

# Password to join server

serverpassword=


# Maximum bandwidth (in bits per second) clients are allowed

# to send speech at.

bandwidth=72000


# Maximum number of concurrent clients allowed.

users=100


# Regular expression used to validate channel names

# (note that you have to escape backslashes with \ )

#channelname=[ \\-=\\w\\#\\[\\]\\{\\}\\(\\)\\@\\|]+


# Regular expression used to validate user names

# (note that you have to escape backslashes with \ )

#username=[-=\\w\\[\\]\\{\\}\\(\\)\\@\\|\\.]+


# Maximum length of text messages in characters. 0 for no limit.

#textmessagelength=5000


# Maximum length of text messages in characters, with image data. 0 for no limit.

#imagemessagelength=131072


# Allow clients to use HTML in messages, user comments and channel descriptions?

#allowhtml=true


# Murmur retains the per-server log entries in an internal database which

# allows it to be accessed over D-Bus/ICE.

# How many days should such entries be kept?

#logdays=31


# To enable public server registration, the serverpassword must be blank, and

# this must all be filled out.

# The password here is used to create a registry for the server name; subsequent

# updates will need the same password. Don't lose your password.

# The URL is your own website, and only set the registerHostname for static IP

# addresses.

#

#registerName=93.97.170.26

#registerPassword=

#registerUrl=93.97.170.26

#registerHostname=93.97.170.26


# To enable bonjour service discovery uncomment the following line.

# To change the name announced by bonjour adjust the registerName variable.

# See http://developer.apple.com/networking/bonjour/index.html for more information

# about bonjour.

#bonjour=True


# If you have a proper SSL certificate, you can provide the filenames here.

#sslCert=

#sslKey=


# If murmur is started as root, which user should it switch to?

# This option is ignored if murmur isn't started with root privileges.

#uname=


# If this options is enabled, only clients which have a certificate are allowed

# to connect.

#certrequired=False


# You can configure any of the configuration options for Ice here. We recommend

# leave the defaults as they are.

# Please note that this section has to be last in the configuration file.

#

[ice]

Ice.Warn.UnknownProperties=1

Ice.MessageSizeMax=65536

 

What am I doing wrong?

Link to comment
Share on other sites

  • Administrators

Quite a lot :D First time you see a configuration file I guess?


The # in front of a line means it will be ignore when reading the configuration (it's for comments and to deactivate parts you don't actually want to be interpreted).


Also: Are you even sure you want to bind to a specific IP address, because most people don't want to. If you leave the host field blank the server will bind to all IPs the server controls.

Link to comment
Share on other sites

  • Administrators

That entirely depends on your system, system configuration and hardware.


What I would do is just try it like that.

If Ventrilo worked mumble probably does as well. (if you didn't do any setup for Ventrilo neither)


Otherwise,

you’ll probably have to forward the port in your routers firewall,

or open the port on your local firewall / allow the app.

Link to comment
Share on other sites

This is the ventrilo config I was using and never had a problem with it.


 

[server]


Name=Server 1

Phonetic=Server 1

Auth=0

Duplicates=1

AdminPassword=

Password=

SendBuffer=0

RecvBuffer=0

Diag=0

LogonTimeout=5

CloseStd=1

TimeStamp=0

PingRate=10

ExtraBuffer=0

ChanWidth=0

ChanDepth=0

ChanClients=0

DisableQuit=0

VoiceCodec=0

VoiceFormat=1

SilentLobby=0

AutoKick=0

 

What I need the a basic config for mumble so I can do the same. I just need to know what changes to make to the mumble config file to get it working. I know how to do port forwarding on my computer. I can pop along to no ip and get dnns if I need them. Can some kind person just give me the very basic's pls?

Link to comment
Share on other sites

I'v try that but no one else can connect.

 

2010-08-30 21:56:27.126 Initializing settings from C:/Users/St Lewes Investments/Desktop/New Folder (3)/Mumble/murmur.ini (basepath C:/Users/St Lewes Investments/Desktop/New Folder (3)/Mumble)

2010-08-30 21:56:27.161 SSL: Added CA certificates from system store 'Ca'

2010-08-30 21:56:27.171 SSL: Added CA certificates from system store 'Root'

2010-08-30 21:56:27.179 SSL: Added CA certificates from system store 'AuthRoot'

2010-08-30 21:56:27.195 ServerDB: Openend SQLite database C:/Users/St Lewes Investments/Desktop/New Folder (3)/Mumble/murmur.sqlite

2010-08-30 21:56:27.319 DBus registration succeeded

2010-08-30 21:56:27.319 Murmur 1.2.2 (1.2.2) running on Win: 6.0.6002.1: Booting servers

2010-08-30 21:56:27.546 1 => Server listening on [::]:6881

2010-08-30 21:56:27.652 1 => Server listening on 0.0.0.0:6881

2010-08-30 21:56:27.656 Bonjour: Failed to load dnssd.dll

2010-08-30 21:56:27.796 1 => Not registering server as public

2010-08-30 21:56:28.626 1 => <1:(-1)> New connection: 127.0.0.1:54008

2010-08-30 21:56:28.626 Connection: Failed to add flow to QOS

2010-08-30 21:56:28.812 1 => <1:(-1)> Client version 1.2.2 (Win: 1.2.2)

2010-08-30 21:56:28.908 1 => Starting voice thread

2010-08-30 21:56:29.008 1 => CELT codec switch ffffffff8000000b 0 (prefer ffffffff8000000b)

2010-08-30 21:56:29.102 1 => <1:doa(-1)> Authenticated

 

thats the log, but when I ask someone to test it for me, they cant contect with an ip address and port number.

Link to comment
Share on other sites

  • Administrators

So you’re using port 6881, and the other person is connecting to the correct IP address and port 6881?


doa is you?


No incoming connection is logged, so it’s a network problem.

Check that the port is open to the network for connections.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...