Jump to content
Mumble forums

SuperUser gives "Wrong certificate or password for regist.."


unsane
 Share

Recommended Posts

I set up a Murmur server, with SuperUser password and the whole bit, following the guide. I created a user account and successfully joined the Mumble server.


However, if i try to connect using the SuperUser username with correct password, i get "Wrong certificate or password for registered user. If you are certain this user is protected by a password please retry. Otherwise abort and check your certificate and username."


aStTq


What is the problem here?

Link to comment
Share on other sites

  • Administrators

Hello there


The SuperUser account can not have an assigned account certificate. So if you indeed log in with username superuser, it should ignore the certificate and try to authenticate you with the password you provide.

Are you sure you are using the correct password? Where did you get it from? Did you try setting a new password with -supw and then restarting the server? (Note that if you emit the virtual server id it will use ID 1 - which is fine if you only use one virtual server in the server process, and did not start/configure an additional one).


Sadly, I'm not sure if a wrong superuser password also leads to a "wrong ... password for registered user", which would be a suboptimal and confusing error message (as superuser is not really a 'registered' user account).

But I would expect it to be different; especially with the note to check the username...

Link to comment
Share on other sites

Are you sure you are using the correct password?

Quite sure, yes.

 

Where did you get it from?

It's my server, i created the password moments before, using "murmur.exe -supw Password_of_your_choice", as directed in the aforementioned guide.

 

Did you try setting a new password with -supw and then restarting the server?

No, since i had just created the server and password, and started the server, it seems odd that i would need to again set a new password and restart the server. Also it presumably would ask for the old password before letting me make a new one anyway... Right? :P

 

(Note that if you emit the virtual server id it will use ID 1 - which is fine if you only use one virtual server in the server process, and did not start/configure an additional one).

I don't know what any of this means. :P I don't think it was referenced in the guide. Presumably i have one server.

Link to comment
Share on other sites

  • Administrators

it presumably would ask for the old password before letting me make a new one anyway... Right?

 

No. The -supw command line argument does not ask for a password, it just sets the password.

It is the fallback. The context is that if you have command line access you could do anything to the server anyway. So you can set the superuser password.

 

No, since i had just created the server and password, and started the server, it seems odd that i would need to again set a new password and restart the server.

Well, I'm not sure what I can suggest to you then. After setting the superuser password with -supw you are/should be able to log in with username superuser and the password you set.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 years later...

I may have found ! Because I had the same issue :

 

murmurd -supw <chosen_password> updated the password locally (/home/<user>/.murmurd/murmur.inià, but murmurd was launched as an admin task

sudo murmurd -supw <chosen_password> did the trick 😄

 

could be translated to windows... perhaps

Link to comment
Share on other sites

  • 6 months later...

Can i confuse this topic even more??   i have had murmur running on my win 2012r2 server for a while and had set the superuser password and it was working fine.... until i replaced the laptop i was using to administer the server with.  i installed mumble 1.3.3 on a new laptop, copied the certificate over for my personal account which worked fine.  but, when i went to login to SuperUser the first time i went and looked up the password, put it in, and got the wrong password or certificate error message... now from what i have read the certificate part of that is superfluous, but i didn't see that until after wasting an hour or two trying to find the certificate on the old laptop where i had uninstalled mumble already.  after resetting the password a couple times to the same thing i thought it was i played a hunch and reinstalled mumble on the old laptop hoping it might be hiding a certificate somewhere i couldn't find it.... Viola! the old laptop logged in as SuperUser the first time with the saved password it had hidden somewhere.  i checked the password on the old laptop and it matched what i thought it should have been.  So, logged out of the old laptop and tried logging in on the new one with the same password, same error message.  so why would one laptop work as SuperUser and the other one sitting right next to it won't??

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...