Jump to content
Mumble forums

unable to connect to my friend's server


Recommended Posts

Hi ! I post my topic because i need some help.

Saturday night I was connected to mumble on my friend's server (raspberry) with my other friends, we talked while playing all night, i went to bed at 6:00am, i shutted off my computer.

I turned it on in the evening that followed, and there I could not connect to my friend's server, meanwhile nothing happened, no update of anything. When i try to connect to server, i have this message : Remote Host Closed the Connection.

I disconnected from my internet box, to go through the 4G (mobile phone). I could connect! only once ..... when I disconnected, then reconnected to try I had the same message again. I thought maybe it was an IP problem.

I restarted my box to change the IP address. When I tried again to connect to my friend's mumble server, I did not have this error message anymore, the password was asked! I naturally entered the correct password! (-_-) but there .... error message! BAD PASSWORD !! all the edition of the server is good, the password is good, and I have this famous error message that tells me that the password is bad è_é ARE YOU KIDDING ME ??

It can not be a problem box, it is new, do not cause me a problem on the internet, downloads are good, ping too, absolutely everything works, online games ..... my one and only problem is the connection to my friend's mumble server.

I have this bug only with my friend's server, I can connect to other public servers, talk about it. it's incredible. My friends have no problem connecting to my friend's server. I am not in the list of banned IPs.

I installed mumble on my second pc to try, I have exactly the same problem. As well as on my wife's laptop. Crazy! How is it possible ?

I tried with an unofficial android MUMBLE application with 4G, I was able to login once, the second also put me the same error message about the remote host that closed the connection .. .... T_T

Why my friends can connect to it without problems and not me with my 3 computers and 1 phone?

when I do not have the problem of remote host that closes the connection, and that I am able to type the password and that despite that it is wrong, my friend on his side in his log file, he finds an expired certificate problem preventing the connection. While on my side it is a password error.... OK, WHERE IS THE LOGIC ??? I created a new certificate, the problem remains EXACTLY the same, nothing changes.

We spent several hours trying to solve the problem, without ever finding a solution. This is a problem that seems to be no logical solution, my WINDOWS 10 is installed for a few months only, is very clean. I have the necessary resources for, i5 8600k 16gb ram........ latest version of mumble installed for several months......I disabled the firewall windows

and even uninstalled my antivirus to try to connect me. always this error message.

I tried with previous versions of Mumble, still nothing.

my friends who tried to help me believed that I troll them so much my problem seems impossible to solve, completely devoid of logic .... My last hope is to defer myself to the forum mumble.

I think I have gone around what I tried, I'm interested in any other sollution.

Reformating windows does not seem to be the solution as I have this problem here too with my other two computers as well as mobile phone.

In advance, thank you for any answers you can give me ! Have a good evening.

Link to comment
Share on other sites

  • Administrators

That indeed sounds strange.

Did you generate a new certificate with mumbles own certificate wizard?

After generating a new certificate, what is the error message on the servers log?

Remote host closed the connection usually indicates that the server rejected your connection, for one reason or another. As such, it should be logging why it rejects you.

Link to comment
Share on other sites

Indeed I have generated a new certificate using the wizard own mumble.

The error message remains the same, I do not know exactly the words but it is about an error due to an expired certificate, my certificate is not expired, duration of about 20 years .... lol and when it is not this error, that I can "try" to type the password, it is translated by a password error (which is nevertheless good ....) .

The registered reason for which my connection is rejected is a certificate error .... even with a new one.

Link to comment
Share on other sites

  • Administrators

I wonder what kind of server, or authentication callback script your friend uses.

Users can use certificates generated by mumble, or their own ones. Own ones can be checked for trustworthyness through their signers. But afaik the mumble-generated certificate is handled specifically, so the server always accepts it as valid.

So I really don't see how a self-generated certificate would be expired - and only for you.

Server hosters/adminsitrators can integrate custom authentication scripts that handle authentication, e.g. through an existing username + password database. But I guess that's not the issue here either, as certificate is rejected apparently.

Did I understand you correctly that the certifiacte expired is on the servers log? Not your client? You don't see that?

I also don't quite understand what you mean by "when it's not that". When and how do you get the password prompt?

Link to comment
Share on other sites

For answer to your last question, it is when miraculously (or the biggest of the chances) I do not have the message of distant host which closed the connection, I have a short moment of "connection to the server" (2 or 3 seconds) and there the password request window appears, it suddenly appears after the short time of connection to the server.

The inconsistency is that when I on my side have this incorrect password error, my friend on his side has an error related to an invalid certificate. it's like a problem that would be different on both sides! it is not normal ! another friend of mine was wrong once in the password, and on the server file I saw "Anthony * my friend * entered a bad password" and then a few seconds later "henry is connected" for he had entered the good. for me there is not the same logic in my problem because yet I enter the right password. I'm confused, really. completely out of ideas. I feel completely overwhelmed by something supernatural. Everything is done so that I should be able to connect.

For the question of the certificate, I can not answer too much because it is quite technical, only I am able to say that since April 2016 we connect regularly on his server, I think all with a certificate created by mumble, self signed, and that it is therefore more than two years that no problem is to be reported until this mysterious and irresolvable problem strikes me. I do not understand that overnight it does not work anymore. Totally incomprehensible.

And to finish, you understand me when I say that it is an expired certificate problem, but that it is only visible on the server log, so only my friend can see it, on my client nothing 'appears, off put' the remote host has closed the connection '

Thank you for the time you spend trying to help me!

Best regards

Link to comment
Share on other sites

  • Administrators

As you say you can connect to other servers fine, I'd like to blame it on your friends server/his configuration.

I'd be interested what server he runs on what OS, which configuration, and if he runs any scripts.

What kind of password do you enter? Is it an account password? Does your friend have a database backed login setup then?

Maybe we can replicate it on/with another server, or confirm it's not your end that's failing.

Link to comment
Share on other sites

  • 2 weeks later...

Hi !

I come back several days later and told myself that the problem might go away by itself. But no ! lol

For the question of his server, it's a raspberry, pi 2 I think. And about the password, it's a password that he himself assigned to the server to access it when he installed mumble on it (using

Does my friend have a database backed login setup then? -> i don't know.

I am especially intrigued by the fact that my other friends can connect to it quite normally.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...