Jump to content
Mumble forums

Remote Host Closed the Connection


asickle
 Share

Recommended Posts

I recently set up a new modem, and upon doing so, I lost my ability to connect to certain Mumble servers. Not all of them, but certain ones, such as one my friend runs. I've attempted to set up port forwarding, using the port associated with my friend's server, but this does not resolve the issue. Is there a certain port that I should use for forwarding? Is it IPv4 or IPv6? TCP or UCP or both? Any suggestions would help. Thanks!

Link to comment
Share on other sites

  • Administrators

Generally, I don't think it should be necessary to forward ports on the client side. Only server side.


Because your client initiates the connection, to the servers listening port on TCP. Routers generally allow response packets after a client initiated a connection. The client TCP port is (probably?) random. Same for UDP. The server UDP port is probably the same.


Even if UDP does not work, all the control happens over TCP, like connecting, switching channels, sending text, etc. And if UDP fails Mumble falls back to tunnel the voice data over TCP (which is slower but still works).


Mumble supports both IPv4 and IPv6. It does not matter to it. It is a question of what interfaces the server listens on and your client can use.


What do you mean by setup a modem? A router in front of your local home network?

Link to comment
Share on other sites

So...how do I forward ports on the server side? Like I said, I used to be able to connect to my friend's server and now I no longer can, after I installed a new cable modem in my house. My friend didn't change anything with the server, I just changed my modem and now I'm receiving this error. This is the new modem/router combo that I installed: https://www.arris.com/surfboard/products/wi-fi-cable-modems/sbg6900-ac/


I can't figure out why I'm now receiving this error though. What's needed to overcome this error?

Link to comment
Share on other sites

  • Administrators
What's needed to overcome this error?

 

You did not say what your error actually is.


The servers side can give information on why the connection is dropped, or at least that is indeed a client side issue rather than server side.


I guess as you installed your new router, it is likely that it does something different. Try looking through its features and see if you can disable any firewall, flood protection, network protection etc and see if that helps.

Link to comment
Share on other sites

Ultimately, my error is that I keep receiving the message that the remote host closed the connection. This is happening on multiple servers since replacing my modem. Even when I turn the firewall off entirely, it still doesn't work. On my friends server, there is no indication that I'm attempting to connect. So, it seems like its getting blocked on my client side. Is this something you commonly run into?

Link to comment
Share on other sites

Ok, is there something more specific I can tell you to uncover the problem? All I've seen is it telling me that the remote host closed the connection. Can you show me tell me what ports to use if I were to try and set up port forwarding to resolve this? Is there anyone else at Mumble that I should be speaking with about this?

Link to comment
Share on other sites

  • 3 weeks later...
  • Administrators

I think I already posted (all of) my ideas of where to debug/what to look for.


I checked the code. It looks like it is a SocketError - so within the mumble client we do not have more information than only that. The Qt SocketError class Lists `QAbstractSocket::RemoteHostClosedError` described as

 

The remote host closed the connection. Note that the client socket (i.e., this socket) will be closed after the remote close notification has been sent.

 

As I said my go to would be checking the server logs. Because if the server closes the connection, you have to check the server as to why it did.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...