Jump to content
Mumble forums

2010-09-05-2257-a8a212 crashes with A.V.A.


rawnar
 Share

Recommended Posts

After updating to the latest snapshot problems started to arise while playing Alliance of Valiant Arms(aka AVA). With the previous snapshot everything was running okay. The first time I started AVA while being connected with the latest snapshot, the graphical interface of AVA was slow. And playing a match was really terrible. The game was lagging extremely, but according to the server my ping was below 20. Trying to switch back to desktop and disabling the overlay cause mumble to crash. I tried several ways to get mumble to work again, but often it crashed before I got back into the game. Playing another game based on the UE3, UT3 did not have any problems.


After a crash mumble never asked me to file a crash report. Using windbg to get some info did not work very well. I could not get the window of windbg on the foreground, while AVA was still running. But I will try again later.


Also mumble seems to crash when I opened the server statistics. But I have to check I that happens independent of the AVA problem, and only for this window.


There were also another thing that was strange. I was playing with my sound configuration for the best positional audio. I used to Audio Wizard to hear the effect of the configuration, and then cancelled it just before the end. After braking off the Wizard the sound bar in the Audio Input configuration was not moving anymore. After going through the audio wizard and braking it off at the some point, made the sound bar respond again to my mic input. I thing a timer is not correctly stopped while cancelling the audio wizard.


Update: Quick peak into the git repo showed only two commits, related to the mumble client itself, between the two snapshots: "Improve Overlay Font Resizing" and "Added launch checkbox and new bitmaps for the installer". The first one adds a Warning string and changes the way fonts are set. This warning string pops up in windbg when I open the configuration window of mumble.


I will keep on bug hunting and keep you guys up to date of my findings.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Yesterday, I did a quick check if the change in the installer was the problem. Installed the previous snapshot, un-installed that one, rebooted and installed the latest snapshot. This did not help, mumble still crashes and takes AVA and sometimes even pidgin with him. Overlay was off at the time of the crash and positional audio was on, but this game is not supported by positional audio. The crash happened when I went back to the desktop, while playing AVA, to check in the configuration of mumble if the overlay was on or off. Also windbg gave no output.


Just a though, but could it be that there was a update between the snapshot of one of the third-party libs.


I switch back to the previous snapshot, because it was game-night and we were planning on playing AVA.


Everyone who wants to confirm the problem, AVA is free. Just go to this website and download the game.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Could not sleep, so I did some testing. Trying to catch a crash report with windbg was no go, every time mumble crashed only one thread was alive with no info.


The problem was that both programs were fighting over the UDP connection. Switching mumble to force TCP solved the problem. The following indicators help with finding the problem.

- The game gave a message that there was a connection problem, when starting a match. This disappears quickly, and probably mumble would have died in the background.

- Trying to start mumble when the game was running caused an instant crash. Due to the window of the server list, trying to get info from the servers.

- Starting mumble but not being connected to a server, there were not crashes. But trying to connect will playing the game slowed down mumble and crashed it.


With Force TCP on I could run the game with overlay on. Unfortunately the overlay has a very high impact on the fps. I was getting ~120 fps without overlay and <40 with overlay. So the difference between ownage and being owned. Maybe the framerate drop has to do with my SLI setup.


So mumble with AVA is not go with the latest snapshot, yet. The connection of the game is effected and when using the overlay there is a big framerate drop.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...