Jump to content
Mumble forums

Mumble URLs are WONDERFUL but mine don't look like the wiki


Recommended Posts

I just discovered Mumble URLs and I am using them with success on Mumble V1.3.0 with Manjaro Linux. Here is the "c" source code that I use to connect to the "root" channel of my Mumble server at LinuxAirCombat.com:


popen ("mumble mumble://linuxaircombat.com/LinuxAirCombat?title=Root&version=1.2.0", "r")


Cool, huh? Yes, it really is a ONE-LINER!

If I want to go deeper into my channel hierarchy, I just expand that line a bit like this:


[popen ("mumble mumble://linuxaircombat.com/LinuxAirCombat/Realm0/MissionNetworkBattle01/M1Red?title=Root&version=1.2.0"", "r");


That commands my local copy of Mumble V1.3.0 to connect with my murmur server at LinuxAirCombat.com, immediately accessing the channel I created there thru the path "LinuxAirCombat/Realm0/MissionNetworkBattle01/M1Red".

Note, however, that those working Mumble URLs (retrieved from a working Mumble app by right-clicking on the associated channel) do NOT look like those documented in the Mumble Wiki here:


This inspires a question about some funny behavior I observed when I tried to use my Mumble URLs with an older version of Mumble (V1.2.3). The same Mumble URLs that work well with new Mumble 1.3.0 automagically invoke ancient Mumble version 1.1.x instead of version 1.2.3 which I routinely use on that system. I am guessing this results from some old attempt at backward compatibility???

If I try formatting those Mumble URLs as documented in the wiki (instead of the format given to me when I right-click on the newer V1.3.0 client), can I expect them to work better with users still tied to Mumble V1.2.3?



Link to comment
Share on other sites

Well maybe I can express my situation more clearly.

I have Mumble URLs working correctly with Mumble V1.3.0. and I'm VERY HAPPY with the results.

Many of my users, however, are using old Mumble V1.2.3 and it's clear that the interpretation of Mumble URLs is different for them. I have discovered how to format a Mumble URL for V1.2.3 that will cause them to connect with my Mumble Server, but I have not figured out how to specify a desired channel.

For example, my Mumble server is at LinuxAirCombat.com, and I can get my LINUX-based Mumble V1.2.3 to connect with that server if I issue this command:


mumble mumble//LinuxAirCombat.com/?version=1.2.0


My Mumble server has several channels in a rich hierarchy. The simplest channel is simply:


I would like to enhance the working command shown above to guide the connection into that "001" channel after it successfully connects with my server. I have tried expanding that working URL in the most obvious way by inserting "001" like this:


mumble mumble//LinuxAirCombat.com/001/?version=1.2.0


...but that makes no difference. Mumble V1.2.3 still connects to my server but does NOT enter channel 001.

Can anybody provide some working examples of Mumble V1.2.3 URLs that correctly enter a designated channel?


Link to comment
Share on other sites

[2 days later....]

I discovered my error in the prior posting: I had neglected to insert a colon character between "mumble" and "//".

Having fixed that, I am now experiencing progress with Mumble URLs and Mumble V1.2.3. It still isn't behaving as nicely as Mumble V1.3.0, but I can get it to connect to my server and go to a designated channel. Here is a sample of the command line I am issuing into a LINUX bash shell to get that far:


mumble mumble://LinuxAirCombat/com/001/?version=1.2.0 &


I can expand that command line to reference any of the channels offered by my Mumble Server. it always connects and switches to the designated channel on my first attempt.

However, subsequent attempts to switch to a different channel do NOT work: it just stays in the same channel. I don't know why. I plan to continue experimenting with this to see if I can find a command syntax that works as nicely with old Mumble V1.2.3 as it works with the new Mumble 1.3.0. I will continue to report my progress in this thread.

Link to comment
Share on other sites

To clarify, here is what I am doing. First, on my Linux machine equipped with Mumble V1.2.3, I issue this command line into a bash shell:


mumble mumble://LinuxAirCombat.com/001/?version=1.2.0 &


That works. I get connected to my Mumble server at LinuxAirCombat.com and I also get switched to the "001' channel, exactly as expected.

Immediately after that, I issue these commands in an attempt to switch into channels "002", "003", and "004", respectively:


mumble mumble://LinuxAirCombat.com/002/?version=1.2.0 &



mumble mumble://LinuxAirCombat.com/003/?version=1.2.0 &



mumble mumble://LinuxAirCombat.com/004/?version=1.2.0 &


As you can see, each of those command lines is essentially identical to the first, successful one, differing only in the single character that differentiates my channel "001" from my channel "002", etc.

After that first command succeeds in switching me into my channel "001", none of the other command lines ever switches me to any other channel. It just stays in my channel "001". In each case, however, I can look at the message log area of the Mumble V1.2.3 client and it always displays a sensible-looking record of what I wanted to achieve. For example, it shows THIS after my attempt to switch into my channel "002":

Opening URL mumble://linuxaircombat.com/002.>version1.2.0

Disconnected from server.

Connecting to server LinuxAirCombat.com.


Can anybody suggest some change that might get Mumble V1.2.3 to accept additional channel-change URL commands after it has successfully processed one of them?

Link to comment
Share on other sites

[12 hours later]

Well, I found a bizarre way to make progress. If I insert a command attempting to connect with a non-existent mumble server, specifying a non-existent username and non-existent password BETWEEN commands to my real mumble server, it works better. That non-existent server connection attempt forces a disconnection with my own, real mumble server. The sequence is like this:


mumble mumble://LinuxAirCombat.com/001/?version=1.2.0 &


works as expected, connecting me to my channel "001".


mumble mumble://nobody:nobody@ &


Forces a disconnection from my mumble server and then a series of "Disconnected from Server.... Connection failed; connection refused" errors, going on indefinitely until I continue with:


mumble mumble://LinuxAirCombat.com/002/?version=1.2.0 &


That works, taking me into my channel "002' as I had hoped.

Obviously this is a cumbersome process. Has anybody found a better way?


Link to comment
Share on other sites

  • Administrators

Why are you still using 1.2.3? Please note that the patch releases include some security fixes, although I am not currently aware if it applies to clients or linux clients specifically, and you packager may apply them for a customized, patched .1.2.3 version but that depends on their support.

Link to comment
Share on other sites

Why are you still using 1.2.3? Please note that the patch releases include some security fixes, although I am not currently aware if it applies to clients or linux clients specifically, and you packager may apply them for a customized, patched .1.2.3 version but that depends on their support.


I have no control over the choices my users make regarding use of Mumble. Some of them are using current versions and some are using old versions. A lot of them are using "Plumble" on Android.

Fortunately, even the old desktop Mumble V1.2.3 supports Mumble URLs in a manner that has enabled me to interface with it. I had to do some adapting (as described in prior memos of this thread) to Linux Air Combat to control every version of Mumble from old V1.2.3 up thru the current 1.3.0, but that effort has now been successful.

As a result, anybody that installs any version of Mumble since old V1.2.3 on the same computer hosting my "Linux Air Combat" flight simulator now benefits. Mumble is fully integrated into the "cockpits" of all players, and acts very much like a real aircraft radio, automatically switching players among the different channels offered by our Mumble server according to the chosen mission and the player's team. I am VERY happy with the result.

Obviously my flight sim software cannot control "Plumble" or any other Mumble-compatible tool installed on a different computer, but since you helped me configure my server to implement a much smarter relationship among channel families, even those users are having a much easier time switching among my channels manually.

If anybody wants more details about the marvelous results, take a look at the Linux Air Combat "Frequently Asked Questions" here:


In particular, Mumble is discussed in FAQ #5, #6, #37, and #38.

Thanks for your patient support Kissaki.... I couldn't have done this without you!

: )

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...