This is a read-only archive of the Mumble forums.

This website archives and makes accessible historical state. It receives no updates or corrections. It is provided only to keep the information accessible as-is, under their old address.

For up-to-date information please refer to the Mumble website and its linked documentation and other resources. For support please refer to one of our other community/support channels.

Jump to content

Murmur requires administrator on windows?


Recommended Posts

I've run Murmur for years on Linux environments, but recently I experimented with running on a Windows Pro host.

The first thing I ran into was that no logs were saved. Apparently because the installer somehow locks Murmurs folder/files, so they can only be opened by an administrator. (Running Murmur as admin makes the logfiles show up.)

Question 1: I have a hard time beliving that this is how it is supposed to work? Or?

Question 2: Is it possible to run Murmur as a service? (I only found old stuff online that required some third party program to make Windows think Murmur was a service.) If not, whats the prefered method of making sure that Murmur is running automatically after a restart?

Sorry if these questions have been asked and answered before... but the search function on this forum is pretty finicky... and thinks that words like "pro" and "Windows" are so common that it does not even bother to include them in a search. "Administrator" is fine... but then.. is a common word with hundredes of hits :lol:

Link to comment
Share on other sites

  • 2 weeks later...
  • Administrators

Mumble does not need to run as administrator to work and log fine.

I suspect one of a few things went wrong are unexpected on your end - and information is missing. Maybe you did not install the official installer? Maybe you modified it trying to make it run in "portable" mode with an ini next to the exe?

Where do you expect and check the log/log file?

The official installer does currently not provide anything for running murmur as a Windows service by itself.

Link to comment
Share on other sites

Thanks for your reply Kissaki.

I used the official Windows 64bit installer, (Downloaded here: )

I simply ran it just as it is. (Why would I even want to modify it? )

I expected the log to be found at C:\Program Files\Mumble (Which is where it shows up if I run Murmur specifically as admin.)

More info:

I am using Windows 10 Pro

I am simply doing the install from the only user that exist on the machine. (Eg it's an account that is basically admin.)

I just removed the old installation, and tried once again.

This is the output from the log window. (There is no need to hide the password, as I will change it right away. And may delete the sever after writing this.... and it's not online yet.)

2020-11-09 21:23:42.405 SSL: OpenSSL version is 'OpenSSL 1.0.2u 20 Dec 2019'

2020-11-09 21:23:42.421 Initializing settings from C:/Program Files/Mumble/murmur.ini (basepath C:/Program Files/Mumble)

2020-11-09 21:23:42.467 MetaParams: TLS cipher preference is "ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:AES256-SHA:AES128-SHA"

2020-11-09 21:23:42.467 Failed to open logfile murmur.log. No logging will be performed.

2020-11-09 21:23:42.467 SSL: CA certificate filter applied. Filtered size: 76, original size: 76

2020-11-09 21:23:46.889 ServerDB: Opened SQLite database C:/Users/Server/murmur.sqlite

2020-11-09 21:23:46.889 ServerDB: Using SQLite's default rollback journal.

2020-11-09 21:23:47.702 Performed initial PBKDF2 benchmark. Will use 8000 iterations as default

2020-11-09 21:23:47.702 Generating new tables...

2020-11-09 21:23:47.827 MurmurIce: Endpoint "tcp -h -p 6502 -t 60000" running

2020-11-09 21:23:47.827 Murmur 1.3.3 (1.3.3) running on WinX64: Windows 10 Pro x64 2004 19041.610: Booting servers

2020-11-09 21:23:47.936 1 => Password for 'SuperUser' set to 'QYrMGQbc8GhH'

2020-11-09 21:23:48.077 1 => Server listening on

2020-11-09 21:23:48.123 1 => Generating new server certificate.

2020-11-09 21:23:48.608 Bonjour: Failed to load dnssd.dll

2020-11-09 21:23:48.639 1 => Not registering server as public

Link to comment
Share on other sites


  • Create New...