Jump to content
Mumble forums

Murmur "Unable to Open Database, Unable to fetch row" on XP


etmegabyte
 Share

Recommended Posts

I am getting a strange error when starting Murmur. Once this error comes up (right away), Murmur.exe dies...


DATE/TIME SQL Error [iNSERT INTO `slog` (`server_id`, `msg`) VALUES(?,?)]: unable to open database file Unable to fetch row


This server isn't anything special. One server, running on Windows XP Pro. The only "odd" thing about this setup is that though Mumble/Murmur is installed in c:\program files\mumble, the sqlite database and the log file have been moved to "D:\Murmur". I did this because C: is a compactflash drive, and I don't want a bunch of writes to that flash disk...


It is not a corrupt database, I grabbed the murmur.sqlite from another machine that is running just fine, and it still gives the error.


Just a bit of background here. The goal was to migrate the murmur server to this new machine from an old machine that I'm planning on putting to pasture soon. So I shut down murmur on the old machine, copied the murmur.sqlite file from the old one to the new one, then started it on the new one. That would effectively eliminate the possibility of it being a corrupt database (which is what the faq suggests as a possible problem). Murmur still runs just fine on the old machine, with no errors.


It's not a permissions issue, as the drive where the sqlite database file and log is is formatted FAT32.


It's not a size issue, as the sqlite databae file is just over 3 megabytes.


Just for testing, I deleted the "migrated" sqlite file and tried to let it re-create it fresh. When starting murmur, it creates a new, empty file in the proper location, but gives a different (yet similar) error:


DATE/TIME SQL Error [CREATE UNIQUE INDEX `config_key` ON `config` (`server_id`, `key`)]: Unable to open database file Unable to fetch row....


The relevant changes in murmur.ini are as follows:

database=d:/murmur/murmur.sqlite

logfile=d:/murmur/murmur.log


The rest of the file is identical to the one on the properly running server.


And finally, a direct copy from murmur.log...

2010-10-04 12:59:06.687 Initializing settings from C:/Program Files/Mumble/murmur.ini (basepath C:/Program Files/Mumble)

2010-10-04 12:59:06.890 SSL: Added CA certificates from system store 'Ca'

2010-10-04 12:59:06.937 SSL: Added CA certificates from system store 'Root'

2010-10-04 12:59:06.968 SSL: Added CA certificates from system store 'AuthRoot'

2010-10-04 12:59:07.015 ServerDB: Openend SQLite database D:/murmur/murmur.sqlite

2010-10-04 12:59:07.015 Meta: Failed to load qWave.dll, no QoS available

2010-10-04 12:59:07.062 DBus registration succeeded

2010-10-04 12:59:07.078 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running

2010-10-04 12:59:07.078 Murmur 1.2.2 (1.2.2) running on Win: 5.1.2600.1: Booting servers

2010-10-04 12:59:07.093 SQL Error [iNSERT INTO `slog` (`server_id`, `msg`) VALUES(?,?)]: unable to open database file Unable to fetch row


-----


I've tried just about everything I can think of. Mumble works fine on that machine. I've even copied the mumble directory from a known working machine in it's entirety. I've tried changing the config back to put the sqlite file and the log in the same directory as the program. None of it helps. The error perplexes me, since it's telling me that it can't open the database, when 5 lines above in the same log it tells me that it DID open the database. I can't figure out what I could possibly be missing here... The user account trying to run murmur is a computer administrator. Everything is as it seems like it should be... Except, of course, that it doesn't run...


Am I missing something?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...