Jump to content
Mumble forums

Mumble 1.2.3


zacharybinx34
 Share

Recommended Posts

I am very excited to make the switch from Ventrilo to using Mumble! However, I'm currently waiting for the Mumble 1.2.3 release before I introduce my guild to this awesome software.


Do you guys think its better to wait, as I know how lazy people can be when it comes to upgrading software. That way I can roll it out all together? Also, is there an estimated release date for the Mumble 1.2.3 version?


Thanks!

Link to comment
Share on other sites

  • Administrators

Currently only bugfixes and strings + translation is what’s to be done for 1.2.3. Still, there’s no estimate.

But as the clients are compatible with one another, you don’t really have to wait. Ppl. will still be able to use the older (1.2.x) client while others (and your server) are more recent.

For the changes see http://mumble.sourceforge.net/1.2.3

Of course the next release will be a lot better than 1.2.2, but it’s not that big of a problem if some of your ppl won’t update. It’s just them being at a disadvantage then not being able to enjoy the awesome new features. You can still talk to them.

Link to comment
Share on other sites

  • Administrators

Sorry. No fixed release date yet. We expect to string freeze soon and from then its mainly translations and show-stopper bugs that delay the release.


As to mixing different client versions. We of course support that (we plan to stay backwards compatible at least throughout the 1.2.X series if possible). However to get the best experience everyone should always upgrade to the newest Version. We not only do a lot of bugfixes and add new features between Versions but also update our codecs. If we now have old and new clients in one channel the new clients will downgrade to a common codec version. It's not like the old ones sounds horrible but the new Versions are better ;-)


Good luck with your switching effort.

Link to comment
Share on other sites

  • 4 weeks later...

Sorry if I'm being impatient and nagging, but some time have passed now so is there now any releasedate or rough ETA on the 1.2.3 release? I can see that developement have progressed nicely and that strings were frozen a couple weeks ago. Several translations have been submitted and CELT 0.9 have been released. Are you currently waiting on any translations? Again sorry for being impatient, I'm just excited for the upcoming release.

Link to comment
Share on other sites

  • 2 weeks later...

I'm on 1.2.3 on one machine and 1.2.2 on another on the same server. I don't use overlays much at all, but I've had zero problems with the 1.2.3 snapshot. That said, I've not had a serious problem with any Mumble snapshot.


I was in a similar situation with the 1.1 to 1.2 transition, but that wasn't backwards compatible so was much more of an issue. Right now, I there is no reason not to advocate switching since compatibility is guaranteed and upgrades are easy.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
Of course the next release will be a lot better than 1.2.2, but it’s not that big of a problem if some of your ppl won’t update. It’s just them being at a disadvantage then not being able to enjoy the awesome new features. You can still talk to them.

That's not entirely correct, because of the new "priority speaker" feature. If many users connect with 1.2.2, then that feature is practically "hijacked". If a clan leader (or party leader) sets himself as a priority speaker, that setting is ignored in 1.2.2 clients. The leader can't enforce that setting upon the other members since they can circumvent it (maliciously or not) by using Mumble 1.2.2.

Link to comment
Share on other sites

  • 2 weeks later...
  • Administrators
Of course the next release will be a lot better than 1.2.2, but it’s not that big of a problem if some of your ppl won’t update. It’s just them being at a disadvantage then not being able to enjoy the awesome new features. You can still talk to them.

That's not entirely correct, because of the new "priority speaker" feature. If many users connect with 1.2.2, then that feature is practically "hijacked". If a clan leader (or party leader) sets himself as a priority speaker, that setting is ignored in 1.2.2 clients. The leader can't enforce that setting upon the other members since they can circumvent it (maliciously or not) by using Mumble 1.2.2.

IF you use it, yes.

And if you use it, it will be just them not hearing the priorisation, right?

It's not that they will influence the other ppl.

Link to comment
Share on other sites

  • 3 weeks later...
  • Administrators

Seeing me being quoted like that, I want to make something clear:

Of course the next release will be a lot better than 1.2.2, but it’s not that big of a problem if some of your ppl won’t update. It’s just them being at a disadvantage then not being able to enjoy the awesome new features. You can still talk to them.

The newer audio codecs in 1.2.3 improve audio quality etc of the transmitted audio. If someone uses an older client the codec will fall back to a compatible one, which ofc is inferior to the old one.

So its not just the one not upgrading being at a disadvantage, at least audio/codec quality wise.



@kapteen

what's your problem?

http://mumble.sourceforge.net/Murmurguide#Linux_2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...