Jump to content
Mumble forums

technophobe, pls help...


mzchief
 Share

Recommended Posts

i have used vent for 2 years and wanted something new and better ;)


this brings me here. but unfortunately i'm not quite able to set this up properly. i know i'm missing something! i just don't know what it is :cry:


i installed mumble, rented a private server and had invited one friend to test this out. but i'm not able to set up channels or even mute/deafen the other user. i began to read more about this and found info that said i need to edit "murmer.ini" file, which doesn't exist on my pc - or at least, i can't find it.


any help, would be very much appreciated! cheers :D

Link to comment
Share on other sites

  • Administrators
i have used vent for 2 years and wanted something new and better ;)

Welcome to the right place! :)


You probably received a superuser password.

You’ll just have to log in as SuperUser and enter your password when asked.

Then you can edit ACL, and also add yourself (user registration) to the admin group in the root channel, so you can do everything with your normal account.

http://mumble.sourceforge.net/ACL_and_Groups

http://mumble.sourceforge.net/ACL_Tutorial/English

Link to comment
Share on other sites

ok, i haven't received any superuser password. how would i got about getting one?


thanks again :)


edit: i just read the link above - doh :P


however, i have my own server, so this is what i'm trying to set up. it only has route channel, if that's what it's called, i can't add or edit anything.


if there is some guide starting from scratch, aimed at private servers, that would be ideal. many thanks.

Link to comment
Share on other sites

  • Administrators

Oh, you self hosted?

You said

rented a private server

so … I thought it was a rented server!?


Anyway,

see http://mumble.sourceforge.net/Running_Murmur

What you need to do to set a superuser pw ist to run your murmur executable with -supw

see http://mumble.sourceforge.net/Running_Murmur#Setting_the_SuperUser_Password

Link to comment
Share on other sites

oh sorry, i'm not familiar with the terminology. when i first dl'd mumble, i saw there were many servers, but didn't know what was private or wasn't. so thought i had to get my own server. yes, it's rented i guess on a monthly basis for the moment. i just got one month only, to see if i could use it first. however, i'm not sure i'm technically able to set it up, it all looks so complicated :?


so as i understand it, to set up channels and have options to mute/deafen etc., i must set up a superuser password? only then can i change/add channels? and, if i can't deafen/mute users in my channel at the moment (without superuser pass) i guess other channel users won't have that option either? do they too need to get a spw also?


i followed your link for the instructions on how to set up a spw. but *sadface* i don't understand what i have to do - i understand the bit about using run command, but...


---------

To set the password on Windows systems, run

-ini -supw

--------


i know where the path is, but what do i put for that -ini part? and what is the configuration file name? so that i can locate if to enter the path.


sorry, it's embarassing to be so dumb, but you know. but thanks in advance for putting up with me :)



if i'm too much hard work, ok - i'll stick with vent for now :|

Link to comment
Share on other sites

  • Administrators

Superuser is the hardcoded admin account.

You need to set a pw once, so you can log in. Then you can add yourself (registration) as admin and do all further with your account. Or stick with superuser for initial setup – doesn't matter.


If you rented the server from someone else you probably do not have access to the command line, to execute murmur, do you?

Did you rent a mumble server? A vserver??


The -ini param is optional. Just don’t pass it and it will use / create a Murmur.ini in the same folder the executable is in.


If it’s a rented murmur server you don’t have shell access to (and you thus can not set your superuser pw) your hoster will provide it. Ask if you do not have it.

Link to comment
Share on other sites

ok, thanks for your help. i think i must have done something right, because i can now add a channel. however, it says the channel is only temporary - i also can't create more than one. but at least i'm getting somewhere ;)


the server is hosted by instantvchat. i have contacted them about a superuser password too. i do have a control panel on their website, but it's very limited. i'm really not sure where i am with this at the moment, although obviously something isn't right because i can't add permanent channels, or more than one.


thanks again.

Link to comment
Share on other sites

ok thanks for replying again. sorry to be so dumb - last try, then i'll have to stick with vent :(


see this from ACL guide....


"To edit or create a new group, right click on the root channel and click "Edit"


i click on route channel and have no option to edit, only to "Add". as soon as i create a channel, i try add myself in the ACL to allow me to make channels etc. as soon as i close and re-open mumble, my created channel is gone.


i can't even get started with this.

Link to comment
Share on other sites

  • Administrators

You don’t have to switch back.

I’m glad to help. :)

In the end we could still talk via Mumble or use TeamViewer if we do not succeed here at all. :)

 

"To edit or create a new group, right click on the root channel and click "Edit"

i click on route channel and have no option to edit, only to "Add". as soon as i create a channel, i try add myself in the ACL to allow me to make channels etc. as soon as i close and re-open mumble, my created channel is gone.

i can't even get started with this.

 

Then you are NOT logged in as superuser.

You HAVE to get logged in as superuser to start (if your hoster doesn’t do anything custom / specific like setting up a different admin account you can log in to).


So, go back to trying to log in as superuser with your superuser pw.

Your hosters admin interface probably either displays or allows you to set a new superuser PW. Check there.

Link to comment
Share on other sites

thanks for your patience! :)


ok, i had emailed the server host about superuser pass. they didn't reply, however, i noticed a new user in the control panel called superuser! so, i edited and added a pass.


now my problem lies in trying to logon as superuser. the guide says...

-ini -supw


and this is where i fail :? sorry, but that doesn't mean much to me. the only part of it i understand, is to run mumble.exe. i don't have an ini file, so i tried to run the following...


C:\Program Files\Mumble\mumble.exe -supw


it doesn't work. is it something i'm doing wrong? do i need an ini file? or is it something from the server host?


i feel really confident, if i can get past this, to add myself so i can set up channels/users etc, i won't have a problem. your guides are very detailed and informative. i just need to use that superpass so's i can do all those things ;)

Link to comment
Share on other sites

  • Administrators

-ini -supw

Note it's murmur and not mumble.

Murmur is the server.

You're not setting up a server yourself, thus the Running Murmur guide is not for you.

You just want to join and administrate it.

Just log in with your client.

Run it, add a new server and connect with username SuperUser. It will ask you for the PW.

Link to comment
Share on other sites

you'll be relieved to hear, i finally did it! :D


i had to read you're previous post a couple of times to understand what it was i was doing ;) so happy i'm finally there. now, i have to get to grips with ACL and groups. i'll get around to that when i introduce more users. i think the guides are all i need now, i also saw some good video's on youtube. if you know of any video's too, please do let me know.


thanks so much for being so patient with me! i'm now officially a happy mumble user :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...