Jump to content
Mumble forums

"wrong password for registered users"


memoi2001
 Share

Recommended Posts

Hi


Before you roll your eyes at me, let me assure you that I've done the whole murmurd -ini /etc/murmur/murmur.ini -supw , registered a user ect...


To be frank I've been searching the web for the past three weeks to find a solution, reinstalled pretty much everything but still without joy.


The setup:

Gentoo server running murmur 1.2.2

OSX client (snow leopard) running mumble 1.2.2


I've followed the murmurguide to the letter but when I try to log in as SuperUser (with the password I set on the server, checked that) I get the (in)famous "wrong password for registered users"


When I set the server up it worked without troubles but then I updated the server from 1.1 to 1.2.2 (or something, it was a while ago)


Any clues? Is there a cert somewhere that needs to be deleted?

I did delete mumble from my client but when I reinstalled it had kept my preferences so I guess I missed a file or two.

Link to comment
Share on other sites

  • Administrators

wrong password for registered users

Is that really plural?

Client or server error (log)?


So, do you have issues logging in as SuperUser or as a previously registered user?

Or both?


So you’re having problems with your converted DB?

Did you try moving/renaming it (the sqlite db) -> running a fresh server?


Did you set a new superuser pw via -supw newpw before trying to log in as user(name) superuser or was that prior to updating?

Link to comment
Share on other sites

wrong password for registered users

Is that really plural?

Client or server error (log)?


> Plural, exact text is "Wrong password for registered users, please try again"

> (client log says [12:15 AM] Server connection rejected: Wrong password for user.)

> server log is:

<W>2010-11-24 00:12:43.880 1 => <3:(-1)> New connection: 192.168.0.2:52207
<W>2010-11-24 00:12:43.963 1 => <3:(-1)> Client version 1.2.2 (OSX: 1.2.2)
<W>2010-11-24 00:12:43.966 1 => <3:SuperUser(-1)> Rejected connection: Wrong password for user
<W>2010-11-24 00:12:43.969 1 => <3:SuperUser(-1)> Connection closed:  [-1]

 

So, do you have issues logging in as SuperUser or as a previously registered user?

Or both?


>The previously registered users work OK and can create temporary chans, the SuperUser seems to be a lost cause


So you’re having problems with your converted DB?

Did you try moving/renaming it (the sqlite db) -> running a fresh server?


>Server side I've deleted murmur, deleted all related files and done a fresh installation, same thing


Did you set a new superuser pw via -supw newpw before trying to log in as user(name) superuser or was that prior to updating?


> Tried logging in without resetting the SuperUser password and when I got the error message thought I must have forgotten it so I changed it then

Link to comment
Share on other sites

  • Administrators

2010-11-24 00:12:43.966 1 => <3:SuperUser(-1)> Rejected connection: Wrong password for user

So you are logging in with the correct user but the provided pw does not match the stored one.


(After setting your supw), what is the last modified timestamp of your murmur.sqlite?

I suspect missing file perms!?

Check those and make sure murmur executing user has write perms.

You could also try updating your user comment or avatar, if you can, logged in as a user.

Link to comment
Share on other sites

  • Administrators

No.

For Murmur, registrations certificates are stored in the sqlite.

But, no certificate is stored for the SuperUser account, obviously.

Thus, certificates are not the issue.

This is proved by the invalid password for account SuperUser log entry of murmur you posted above.


You set a new superuser pw and the sqlite was changed / modified. This indicates setting the pw also succeeded.


You then log in with your client and again, your murmur log says you are logging in as SuperUser but with a wrong pw.


So …

Either you are not using the new superuser pw,

or you do not set it correctly.

You could post your command for setting it here (with a temporary pw you can disclose) and / or check your sqlite (with an appropriate viewer / GUI) that the correct superuser pw is indeed changed. You could then also check the md5 checksum manually, if it is indeed the one you set and use.


You are using only 1 Mumble server, right?

I do hope you do not host multiple servers with murmur and log in to one the pw was not set.

Link to comment
Share on other sites

Hmmmm...


I just reset the SuperUser password using "murmurd -ini /etc/murmur/murmur.ini -supw debugtestpassword" and tried it and know it works..


I haven't changed anything but the password, and I must admit I may be intruiged as to why, but as long as it works..


Thanks for you help, and if you do figure out why my original password wouldn't work let me know.

Could it be special characters?


(Off to change that password now I've put it on the net...)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...