Jump to content
Mumble forums

Superuser access.


darksmiler
 Share

Recommended Posts

Hi I'm new to Mumble and have had a look for an answer here and in the instructions but am still having trouble.


I have purchased a 25 slot Mumble server from mumblehosts and I'm running OSX 10.6.5.


Edit:


I was reading Becoming Administrator and Registering a User

and got as far as step 5 which is where I got lost. 'When you are connected to the server, right click on your username, and then click "Register" - if you do not see this option, ensure that you have an @all ACL that has "Register Self" set to Allow, Applies to sub-channels unchecked'.


I do not see the Register option but I don't understand the solution it advises, what is '@all ACL'?

Link to comment
Share on other sites

  • 3 weeks later...

Hi,



I have read about setting up the server on Ubuntu, but I cnnot log in as SuperUser. However, the customised packed for Ubuntu is rather shortsighted. Let me detail:


It seems that all admin should be done via the wrapper. This refuses to be run as root, so this means that one has to run it as the mumble-server account that is added during the install on Ubuntu (apt-get install mumble-server).


One small problem. One cannot su to the account as the shell is set to /bin/false.

mumble-server:x:125:133::/var/lib/mumble-server:/bin/false


the result is:

#  murmur-user-wrapper -p fred
You should never run this script as root. If you want a system-wide install, see 

I changed the shell to /bin/bash on mine and then su'ed to the account. It would be better to change the wrapper to run the commands as the mumble-server user, instead of having the user to su to the account first.


Next step to add the SuperUser account and restart Mumble-server

mumble-server@1234:~$ murmur-user-wrapper -p fred
Making /var/lib/mumble-server/murmur
Creating /var/lib/mumble-server/murmur/murmur.ini
Setting superuser password to "fred"
Initializing settings from /var/lib/mumble-server/murmur/murmur.ini (basepath /var/lib/mumble-server/murmur)
SSL: Added CA certificates from '/etc/ssl/certs/ca-certificates.crt'
ServerDB: Openend SQLite database /var/lib/mumble-server/murmur/murmur.sqlite
Generating new tables...
Superuser password set on server 1
mumble-server@1234:~$ logout
root@AMS-L0769L:~# /etc/init.d/mumble-server restart

 

This looks good, but I cannot connect as SuperUser - On the client I used Connect / Edit (log in as SuperUser), but got the message: Wrong password for registered users.


Bit strange: What gives?



Regards.


P.S

-rw-r--r-- 1 mumble-server mumble-server 4796 2010-12-20 16:36 /var/lib/mumble-server/murmur/murmur.ini

# Password to join server

serverpassword=

This is blank so any one should be able to access it. It was set to 1234, but when I run the wrapper it removed the setting. Strange.

Link to comment
Share on other sites

  • Administrators

http://packages.ubuntu.com/maverick/sound/mumble-server

The package is maintained by "Ubuntu MOTU Developers". Link to mailing list on that page. Also a link to asking a question ( https://answers.launchpad.net/ubuntu/+source/mumble/+addquestion ) and for filing reports.

/etc should be the config. /var/lib is probably a policy for ubuntu packages that place default config files there? (dunno)


I have no idea which wrapper you're talking about.


After setting the useruser pw and using the correct address and "SuperUser" as username you should be able to log in.

Are you connecting to the correct address? Maybe 2 processes of murmur are running? Or 2 virtual servers, where you set the supw for s1 but connect to s2?

Link to comment
Share on other sites

When I look at the scripts provided by the Ubuntu packages it seems that you are mixing two setups.


The murmur-user-wrapper is used when you want to run a murmur server as a standard user. It will make an new murmur map in the users home directory in which all the files for the server will be placed. So do not run this from the mumble-server user, as this user is used for the mumble-server service.


The mumble-server that is started with /etc/init.d/mumble-server will used the file in /etc/mumble-server.ini for the configuration. This configuration file will point to /var/lib/mumble-server/mumble-server.sqlite for the dataset, which is different from the one you have generated with murmur-user-wrapper, so that is why the SuperUser password does not work. To fix the problem you could stop the service, copy in /var/lib/mumble-server/ the murmur/murmur.sqlite to mumble-server.sqlite, and start the service again.

Computer specs: AMD FX-8320, 8GB DDR3-SDRAM, AMD Radeon HD 7950, Asus Xonar D1, Windows 7 Ultimate 64bit/Debian Jessie AMD64.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...