Jump to content
Mumble forums

[Fixed]Upgrade 1.2.2 -> 1.2.3 troubleshooting


lienju
 Share

Recommended Posts

Hi,


Thanks for the RC1 release. I have actually a mumble-server mounted on my dedicated server with 4 murmur virtualservers. I'm on debian lenny. When i upgraded my server 1.2.1 to 1.2.2 I followed this instructions : http://mumble.sourceforge.net/Ice ; so I stopped the server, chmod & remplace murmur.x86 to /usr/sbin/murmurd, remplace Murmur.ice. I backup my bdd.sqlite and restart the server to generate default database with the new 1.2.2 server. Then, I remplace my database.backup to the default database, force reload and works.


However, doesn't work for the 1.2.3 update. I remplaced the ini file to /etc/mumble-server.ini murmurx86, murmur.ice and when i start the server I get this errors :

 

Renaming old tables...
<F>2010-12-06 08:02:49.880 SQL Prepare Error [ALTER TABLE `servers` RENAME TO `servers_old`]: there is already another table or index with this name: servers_old Unable to execute statement

 

and apache2 down. When i check my logs :

 

PHP Fatal error:  Unable to start ice module in Unknown on line 0
/var/lib/mumble-server/Murmur.ice:9: No include path in which to find Ice/SliceChecksumDict.ice
PHP Fatal error:  Unable to start ice module in Unknown on line 0

 

I have really need some help from you.


Thanks in advance,


Lienju, Nantes ( France ).

Edited by lienju
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...